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Copyright 2008 Washington University 
Permission to use, copy, modify, and distribute this document solely for non-commercial 
applications is hereby granted by Washington University free of charge, provided that the 
copyright notice “Copyright 2008 Washington University” appears on all copies of the 
software and that this permission notice appears in all supporting documentation.  The 
name of Washington University or of any of its employees may not be used in advertising 
or publicity pertaining to the software without obtaining prior written permission from 
Washington University. 
 
Washington University makes no representation about the suitability of this software for 
any purpose.  It is provided “as is” without any express or implied warranty. 
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Overview and General Information 
 
Caret5 is a software application for viewing and manipulating surface reconstructions of 
the cerebral and cerebellar cortex, viewing volumes, for displaying experimental data on 
the surfaces and volumes, and performing functional and structural analysis of the 
cerebral cortex. 
 
Visit the Caret web site, http://brainmap.wustl.edu/caret, for more information about 
Caret including downloading the Caret software, downloading data sets, and obtaining 
other tutorials.  You may also use your own data, such as anatomical volumes, functional 
volumes, contours, and surfaces with Caret.  In addition, there is a mailing list for 
obtaining help with Caret. 
 
This tutorial provides an introduction on how to use Caret for data visualization.  It uses a 
small subset of the PALS (Population-Average Landmark- and Surfaces-based) atlas.  
The full PALS atlas and its associated tutorial are available from the Caret website.  
Other tutorials include reconstructing surfaces from contours (drawn with Caret, MDPlot, 
or Neurolucida), reconstructing surfaces by segmenting anatomical volumes, flattening 
surfaces, surface-based registration, and surface-based analysis. 
 
Some conventions in this document 

• All tutorial steps are identified by bullets. 
• Actions the user should take are in italics. 
• User-interface components are in bold characters. 
• Some instructions are streamlined using arrows (e.g. Toolbar->L means press the 

L button in the Toolbar or File Menu->Open Spec File means select the item 
Open Spec File from the File Menu). 

 

Starting Caret5  
• Microsoft Windows users should double-click the Caret icon on the desktop to 

start Caret. 
• Mac OSX users should click the Caret icon in the dock to start Caret. 
• Linux users should enter caret5 and press the return key in a shell to start Caret. 

 

Opening a Spec File 
A Specification File (commonly called “Spec File”) is a file used by Caret to organize a 
set of files (such as volume, coordinate, and topology files).  Typically a Spec File 
contains a list of filenames associated with a single subject’s right or left cortical 
hemisphere along with some metadata. 

• Select File Menu->Open Spec File to display the Choose Spec File Dialog for 
opening a Spec File (If Caret is started from a terminal window, this step may not 
be necessary).  The Choose Spec File Dialog is a file selection dialog used to 
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select the Spec File that is to be opened.  To go into a folder, double-click the 
folder icon next to the name of the folder.  To move up one directory (into the 
parent directory) press the folder icon containing an arrow located in the top right 
corner of the Choose Spec File Dialog. 

• Use the Choose Spec File Dialog to find and open the Spec File named 
PALS_B12.RIGHT.MCW_2008_06.73730.spec which results in the Spec File 
Dialog being displayed. 

• On the Spec File Dialog, press the Select All button, located at the bottom of the 
dialog, to select all of the data files. 

• If the Metric button along the top of the Spec File Dialog is enabled, click it and 
uncheck any metric files that are listed.  This will only be necessary if this tutorial 
was previously run using these data files. 

• Press the Load button.  It may take a minute or so to load the data files after 
which the Spec File Dialog will automatically close.  

 

 
Figure 1 - The Spec File Dialog 

The Caret5 Main Window 
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The Main Window is shown in Figure 2.  The Toolbar contains frequently used controls 
in its top row and the Model Selection Control is below the Toolbar.  At the bottom of the 
Main Window is the Statusbar that displays the functions of the mouse buttons.  

• Drag the Main Window to the upper-left corner of the screen to create available 
space for Caret’s other windows. 

• Slowly move the mouse cursor over the Toolbar.  As the mouse cursor moves 
over a control, a Tooltip pops up describing the function of the control. 

• Move the mouse cursor over the Model Selection Control and hold down the 
left mouse button.  A menu is displayed listing all brain models (contours, 
surfaces, and volume) that are loaded in Caret. 

 
Figure 2 - The Main Window Displaying Surface 
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Getting Help 
• Select Caret Help from the Help Menu.  The Caret Help Window provides 

brief descriptions of each item on the menus and some of the other tutorials.  
Press the Close button on the Caret Help Window. 

• Select Caret Tips from the Help Menu.  Use the Previous and Next buttons to 
view tips.  Press the Close button when finished. 

• Select Go To Caret Web Site from the Help Menu to display the Caret web page 
in your browser. 

 

Visualizing Surfaces 
Currently displayed in the Main Window is the FIDUCIAL surface (“fiducial” is defined 
in the dictionary as a “standard of reference” and, in Caret’s case, typically indicates an 
anatomically accurate representation of the cerebral cortex).  In most cases, the fiducial 
surface is that of an individual.  However, the fiducial surface used in this tutorial is an 
average of twelve individuals which accounts for its appearance.  

• In the Toolbar, press each of the standard view buttons (M, L, etc.) to see how 
they operate. 

• Use the Model Selection Control to select the INFLATED surface and then 
select the FLAT surface. 

• Use the Model Selection Control to return to the FIDUCIAL surface and press 
the Toolbar:L button for a lateral view. 

• From the Window Menu (located towards the right side of the menubar), select 
Viewing Window 2 which contains a dorsal view of the FIDUCIAL surface. 

• Enlarge View Window 2 by selecting its lower right corner and dragging the 
mouse. 

• Use the Model Selection Control in Viewing Window 2 to display the 
INFLATED surface. 

• Press the Toolbar:L button on Viewing Window 2 to place the INFLATED 
surface in a lateral view. 
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Figure 3 - Viewing Window 2 
 

• Move the mouse into the Main Window, hold down the left mouse button and 
move the mouse to rotate the FIDUCIAL surface.  Do the same in Viewing 
Window 2 and notice that the surfaces rotate independently. 

• Press the Yoke button in Viewing Window 2’s Toolbar.  Now rotate the surface 
in either window and notice that the views of the surfaces are synchronized. 

• Deselect the Yoke button in Viewing Window 2 and use the Model Selection 
Control to switch to the FLAT surface. 

• Click the left mouse button over the FIDUCIAL surface which pops-up the 
Identification Dialog.  Drag the Identification Dialog off of the Main and 
Viewing Window.  Notice that a green symbol is placed at the location of the 
mouse click on the FIDUCIAL surface and also at the corresponding location on 
the FLAT surface in Viewing Window 2.  Click on additional locations on both 
the FIDUCIAL and FLAT surfaces as desired. 

• Press the CID button in the Identify Window’s Toolbar to remove the green 
identification symbols from the surfaces. 

 

Visualizing Volumes 
The volume file used in this tutorial is an average of twelve individuals, and, as a result, 
the volume has a blurry appearance. 

• Use the Main Window’s Model Selection Control to display VOLUME.  You 
will notice changes in the Toolbar as controls used for surface manipulation are 
replaced by those used for volume manipulation.  Slowly move the mouse over the 
controls in the Toolbar to see tooltips describing their functions. 

• Press the Toolbar:R button to reset to a default view of a volume.  Note that the 
lines of the cursor intersect at the Anterior Commissure.  This location 
corresponds to the origin of the volume’s stereotaxic coordinate system, which, in 
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this volume’s case, is in Washington University’s 711-2P version of the Talairach 
Space. 

• Press the up and down arrows in the rightmost Slice Control (to the left of the 
Toolbar’s D/C button) to change the displayed horizontal slice. 

• Press the mouse over the Slice Axis Control, currently labeled [H (XY)], to 
switch to a coronal view [C (XZ)] and then a parasaggital view [P (YZ)]. 

• Return to a horizontal view [H (XY)] and press the R button reset the volume to 
its stereotaxic origin. 

 
Figure 4 - Main Window Displaying Volume 

Surface-Volume Comparisons 
• Click the mouse over a voxel in the Main Window’s Volume.  Notice that in 

Viewing Window 2, containing the surface, a set of axes are briefly displayed 
and a green symbol is shown at the surface location corresponding to the voxel 
identified in the Main Window. 
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• Click the mouse over the surface in Viewing Window 2 and notice how the 
crosshairs over the VOLUME in the Main Window move to the location in the 
volume corresponding to the identified location on the surface. 

 

Using the Display Control Window 
The Display Control Window is frequently used in Caret.  Both surfaces and volumes 
may be colored with multiple “layers” of data, such as functional data over anatomical 
data.  The Display Control’s available pages vary with the types of data loaded into 
Caret.   

• Use the Main Window’s Model Selection Control to display the INFLATED 
surface. 

• Press the Main Window Toolbar’s D/C button to display the Display Control 
Window.  Drag the Display Control off of the Main Window. 

 
Figure 5 - The Display Control 
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Viewing Paint Surface Data 
The Surface Attributes section of the Display Control’s Overlay/Underlay – Surface 
page contains columns named Primary Overlay, Secondary Overlay, Underlay, and 
Coloring and rows for each of the different types of surface-based data.  To choose a 
type of surface-based data for display as an overlay or underlay, select the radio button 
where the data and overlay/underlay columns intersect.  Most types of surface-based data 
allow the loading “columns” of that data type and may be selected by the control in the 
right side of the data type’s row. 

• In the Primary Overlay set the Data Type to Paint.  The first Paint column, 
Brodmann, results in the surface coloring reflecting the cortical areas identified 
by Brodmann many years ago. 

• Press Main Window: Toolbar: L to place the surface into a lateral view. 
• Click the mouse over some of the areas on the surface and in the Identify 

Window, the corresponding Brodmann area will listed (it may be necessary to 
scroll up and look for a line of text that begins with Paint). 

• On the Display Control Dialog, use Page Selection to display the Paint Main 
page. 

• On the Paint Main page, press the Display Color Key button.  The Color Key 
displays the colors corresponding to each of the Brodmann areas.  Click one of the 
colored rectangles (such as the one left of Brodmann.1) and the area of the 
surface that makes up that Brodmann area will be highlighted in green.  Click the 
color rectangle again to remove the surface highlighting.  Press the Close button 
on the Paint Color Key Dialog. 

• Return to the Overlay/Underlay – Surface page of the Display Control by using 
the Page Selection control at the top of the Display Control Dialog.   

• In the Primary Overlay section, set the Display Column to Visuotopic.   
• Rotate the surface to see how the different areas, mostly in the occipital lobe are 

colored. 
• In the Main Window, select the FLAT surface using the Model Selection 

Control to see the Visuotopic areas on the FLAT surface. 

 
Figure 6 - Brodmann Areas 
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Figure 7 - Visuotopic Areas 

Map a Functional Volume to the Surface 
In this part of the tutorial, we will map group fMRI results using the PALS atlas.  The 
volume will be mapped to each of the twelve individuals in the PALS atlas and these 
results will then be averaged.  If we had mapped the volume to an individual’s surface the 
results would be biased by that individual’s anatomy. 

• Select Map Volumes to Surfaces from the Attributes Menu to display the Map 
Volumes to Surfaces Dialog.  This dialog contains a series of pages that are used 
to collect the information necessary to map a functional volume into a metric file 
that may then be displayed on the surface. 

• Verify that the Data Mapping Type is set to Metric (Functional) or Surface 
Shape Data and press the Next button at the bottom of the dialog. 

• In the Volume Thresholding section of the Volume Selection page, check the 
box labeled Enable Entry of Volume Threshold.   

• Press the Add Volumes From Disk button located in the Volume Selection 
section.  In the Choose Volume File Dialog, select the file 
BURTON_04_VibroTactile_SIGHTED+orig.nii.gz file and press the Open 
button. 

• In the Volume Thresholding Dialog, set the Positive to 3.5, the set the Negative 
to –3.5, and press the OK button. 

• Back on the Map Volumes to Surface Dialog, press the Next button at the 
bottom of the Volume Selection page. 

• On the Spec File and Surface Selection Page, press the Map to Spec File With 
Atlas button.  At the top of the Atlas Surface Selection Dialog, click the Select 
button to choose the Output Spec File.  Choose the file 
PALS_B12.RIGHT.MCW_2008_06.73730.spec and press the Open button. 

• Verify that the Space is set to 711-2C, and set the Atlas to “PALS_B12 Multi-
Fid Map RIGHT hemisphere…”.  Caret supports mapping human functional 
volume to other stereotaxic spaces such as AFNI, SPM, FLIRT, and others.  711-
2C is a stereotaxic space used at Washington University that is roughly equivalent 
to the Talairach Space. 

• Verify that the first two Multi-Fiducial Mapping Metric Output checkboxes are 
selected.  Show Mapping to Average Fiducial Surface results in the volume 
being mapped to the Average Fiducial surface you have used in this tutorial.  
Show Average of Mapping to All Multi-Fiducial Cases results in the volume 
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being mapped to the twelve individuals that make up the PALS Atlas and then the 
average of the twelve mappings is output. 

• Press the OK button on the Atlas Surface Selection Dialog. 
• Press the Next button at the bottom of the Spec File and Surface Selection page. 
• In the text box to the right of the button labeled Data File, replace the text box’s 

content by typing in the following name, 
Burton_Mapped_to_PALS.RIGHT.73730.metric. 

• Press the Next button at the bottom of the Data File Naming page. 
• Press the Next button at the bottom of the Mapping Algorithm page. 
• The Summary page shows how the data will be mapped.  Press the Finish button 

to begin the process that may take several minutes. 
• Press the Close button on the Map Volumes To Surfaces Dialog. 
• Press the Spec button in the Main Window’s Toolbar to display a version of the 

Specification Dialog used to quickly load data files.  Press the Metric button to 
see the available metric files.  Press the Open button next to the metric file you 
just created (Burton_Mapped_to_PALS.RIGHT.73730.metric) by mapping the 
functional volume to the surface.  Press the OK button on the Choose Columns 
to Load Dialog to complete loading of the metric file. 

 

Viewing Functional Data on the Surface 
• Select INFLATED from the Main Window’s Model Selection Control. 
• In the Main Window, place the INFLATED surface in a lateral view using by 

pressing Toolbar:L. 
• On the Display Control Dialog’s Overlay/Underlay – Surface page, set the 

Primary Overlay Data Type to Metric. 
• Change the Display Control’s Page Selection to Metric Settings. 
• In the Threshold Adjustment section change the Threshold Type to Column to 

remove insignificant activations.  The Threshold Section is near the bottom of 
the dialog and it may be necessary to scroll down 

• Return to the Display Control Dialog’s Overlay/Underlay – Surface page.   
• In the Primary Overlay section, change the Display Column from AFM RIGHT 

to MFM right.   
AFM RIGHT contains the results of mapping the functional volume to the Fiducial 
surface that is an average of the fiducial surfaces of twelve individuals (referred to as 
Average Fiducial Mapping).  MFM RIGHT is the result of mapping the functional 
volume to twelve individual surfaces and then averaging those results (referred to as 
Multi Fiducial Mapping). 
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Figure 8 - Functional On Surface     

 
Figure 9 - Functional on Volume 

Viewing Functional Data on the Volume 
• If Viewing Window 2 is not open, display it using the Window Menu. 
• Use the Model Selection Control on Viewing Window 2 to display VOLUME. 
• Use the Page Selection Control at the top of the Display Control Window to 

display Overlay/Underlay – Volume. 
• Set the Primary Overlay to Functional View. 
• In Viewing Window 2, select a yellow activation in the right hemisphere and 

notice that the corresponding activation is selected on the Main Window’s 
INFLATED surface. 

 

Viewing Borders 
• Use the Main Window’s Model Selection Control to display the INFLATED 

surface in the Main Window.  Press Toolbar:L to place the inflated surface into 
a lateral view. 

• Use the Page Selection Control on the Display Control Dialog to display the 
Border Main page. 
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• Select Show Borders at the top of the page. 
• Use the Page Selection Control to display the Border Color Page. 
• Press the All Off button to deselect all colors for display. 
• Select Brodmann to show borders around the Brodmann areas over the functional 

data you mapped. 
•  Click the mouse over a border and Caret will identify the border(s) under the 

mouse. 

 
Figure 10 - Borders on Inflated Surface 

• On the Display Control, use the Page Selection Control to return to the Border 
Main page and uncheck the Show Borders checkbox so that borders are no 
longer displayed. 

• Switch to the Overlay/Underlay – Surface page on the Display Control Dialog. 
• Set the Primary Overlay Data Type to None. 
• Select CID on the Identify Window to remove any green ID symbols from the 

surface. 
 

Viewing Activation Foci 
In many articles that report the results of functional neuro-imaging studies, the three-
dimensional coordinates of significant activations are reported in a table.  Caret can 
display this type of data as foci. 
 
Up to this point in the tutorial, you have made many selections in the user-interface to 
display the desired data.  To introduce you to foci, we will use Caret’s “Scene” 
capability.  A Caret scene saves current “state” of Caret.  That is, the names of all loaded 
data files, the contents of the Main Window and Viewing Windows, and all settings on 
the Display Control Dialog.  Scenes are useful for quickly reproducing a complex set of 
Display Control settings that were made to for a specific presentation of data.  In 
addition, it makes it easy for other users to view your data. 

• Use the Page Selection Control on the Display Control Dialog to display the 
Scene page. 

• Either double-click 1.Foci All or select 1.Foci All and press the Show Selected 
Scene button.  Many foci are displayed as small spheres. 
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Figure 11 - Foci on Surface 

• Click the mouse over a focus.  Information about the focus and related study is 
displayed in the Identify Window. 

• In the Foci Color Key Dialog, click the mouse over the orange colored 
rectangle next to the name Bushara_JN01.  Notice that the corresponding foci 
are highlighted as much larger spheres.  Click the orange colored rectangle again 
to reset the foci back to their original size. 

• In the Foci Color Key Dialog, click the mouse over the name Bushara_JN01.  
Information about the Bushara et.al. study appears in the Identify Window. 

• In the Identify Window, click the mouse over the blue hyperlink next to Study 
PubMed URL which results in the abstract for the article appearing in the web 
browser. 

• Return to the Display Control Dialog’s Scene page and select the scene 2. 
Bushara Foci by either double-clicking 2. Bushara Foci or clicking 2. Bushara 
Foci once and pressing the Show Selected Scene button.  Notice that only the 
associated with the Bushara et. al. study are displayed.  Use the Main Window’s 
Model Selection Control to view the FLAT surface and notice that the foci 
maintain their position relative to the surface. 

• Display scene 3. Face Foci by double-clicking it to see only foci that are 
associated with facial recognition. 

 
Figure 12  - Facial Recognition Foci on Surface 
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SuMS (Surface Management System) Database and 
WebCaret 
The SuMS Database is a repository of brain mapping data from many laboratories.  This 
data may be downloaded or viewed on-line in a web browser with WebCaret. 
 

• Select Go To SuMS Database Web Site from the Help Menu and the SuMS 
Database web page (http://sumsdb.wustl.edu/sums/index.jsp) will appear in your 
web browser. 

• Click the image of cortical models below Human PALS Atlas.  A new window 
will pop up and, after a minute or so, a surface or volume model will appear. 

 
Figure 13 - SuMS PALS Atlas Selection in Web Browser 

• Near the top of the browser window is a control for selecting scenes.  Use the 
mouse to select other scenes. 



 18 

 
Figure 14 - Web Caret Surface View 

---------- END OF TUTORIAL ---------- 


