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Copyright 2007, Washington University 
Permission to use, copy, modify, and distribute this document solely for non-
commercial applications is hereby granted by Washington University free of 
charge, provided that the copyright notice "Copyright 2007 Washington 
University" appears on all copies of the software and that this permission notice 
appears in all supporting documentation. The name of Washington University or 
of any of its employees may not be used in advertising or publicity pertaining to 
the software without obtaining prior written permission from Washington 
University. 
  
Washington University makes no representation about the suitability of this 
software for any purpose. It is provided "as is" without any express or implied 
warranty. 
  
Introduction 
 
Caret (Computerized Anatomical Reconstruction and Editing Toolkit) is a software 
application developed by the Van Essen lab for a variety of brain-mapping and 
neuroimaging purposes.  This tutorial aims to help Caret users in reconstructing Caret 
surfaces from section contours.  These contours may be drawn in Caret or imported from 
another program such as MDPlot. 
 
This tutorial requires Caret version 5.502 or later. 
 
This tutorial contains three main sections in addition to this introduction. 
 
PART 1.  Drawing and editing contours in Caret. 
PART 2.  Reconstructing and flattening a partial hemisphere created from contours. 
PART 3.  Reconstructing and flattening a full hemisphere created from contours. 
 
Conventions – Tutorial text.  Awarness of the following conventions will facilitate 
navigation of this tutorial. 

• Each tutorial action step is identified by a bullet. 
• Actions the user should take are in italics. 
• User-interface components are in bold. 

 
Access to data sets.  The data set is freely available in SumsDB 
(http://sumsdb.wustl.edu:8081/sums/archivelist.do?archive_id=6654710&archive_name=
caret5_contours_tutorial.zip).  On the SuMS page to the left of 
caret5_contours_tutorial.zip, change the “Single File Action” pop-up menu to 
“Download” to download the tutorial data set.  
 
Downloading and installing Caret software.  If Caret 5.51 is not already installed on 
your computer, visit the Caret website 
(http://brainmap.wustl.edu/resources/caretnew.html).  Installation instructions are 
available from the download page. 
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Additional Caret Tutorials.  Other tutorials are available on the Caret website 
(http://brainmap.wustl.edu/resources/caretnew.html). 
 
Citing atlas and software.  If you publish or give scientific presentations on work that 
capitalizes on Caret, SumsDB, and/or the associated data, please give appropriate 
acknowledgement (http://sumsdb.wustl.edu/sums/html/links/citing.html). 
 
 
Suggestions welcome!  Corrections, bug reports, requests for additional explanations, etc. 
should be sent to the Caret-Users mailing list.  For details, see 
http://brainmap.wustl.edu/mailman/listinfo/caret-users. 
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Part I – Drawing and Editing Contours in 
Caret 
 
This part of the tutorial illustrates a general method for reconstructing surfaces from brain 
sections.  Typically, the input data are photomicrographs or drawings of a series of 
closely spaced histological sections through part or all of a hemisphere.  The optimal 
section spacing is about half the thickness of the cortical sheet. (i.e., about 0.5 mm for the 
macaque and 1 to 1.5 mm for human cerebral cortex).  Greater spacing can be tolerated, 
as long as the shape changes from one section to the next are relatively modest. 
 
The data set for this part of the tutorial is based on section drawings from the right 
hemisphere frontal lobe, taken from a stereotaxic atlas of the macaque (Paxinos, Huang 
& Toga, 2000), which will be referred to as PHT00 in various instances.   
 
Importing Contours From MDPlot 
 
If the user has set of contours that were created in MDPlot, Caret is able to import 
MDPlot object (.mdo) files.  Use the File Menu->Import File menu item to import the 
MDPlot contours.  Lines in the file are converted to contours and points in the file are 
converted to contour cells. 
 
Importing Contours from MicroBrightfield’s Neurolucida 
 
If the user has a set of contours that were created in Neurolucida, Caret is able to import 
files that are in Neurolucida’s XML format.  This XML format was introduced in version 
7.51 of Neurolucida.  Use the File Menu->Import File menu item to import the 
Neurolucida data. 
 
The spatial units in a Neurolucida file are assumed to be microns (10-6) and Caret will 
convert them to millimeters.   
 
The following rules apply to all contours: 

• Contours are assumed to be closed; 
• The name and the color of the contour are ignored; 
• The integer value of the Z coordinate is used as the section number. 

 
The following rules apply to markers that are imported as contour cells: 

• The (symbol) type is ignored. 
• The name is used to name the contour cells. 
• A new color is created using the name of the marker and its specified color. 

 
Requirements for sections that must be met for successful reconstruction 

• Each contour must be closed.  Think of a closed contour as a fence enclosing a 
prison.   



 8 

• Each contour must consist of only one contour.  Several contours chained together 
are not acceptable. 

• There can be only one boundary.  In other words, the contours could represent the 
gray/csf boundary or the white/csf boundary but NOT both. 

• The spacing between each consecutive pair (1 and 2, 7 and 8, etc.) of section 
numbers must be the same.  

• It is okay to skip sections.  In other words the sections do not have to be 
consecutive numbers. 

• A section may have multiple contours.  However, the contours within a single 
section must not overlap other contours in the section.  In addition a contour may 
not intersect itself. 

 
By the end of this tutorial, the user should know how to: 

• Load images of section drawings into Caret; 
• Draw contours that represent the shape of the cortex in each section; 
• Edit contours; 
• Mark the location of experimental data (e.g., architectonic subdivisions) in each 

section and assign appropriate labels; 
• Align sections relative to one another; 
• Reconstruct a surface from a set of aligned contours; 
• Project experimental data onto the surface; 
• Inflate the surface and generate a flat map; 
• Draw borders around identified subdivisions; 
• Paint the regions that are enclosed within each border. 

 
The first part of this tutorial demonstrates the drawing of contours on four sections, 84, 
87, 89 and 92, from the atlas.  Images of additional sections may be loaded if the user 
desires to draw additional sections.  After learning to draw sections, the tutorial shows the 
user how to reconstruct, inflate, and flatten using a set of sections created by drawing 
contours over all 20 sections that make up a partial hemisphere consisting of the frontal 
lobe.  
 
Drawing Contours, Aligning Contours, and Adding Cells 

• Unzip the tutorial data set.  This will create a subdirectory named 
RECONSTRUCT_SECTIONS.11-2006. 

• Start Caret. 
• Select File Menu->Set Current Directory.  Use this dialog to select the 

CONTOUR_IMAGES subdirectory of the RECONSTRUCT_SECTIONS.11-
2006 directory that was created when the data set was unzipped. 

• Click the mouse in the Main Window to remove the Caret splash image if it is 
still present. 

 
Creating a Contour Set and Loading Images 

• Select Layers Menu->Contours->Create New Contour Set. 
• Select File Menu->Open Image Files.  In the File Dialog, select both of the 

image files (Macaque.PHT00.ATLAS.R.1_2.jpg and 
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Macaque.PHT00.ATLAS.R.3_4.jpg) by holding down the CTRL Key (Apple 
Key on Mac) while clicking the mouse button on the image file names.  Press the 
Open button to load the two image files. 

• When asked “Would you like to create a Spec File?“ press the Yes button. 
• In the Create Spec File Dialog, press the Species button and choose “Macaque”.  

Enter PHT00 for the Subject.  Set the Structure to right.  Set Space to 
Unknown.  Set Category to INDIVIDUAL.  In the Comment text window, enter 
“Reconstructing PHT00 right hemisphere”.  Press the OK button. 

• In the Spec File Name Dialog will be the name of the Spec File.  Accept the 
name in the dialog and press the OK button. 

• Press the D/C button in the Main Window Toolbar to launch the Display 
Control Dialog. 

• On the Display Control Dialog, set the Page Selection to Images. 
• Check the box to the left of Show Image In Main Window. 
• Select the radio button (round button) next to 

Macaque.PHT00.ATLAS.R.1_2.jpg to verify that the image of sections 92 and 
89 are shown in the Main Window. 

 
Preparing to Draw Contours 

• Select Layers Menu->Contours->Set Contour Scale. 
• In the Contour Set Scale Dialog, set the Distance to 10.0. 
• Click the left mouse button over the 20mm mark on the right hand section.  Hold 

down the Shift key and click the left mouse button over the 30mm mark on the 
right hand section. 

• Press the Apply button followed by the Close button on the Contour Set Scale 
Dialog. 

• Select Layers Menu->Contours->Set Contour Section Spacing.  Set the 
Spacing to –0.5mm (negative 0.5) by entering the value or by pressing the 
arrows.  Press OK to close the dialog.  (Note: It is important to set the contour 
spacing as negative (going away from the observer, into the screen) so that the 
reconstruction ends up looking like a right hemisphere, not a left hemisphere.  
The atlas sections are in fact from the right hemisphere, even though the slice 
levels are shown on a left hemisphere drawing). 

 
Drawing Contours 

• Select Layers Menu->Contours->Draw Contours.  Set the Point Spacing to 
0.5mm, set the Section number to 89, and press the Apply button.  Move the 
Contour Drawing Dialog to the side of the Main Window. 

• Move the mouse to the middle of the 10M/10V separator (dashed line).  Hold 
down the left mouse button and move the mouse to draw a contour in a clockwise 
direction running approximately midway through the cortical thickness that 
approximates cortical layer 4 (Figure 1).  When concluding the drawing of the 
contour (the contour is complete with the mouse back at the starting point of the 
contour) release the left mouse button.  Hold down the Shift key and click the left 
mouse button to complete the contour and which time the contour being drawn 
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changes from red to green.  If the contour shape changes significantly verify that 
the scale has been set correctly. 

 

 
Figure 1 - Section 89 
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Figure 2 - Section 89 with Scale_Marks 

• Select Layers Menu->Contours->Select Contour Sections.  In the Sections 
Group, select the Single radio button so that only section 89 is selected. 

• Select File Menu->Open Data File.  Set the File Type to Contour Cell Color 
Files.  Select the file Macaque.PHT00.ATLAS.1_20.contour_cell_color and 
press the Open button. 

• Select Layers Menu->Contours Cells->Add Contour Cells.  Enter 
Scale_Marks for the Name and Stereotaxic for the Class.  Press the Apply 
button.  If the Color Editor Appears, the name is not entered correctly or the 
contour cell color file was not loaded.  Click the mouse over the 20mm scale 
position and again of the 30mm scale position for slice 89 as shown in Figure 2.  
These scale marks will be used when the contours are aligned. 

• In the Contour Drawing Dialog, change the section number to 92.  When the 
section number is changed, the mouse mode will switch to contour drawing 
automatically so it is not necessary to press the Apply button.  Use the mouse to 
draw two small contours over the image of section 92 as show in Figure 3. 

• Press the Apply button on the Add Contour Cells Dialog.  Click the mouse over 
the 20mm and 30mm scale marks in the image for section 92 so that two gray 
squares appear as in Figure 3. 
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Figure 3 - Section 92 With Scale Marks 

 
Figure 4 - Section 92 With Cells 
 
Adding Cells 

• On the Add Contour Cells Dialog, change the Name to PHT00_10, the Class to 
Architectonic, and press the Apply button.  Click the left mouse to add two cells 
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to each of the contours that make up section 92 as show in Figure 4.  The cells 
you add should appear in dark blue. 

• In the Contour Selection Dialog, change the selected Section to 89. 
• In the Add Contour Cells Dialog, change the Name to PHT00_10D and press 

the Apply button.  Add 4 or 5 cells in area 10D as shown in Figure XXX. 
• Change the Name in the Add Contour Cells Dialog to PHT00_10M and press 

the Apply button.  Add 4 to 6 cells in area 10M.  Repeat this step adding cells in 
areas 10V, 46V, and 46D (see Figure 5). 

 

 
Figure 5 - Section 89 with Cells 

• Close both the Contour Drawing and Add Contour Cells Dialogs. 
 
Saving Contour and Contour Cell Files 

• Select File Menu->Save Data File.  On the Save Data File Dialog, set the File 
Type to Contour File.  Change the File Name to 
Macaque.PHT00.R.ATLAS.contours.  Press the Save button to save the file. 

• Select File Menu->Save Data File.  On the Save Data File Dialog, set the File 
Type to Contour Cell File.  Change the File Name to 
Macaque.PHT00.R.ATLAS.contour_cells.  i the Save button. 

 
Aligning Contours Using Scale Marks 

• On the Display Control Dialog, go to the Images Page and uncheck the Show 
Image in Main Window checkbox. 

• Use the Contour Section Selection Dialog to Hide All contours. 
• Select Layers Menu->Contours->Align Contours.  Verify that the Section is set 

to 89.  The cells and the contours in section 89 are displayed in blue. 



 14 

• Hold down the Shift key and in the Main Window, hold down the left mouse 
button and move the mouse to move the contour and its cells so that the bottom 
(20mm) Scale_Mark cell is over the cross in the center of the window.  Once the 
Scale Mark cell is over the cross, press the Apply Alignment button on the 
Contour Alignment Dialog.  See Figure 6. 

 

 
Figure 6 - Aligning Section 89 

• Change the Section in the Contour Alignment Dialog to 92.  Use the mouse to 
place contour 92’s bottom (20mm) Scale_Mark cell over the cross in the center o 
the window and press the Apply Alignment button. 

• Press the Close button on the Contour Alignment Dialog. 
• Select Show All sections on the Contour Section Selection Dialog to see the 

sections after alignment. 
 
Save Aligned Contours and Contour Cells 

• Select File Menu->Save Data File.  On the Save Data File Dialog, set the File 
Type to Contour File.  Select the previously saved file 
Macaque.PHT00.R.ATLAS.contours.  Press the Save button to save the file and 
confirm that you want to overwrite the existing file. 

• Select File Menu->Save Data File.  On the Save Data File Dialog, set the File 
Type to Contour Cell File.  Select the existing file 
Macaque.PHT00.R.ATLAS.contour_cells.  Press the Save button and confirm 
that you want to overwrite the existing file. 

• If desired, use the Display Control’s Image page to switch to the image 
containing sections 84 and 87, draw contours, and add cells. 

 
This concludes the section on how to draw contours, add cells, and align contours.  If 
desired, additional images may be loaded and contours drawn for all 20 sections.  
Otherwise, Part 2 of this tutorial starts with a data set that contains all 20 sections and 
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corresponding cells and demonstrates the steps required to generate and flatten the 
surface. 
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Other Contour Editing Operations 
 

Aligning Contours Without Using Scale Marks 
• On the Contour Section Control Dialog, set the Sections to Hide All. 
• On the Align Contours Dialog, set the section to the first section (in this case, 

section 89).  Hold down the shift key and drag the mouse to place the section at 
the desired location in reference to the cross and press the Apply Alignment 
button.  If the contour needs to be larger or smaller, hold the CTRL key (Apple 
Key on Mac OSX) and move the mouse to adjust the size of the section being 
aligned.  If the section needs to be rotated, hold down the left mouse button 
without using any keyboard keys to rotate the section. 

• On the Contour Section Control, set the Sections to Single and the Section 
Selection to 89. 

• On the Contour Alignment Dialog, set the Section to 92 (colored in blue) and 
adjust section 92 so that it is properly aligned with section 89 (colored in green). 

• Close the Contour Alignment Dialog. 
• Set the Sections on the Contour Section Control Dialog to Show All. 

 

Aligning Part of a Contour 
• Set the Sections to Hide All on the Contour Section Control Dialog. 
• Perform any normal alignment of the entire contour prior to aligning part of the 

contour. 
• On the Contour Alignment Dialog, select section 89.  Press the Select Region 

button.  Place the mouse at the bottom left corner of the region that will be 
selected.  Hold down the left mouse button and move the mouse to select part of 
the contour.  The region is shown in a red box.  When the region has been 
selected, hold down the CTRL button (Apple button on Mac OSX) and click the 
left mouse button.  Use the mouse to align the selected region of the contour.  
When done, press the Apply Alignment button followed by the Clear Region 
button. 

 

Reversing the Order of Points in a Contour 
• Select Layers Menu->Contours->Reverse Contour with Mouse. 
• Click the left mouse button over the contour that should have its point order 

reversed. 
 

Merging Contours 
• On the Display Control Dialog’s Contour and Contour Cells Page, check the 

box next to Show First Point In Each Contour In Red.  
• Select Layers Menu->Contours->Merge Contours.  In this operation the 

contour selected by clicking the left mouse button will have its end point (shown 
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in green) attached to the beginning point (shown in red) of the contour selected 
when the shift key is held down.  In some cases, it may be necessary to reverse 
the order of the points in a contour. 

• Click the left mouse button over the contour whose end point (NOT shown in 
red) will be connected to the red beginning point of another contour.  If you hear a 
beep sound, it means that a contour was not selected. 

• Hold down the shift key and click the left mouse button over the contour that 
will have the contour selected in the previous step to its red beginning point. 

 

Deleting Contours 
• Select Layers Menu->Contours->Delete Contour with Mouse. 
• Click the left mouse button over the contour that you would like deleted. 

  

Deleting Points From a Contour 
• It may be helpful to set the Draw Mode, on the Display Control’s Contours and 

Contour Cells page, to Points.  It may also be helpful to increase the Point Size. 
• Select Layers Menu->Contours->Delete Contour Point with Mouse. 
• Click the left mouse button over contour points that you would like removed. 

 

Moving Points in a Contour 
• It may be helpful to set the Draw Mode, on the Display Control’s Contours and 

Contour Cells page, to Points.  It may also be helpful to increase the Point Size. 
• Select Layers Menu->Contours->Move Contour Point with Mouse. 
• Place the mouse over the contour point that is to be moved.  Hold down the left 

mouse button and drag the mouse in order to move the contour point. 
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Part 2 - Reconstructing and Flattening a 
Partial Hemisphere Created from Contours 
 
The previous section of the tutorial demonstrated how to draw contours, align contours, 
and add cells to contours for a few sections.  Rather than drawing the remaining sections 
of the 20 sections that make up the frontal lobe, these instructions on reconstruction start 
with the 20 sections that make up the frontal lobe.  These 20 sections have already been 
aligned and have architectonic identifications made using contour cells 
 
Open the Files for the Partial Hemisphere 

• Select File Menu->Open Spec File.  In the Choose Spec File Dialog, go into the 
PARTIAL_HEMISPHERE_RECONSTRUCTION directory.  Select the Spec 
File named Macaque.PHT00.ATLAS.R.1_20.CONTOURS.spec file and press 
the Open button.  This spec file contains contours, contour cells, contour cell 
colors, and border colors. 

• In the Spec File Dialog, press the Select All button followed by the Load button.  
If a spec file is currently in memory, a dialog will appear with information about 
Caret’s ability to load multiple spec files, just press the New Spec Only button. 

 
Examine Contours For Problems 

• Press the D/C button in the Main Window Toolbar and select the Contours 
and Contour Cells Page. 

• On the D/C’s Contours and Contour Cells Page, disable the display of cells by 
unchecking the Show Contour Cells checkbox.  Enable the Show First Point in 
Each Contour in Red.  Set the Draw Mode to Points and Lines. 

• If needed, increase the size of the contours by holding down the CTRL key 
(Apple key on Mac OSX), the left mouse button, and pushing the mouse forward. 

• Select Layers Menu->Contours->Select Contour Sections.  Set the Sections to 
Single.  Each contour in the section should be closed (its starting point (shown in 
red) should be close to its ending point (shown in green).  Verify that each contour 
is only one set of points (contains only one red point).  Verify that a contour does 
not intersect itself.  Lastly, if there are multiple contours in a single section verify 
that the contours do not overlay in any way.  Repeat this process for each of the 
sections.  Please note that the contours in this example data set do not have any of 
these problems.  However, if you are using your own contours, it is important to 
check for these problems. 

• Select Layers Menu->Contours->Cleanup Contours.  This option will remove 
any invalid contours (those with less than three points) and any consecutive 
duplicate points in contours.  If these problems are not removed, there may be 
errors in the reconstructed surface. 

 
Reconstruction of Partial Hemisphere Contours into Surface 

• Select Layers Menu->Contours->Reconstruct Into Surface.  A warning dialog 
will appear informing the user about “Clean Up Contour” and potential problems 
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with contours.  Since the current contours do not have any problems, press the 
Proceed with Reconstruction button. 

• In the Contour Reconstruction Dialog, verify that the Structure is right and 
that the Convert Contour Cells option is checked.  Press the OK button to 
reconstruct the contours into a surface.  This operation may take a couple of 
minutes.  After reconstruction completes, the surface is shown in the Main 
Window. 

• Select Surface Menu->Topology->Remove Islands.  There are no islands 
(disconnected pieces of surface) so it will report zero islands removed. 

• Select Surface Menu->Topology->Topology Error Report.  This dialog uses a 
mathematical formula (Euler’s count) to determine if there are any topological 
problems.   

• If there are any errors, a crossover check may help find the location of the 
topological errors.  Select Surface Menu->Measurements->Crossover Check.  
In the dialog that pops up, select Other Type of Surface and press the OK 
button.  If there are crossovers, it may be necessary to edit the contours to fix the 
problems.  There should not be any crossovers is this tutorial data.  If a surface 
generated from your contours has crossovers (shown in red on the surface), click 
the mouse on the crossovers and small green symbols will be shown on the 
surface and on the corresponding locations in the contours. 

 
Save Data Files 

• Select File Menu->Save Data File.  Set the File Type to Topology Files.  Set the 
File Name to Macaque.PHT00.R.CLOSED.topo and press the Save button. 

• Select File Menu->Save Data File.  Set the File Type to Coordinate Files.  Set 
the File Name to Macaque.PHT00.R.RAW.coord.  In the Coordinate Selection 
Group at the bottom of the dialog, set the Save As Type to RAW.  Set the 
Orientation to Left, Inferior, Anterior.  Set the Coord Frame (Stereotaxic 
Space) to Native.  Press the Save button. 

• Select File Menu->Save Data File.  Set the File Type to Section Files.  Set the 
File Name to Macaque.PHT00.R.reconstruction.section.  Press the Save 
button. 

 
Create the Fiducial Surface 

• Select Surface Menu->Geometry->Smoothing.  Set the Smoothing Type to 
Normal Smoothing.  Set the Smoothing Parameters Strength to 1.0 and Edges 
Every X Iterations to 0.  Set the Iterations to 4 for a partial hemisphere that is 
used in this example otherwise set the Iterations to 10 for a full hemisphere.  
Press the Apply button.  After smoothing completes press the Close button.  
Smoothing removes any noise (jagged parts) in the surface. 

• Select File Menu->Save Data File.  Set the File Type to Coordinate Files.  Set 
the Save As Type to FIDUCIAL.  Set the File Name to 
Macaque.PHT00.R.FIDUCIAL.coord.  Press the Save button. 
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View the Sections in the Surface 
• Select Surface->Sections->Section Control.  On the Section Control Dialog, set 

the Sections to Single.  Move either the Low or High Section Selection control to 
see how the section number information is preserved in the surface reconstruction. 

 
Generate Curvature Measurements 

• Select Surface Menu->Measurements->Generate Curvature.  Press the OK 
button in the Generate Curvature Dialog. 

• Select File Menu->Save Data File.  Set the File Type to Surface Shape Files 
and the File Name to Macaque.PHT00.R.curvature.surface_shape.  Press the 
Save button to save the file. 

• On the Display Control’s Overlay/Underlay – Surface page, set the Underlay 
to Shape.  Make sure the Folding (Mean Curvature) column is selected. 

 
Create Cell Projection File 

• On the Display Control Dialog, switch to the Cell page.  Check the box next to 
Show Cells so that the cells are displayed. 

• Select Layers Menu->Cells->Delete Cells Using Mouse.  Click the mouse on all 
of the Scale_Marks cells shown in the foreground color to the left side of the 
surface.  Remember that the Scale_Marks cells were used to align the contours.  
There are a number of Scale_Marks cells, so just keep clicking the mouse over 
them to delete them.   

• Select Layers Menu->Cells->Project Fiducial Cells.  Set the Data For 
Projection to All (no sign flips to match hemisphere).  Set the Spatial 
Projection Type to Keep Offset From Surface.   Press the OK button to project 
the cells. 

• Select File Menu->Save Data File.  Set the File Type to Cell Projection Files.  
Set the File Name to Macaque.PHT00.R.cells.cellproj.  Press the Save button. 

• Select File Menu->Save Data File.  Set the File Type to Cell Color Files.  Set 
the File Name to Macque.PHT00.R.cell_color.  Press the Save button. 

• On the Display Control Dialog’s Cell Page, uncheck the box next to Show Cells 
so that the cells are not displayed. 

 
Create the Inflated Surface 

• Select Surface Menu->Copy Main Window Surface to New Surface to make a 
copy of the fiducial surface. 

• Select Surface Menu->Transform->Translate to Center of Mass. 
• Select Surface Menu->Geometry->Inflate Surface.  Set the Number of 

Smoothing Iterations to 500, Inflate Every X Iterations to 10, and the Inflation 
Factor to 1.02.  Press the Apply button and when completed, several minutes 
later, press the Close button. 

 
Creating the Spherical Surface for a Partial Hemisphere 

• Select Window Menu->Viewing Window 2.  In Viewing Window 2, use the 
Model control in the Toolbar to select the FIDUCIAL surface.  Press the Y 
button in the Toolbar twice so that you are viewing the frontal pole.  Click the 
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mouse over frontal pole as in Figure 7 so that a green identification symbol is 
displayed.  Press the Close button at the bottom of Viewing Window 2 to close 
the window.  Note: This example data set consists of a frontal lobe.  If you are 
using your own data that consists of another lobe, orient the surface appropriately, 
such as using the occipital pole for an occipital lobe. 

 
Figure 7 - Frontal Pole Identified 

  
Figure 8 - Frontal Pole on Sphere 

• Select Surface Menu->Geometry->Convert to Sphere.  Press the R button in 
the Toolbar. 

• In the Main Window, press the View button in the Toolbar.  Rotate the surface 
by holding down the left mouse button and moving the mouse from right to left 
so that the green symbol on the occipital pole is in the center of the window 
Figure 8. 
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• Select Surface->Transform->Apply Current View.  Ensure that both Apply 
Translation and Apply Rotation are selected but that Apply Scaling is not 
selected.  Press the OK button. 

• Select File Menu->Save Data File.  Set the File Type to Coordinate Files.  The 
Coordinate File and Save As Type should be set to SPHERICAL.  Set the File 
Name to Macaque.PHT00.R.SPHERE.coord.  Set the Coordinate Frame to 
Unspecified.  Press the Save button. 

 
Creating the Flat Surface 

• Select Surface Menu->Geometry->Project Sphere to Flat.  Figure 9 

 
Figure 9 - Initial Flat Surface 
   

• In the Main Window, use the Toolbar’s model selection control to switch to the 
FIDUCIAL surface.  If needed, rotate the surface so that the posterior face is 
visible (Figure 10). 

• Click the mouse around the perimeter to place green identification symbols as in 
Figure 11.  Draw the Identify Window to the side if it gets in the way. 
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Figure 10 - Posterior Face 

     
Figure 11 - Posterior Face Identified 

• Switch back to the FLAT surface in the Main Window. 
• Press the View button in the Toolbar, and, if necessary, hold down the CTRL 

Key (Apple Key on Mac OSX), hold down the left mouse button, and move the 
mouse forward to enlarge the flat surface. 

• Select Surface Menu->Cuts->Draw Cuts.  Move the mouse to one of the green 
identification symbols, hold down the left mouse button and drag the mouse to 
create a cut line segment that traces the green identification symbols.  Make sure 
that the end of the cut intersects the line formed by the beginning of the cut.  
When the drawing is complete, click the left mouse button and the cut will turn 
from red to a series of blue points as in Figure 12. 
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Figure 12 - Cut Drawn on Initial Flat 
   
 

• Select Surface Menu->Cuts->Apply All Cuts so the Main Window appears as 
in Figure 13. 

 
Figure 13 - Cut Applied 
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Figure 14 - Islands Removed 
 

• Select Surface Menu->Topology->Remove Islands so that the Main Window 
appears as in Figure 14.  If the part of the surface outside the cut does not 
disappear, draw an additional cut or cuts to completely separate the two pieces of 
surface. 

• Select File Menu->Save Data File.  Set the File Type to Topology Files.  Set the 
File Name to Macaque.PHT00.R.CUT.topo and press the Save button. 

• Select File Menu->Cuts->Delete All Cuts.  Click the Yes button on the 
confirmation dialog. 

• Select File Menu->Save Data File.  Set the File Type to Coordinate Files.  Set 
the File Name to Macaque.PHT00.R.InitialFlat.coord and press the Save 
button. 

• Select File Menu->Morphing->Multiresolution Morphing Flat Surface.  Set 
the Cycles to 2 and press the Run button.  This operation will take several 
minutes to complete.  Press the Close button on the Flat Morphing 
Measurements Dialog.  The surface should appear as in Figure 15. 

• Select File Menu->Save Data File. Set the File Type to Coordinate Files.  Set 
the File Name to Macaque.PHT00.R.FlatFinale.coord and press the Save 
button. 
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Figure 15 - Final Flat Surface 
 
Creating Borders and Paint Labels for Architectonic Areas 

• On the Display Control’s Cell Page, enable the display of cells by checking the 
box on the left side of Show Cells.  The cells are displayed on the surface as 
shown in Figure 16. 

 
Figure 16 - Cells on Flat Surface 
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Figure 17 - Flat with PHT00_10D Cells 

• Press the Color tab on the Display Control’s Cell Page. 
• Press the All Off button and then check the box next to PHT00_10D so that the 

surface appears as in Figure 17 with only the PHT00_10D cells displayed. 
• Select Layers Menu->Borders-Draw Borders. 
• On the Draw Borders Dialog, set the Name to PHT00_10D, the Type to Closed, 

Dimensions to 2D.  Check the box next to Assign Paint Identifiers to Nodes 
With Border.  For Paint Column, select Create New Column and enter PHT00 
in the text box on the right of Create New Column.  Press the Apply button.  
When asked Matching Area Color “PHT00_10D” not found, press the Use 
Border Color button. 

• Use the mouse to draw a border around the PHT00_10D cells.  Move the mouse 
to just outside on of the cells, hold down the left mouse button and move the 
mouse to draw the border around the cells.  When the border is complete, release 
the left mouse button, hold down the Shift key and click the left mouse button.  
The border color should change from red to blue.   

• On the Display Control’s Border page, change Draw Borders As Points to 
Draw Borders as Points and Lines.  The border should appear as in Figure 18. 
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Figure 18 - Border Around Cells 

   
Figure 19 - Paint ID of PHT00_10D 

• Turn off the display of borders by unchecking the Show Borders checkbox on the 
Display Control’s Border page. 

• Turn off the display of cells by unchecking the Show Cells checkbox on the 
Display Control’s Cell page. 

• Go the Overlay/Underlay Surface Page on the Display Control Dialog.  Set the 
Primary Overlay to Paint and make sure the PHT00 column is selected.  The 
surface should now appear as in Figure 19. 

• If desired, draw borders and create paint labels for other sets of cells.  If you want 
to save the changes, it will be necessary to save the Area Color, Border, and Paint 
files. 
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Part 3 - Reconstructing and Flattening a Full 
Hemisphere Created from Contours 
 
Open the Files for the Full Hemisphere 

• Select File Menu->Open Spec File.  In the Choose Spec File Dialog, go into the 
FULL_HEMISPHERE_RECONSTRUCTION directory.  Select the Spec File 
named Macaque.PHT00.R.FULL_HEM.spec file and press the Open button.  
This spec file contains only a contour file. 

• In the Spec File Dialog, press the Select All button followed by the Load button.  
If a spec file is currently in memory, a dialog will appear with information about 
Caret’s ability to load multiple spec files, just press the New Spec Only button. 

 
Examine Contours For Problems 

• If using your own data, please follow the steps in the section entitled Examine 
Contours For Problems in the partial hemisphere reconstruction steps of this 
tutorial. 

• There are a couple of problem contours in the tutorial data set, so select Layers 
Menu->Contours->Cleanup Contours to remove these problems. 

 
Reconstruction of Full Hemisphere Contours into a Surface 

• Select Layers Menu->Contours->Reconstruct Into Surface.  A warning dialog 
will appear informing the user about “Clean Up Contours” and potential problems 
with contours.  Since contours were cleaned in a previous step, press the Proceed 
with Reconstruction button. 

• In the Contour Reconstruction Dialog, verify that the Structure is right, set the 
Voxel Dimension to 256, and uncheck the Convert Contour Cells checkbox 
since there are no cells.  Press the OK button to being reconstruction.  After a 
couple of minutes, the reconstructed surface will appear in the Main Window. 

• Select Surface Menu->Topology->Remove Islands.  In this example, no islands 
are reported. 

• Select Surface Menu->Topology->Topology Error Report.  Errors will be 
reported.  Press the Close button.  A crossover check may help locate these 
problems. 

• Select Surface Menu->Measurements->Crossover Check.  Select Other Type 
of Surface and press the OK button. 

 
Orienting the Full Hemisphere Surface 

• The surface needs to be in an LPI (-X is left, -Y is posterior, and –Z is inferior) 
orientation with the origin at the anterior commissure for Caret’s Flatten Full 
Hemisphere process to operate correctly.  Press the “R” button in the ToolBar.  
Notice that you are viewing the posterior pole of the surface with dorsal being up 
and medial being left.  Press the “X” button three times in the ToolBar to place 
the surface into an LPI orientation. 

• If you have cells, first project them by selecting Layers Menu->Cells->Project 
Fiducial Cells.  In the Cell Projection Dialog, set Data for Projection to All (no 
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sign flips to match hemisphere).  Set the Spatial Projection Type to Keep 
Offset From Surface.  Press the OK button.  Projecting the cells attaches them to 
the surface triangles so that the cells will follow the surface as the surface is 
transformed.  Next, save the Cell Projection File using the File Menu->Save 
Data File Dialog.  Set the File Type to Cell Projection, enter a file name, and 
press the Save button. 

• Select Surface Menu->Transform->Apply Current View.  In the Apply 
Current View Dialog, deselect Apply Translation and Apply Scaling so that 
only Apply Rotation is selected.  Press the OK button. 

• Press the “R” button in the ToolBar.  Press the “L” button in the ToolBar and 
notice that the surface is now in a lateral view. 

• Press the “M” button in the ToolBar to place the surface in a medial view.  Click 
the mouse towards the front (left) of the brain in the general vicinity of where the 
Anterior Commissure would be.  In the Identify Window that pops up, note the 
Raw XYZ position such as 2.40, 19.50, 1.36.   

• Select Surface Menu->Transform->Translate.  Enter the XYZ values from the 
previous step but flip the sign of the values (-2.4, -19.5, -1.36).  Press the Apply 
and then the Close button.  Press the “R” button in the ToolBar.  The crosshairs, 
as shown in Figure 20, can be enabled on the Display Control’s Surface 
Miscellaneous page.   

 

 
Figure 20 - Crosshairs at approximate AC location 
 
Save Data Files 

• Select File Menu->Save Data File.  Set the File Type to Topology Files.  Set the 
File Name to Macaque.PHT00.R.CLOSED.topo and press the Save button. 

• Select File Menu->Save Data File.  Set the File Type to Coordinate Files.  Set 
the File Name to Macaque.PHT00.RAW.coord, set the Orientation to Left, 
Posterior, Inferior, and set the Coord Frame to Native.  Press the Save button. 

• Select File Menu->Save Data File.  Set the File Type to Section Files.  Set the 
File Name to Macaque.PHT00.R.reconstruction.section.  Press the Save 
button. 

 
Create the Fiducial Surface 

• Select Surface Menu->Geometry->Smoothing.  Set the Smoothing Type to 
Normal Smoothing.  Set the Smoothing Parameters Strength to 1.0 and Edges 
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Every X Iterations to 0.  Set the Iterations to 10 for a full hemisphere.  Press the 
Apply button.  After smoothing completes press the Close button.  Smoothing 
removes any noise (jagged parts) in the surface. 

• Select File Menu->Save Data File.  Set the File Type to Coordinate Files.  Set 
the Save As Type to FIDUCIAL.  Set the File Name to 
Macaque.PHT00.R.FIDUCIAL.coord.  Press the Save button. 

 
View the Sections in the Surface 

• Select Surface->Sections->Section Control.  On the Section Control Dialog, set 
the Sections to Single.  Move either the Low or High Section Selection control to 
see how the section number information is preserved in the surface reconstruction. 

 
Generate Curvature Measurements 

• Select Surface Menu->Measurements->Generate Curvature.  Press the OK 
button in the Generate Curvature Dialog. 

• Select File Menu->Save Data File.  Set the File Type to Surface Shape Files 
and the File Name to Macaque.PHT00.R.curvature.surface_shape.  Press the 
Save button to save the file. 

• On the Display Control’s Overlay/Underlay – Surface page, set the Underlay 
to Shape.  Make sure the Folding (Mean Curvature) column is selected. 

 
Create the Inflated and Ellipsoid Surfaces 

• Select Surface Menu->Geometry->Generate Inflated and Ellipsoid from 
Fiducial.  On the Choose Surfaces to Create Dialog, verify that only Create 
Inflated Surface, Create Ellipsoid Surface, and Scale Surface to Match Area 
of Fiducial Surface are selected with all other options deselected.  Press the OK 
button. 

 
Save Data Files 

• Select File Menu->Save Data File.  Set the File Type to Coordinate Files.  In 
the Coordinate Selections Group, select the INFLATED surface using the 
popup menu on the right side of “Coordinate File” to select the INFLATED 
surface for saving.  Change the File Name to 
Macaque.PHT00.R.INFLATED.coord.  Press the Save button. 

• Select File Menu->Save Data File.  Set the File Type to Coordinate Files.  In 
the Coordinate Selections Group, select the ELLIPSOIDAL surface using the 
popup menu on the right side of “Coordinate File” to select the ELLISPOIDAL 
surface for saving.  Change the File Name to 
Macaque.PHT00.R.ELLIPSOID.coord.  Press the Save button. 

 
Flatten the Full Hemisphere 

• Select Surface Menu->Flatten Full or Partial Hemisphere.  Set the Flattening 
Type to Full Hemisphere (Ellipsoid) and Morph Sphere.  Verify that the 
Fiducial Surface is set to the FIDUCIAL 
Macaque.PHT00.R.FIDUCIAL.coord and that the Surface to Flatten is set to 
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ELLIPSOIDAL Macaque.PHT00.R.ELLIPSOID.coord.  Set the Border 
Template Cuts to Macaque right standard cuts.  Press the OK button.   

• When the Paint File Query Dialog pops up, press the Continue button since 
there is no Paint File. 

• When the Missing AC Dialog pops up, press the Yes, continue flattening button 
since the surface was approximately translated to the AC in a previous step. 

• Move the Continue Flattening Full Hemisphere Dialog to the side of the Main 
Window. 

 
Identify the Medial Wall and Cuts 

• Use the Model Selection Control in the ToolBar to view the INFLATED 
surface.   

• Press the M button in the ToolBar to get a medial view of the INFLATED 
surface. 

• Click the left mouse button on the approximate boundary of the medial wall 
which will place small green symbols that will be helpful when redrawing the 
medial wall.  See Figure 21. 

• Click the left mouse button along the calcarine sulcus.  See Figure 21. 

 
Figure 21 - Medial Wall and Calcarine Sulcus Identified 
 
Redraw the Medial Wall and Cuts 

• Display the COMPMEDWALL surface in the Main Window. 
• Select Layers Menu->Borders->Delete Borders By Name.  Hold down the 

CTRL Key (Apple Key on Mac OSX) and click the mouse on CalcarineCut and 
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MEDIAL.WALL so that both are highlighted.  Press the Delete Selected 
Borders button and then the Close button. 

• Select Layers Menu->Borders->Draw Borders to display the Draw Borders 
Dialog. 

• Press the Select button to the far right of the Name label.  In the dialog that pops 
up, select MEDIAL.WALL and press the OK button.  Set the Type to Closed 
(Boundary) and Dimensions to 2D.  Press the Apply button.  Move the mouse to 
the Main Window and over one of the green symbols long the medial wall.  Hold 
down the left mouse button and move the mouse to draw a border going through 
the green symbols along the medial wall.  Complete the border by holding down 
the Shift key and pressing the left mouse button.  See Figure 22. 

• In the Draw Borders Dialog, press the Select button and choose the name 
CalcarineCut.  Set Type to Open and press the Apply button.  Draw a border 
along the green symbols denoting the calcarine sulcus.  See Figure 22. 

• If the FrontalCut or the TemporalCut do not intersect the medial wall, the border 
must be redrawn so that it intersects the medial wall. 

• Press the Close button on the Draw Borders Dialog. 
• OPTIONAL STEP:  If desired, the borders drawn during creation of this tutorial 

may be loaded.  To do so, select File Menu->Open Data File.  Set the File Type 
to Border Files – Surface.  Choose the file named Macaque.PHT00.R.MED-
WALL-AND-CUTS-REDRAWN.border.  Uncheck to Append to Current File 
in the Open Options so that any existing borders, including those that you may 
have drawn.  Press the Open button. 
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Figure 22 - Medial Wall and Cuts Redrawn 
 
Continue the Flattening Process 

• Press the Continue Flattening button on the Continue Flattening Full 
Hemisphere Dialog. 

 
Examining and Cleaning the Initial Flat Surface 

• After a few minutes, the Initial Flattening Dialog will appear.  Drag this dialog 
to the side. 

• If any of the green identification symbols are on displayed, select Surface Menu-
>Identify->Clear Node Identify Symbols. 

• Select Surface Menu->Topology->Remove Islands. 
• Select Surface Menu->Topology->Remove Corner and Straggler Tiles.  Select 

Delete Corners and Stragglers and press the OK button. 



 35 

• Select Surface Menu->Measurements->Crossover Check.  Make sure Flat 
Surface is selected and press the OK button.  If there are crossovers near the 
perimeter of the surface, they may be removed with cuts.  See the Initial 
Flattening Dialog for instructions on using cuts. 

 
Figure 23 - Initial Flat Surface with Islands Removed 

• If any islands were removed or cuts were used to remove part of the surface files 
need to be saved.  Select File Menu->Save Data File.  Set the File Type to 
Topology File.  In the Topology Selections make sure the Topology File is CUT 
Macaque.PHT00.R.CUT.topo.  Change the File Name to 
Macaque.PHT00.R.CUT_EDIT.topo.  Press the Save button.  Select File 
Menu->Save Data File.  Set the File Type to Coordinate Files.  In the 
Coordinate Selections group, make sure that Coordinate File is set to the 
“IntialFlat” coordinates.  Change the File Name to 
Macaque.PHT00.R.InitialFlat_EDIT.coord.  Press the Save button. 

 
Multiresolution Morphing of Flat and Spherical Surfaces 

• Press the Continue Flattening button on the Initial Flattening Dialog. 
• Press the OK button on the Multiresolution Morphing – Flat Dialog. 
• Press the OK button on the Multiresolution Morphing – Sphere Dialog.  

Multiresolution morphing may take 1/2 hour or longer depending upon the speed 
of your computer and the quantity of nodes in the surface. 

• At the conclusion of Multiresolution Morphing, the Flat Morphing 
Measurements and Spherical Morphing Measurements Dialogs will appear.  
These dialogs display statistical information about the surfaces produced during 
each cycle of multiresolution morphing.  Press the Close button on both of these 
dialogs. 



 36 

 
Align the Flat and Spherical Surfaces to Standard Orientation 

• Drag the Align Surfaces to Standard Orientation Dialog to the side of the 
Main Window. 

• Select the last of the flat surfaces (such as CYCLE5 or CYCLE5_OVERLAP) for 
display in the Main Window using the ToolBar’s Model Selection control. 

• Select Viewing Window 2 from the Window Menu.  Select the FIDUCIAL 
surface for Display.  Click the mouse near the bottom of the central sulcus to 
perform an identification operation (Figure 24).  This helps identify the central 
sulcus in the flat surface (Figure 25).  Press the Close button to close Viewing 
Window 2. 

 
Figure 24 - ID in Central Sulcus  

  
Figure 25 - Central Sulcus Identified 
 

• Press the Reset button on the Align Surface(s) to Standard Orientation Dialog. 
• Click the left mouse button near the ventral tip of the central sulcus (there should 

be a green symbol near this locations that was created when you identified the 
central sulcus in a previous step). 

• Hold down the shift key and click the mouse on the dorsal-medial tip of the 
central sulcus.  Press the Apply button on the Align Surface(s) to Standard 
Orientation.  After a short time the flat and spherical surfaces will be aligned to 
standard orientation. 
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• Select File Menu->Save Data File.  Set the File Type to Coordinate Files.  
Verify that the Coordinate File selected in the Coordinate Selections is the same 
as the flat coordinate file displayed in the Main Window.  Change the File Name 
to Macaque.PHT00.R.FLAT_FINAL.coord.  Press the Save button. 

• Select File Menu->Save Data File.  Set the File Type to Coordinate Files.  
Verify that the Coordinate File selected in the Coordinate Selections is the last 
of the spherical coordinate files (probably has SPHERE_CYCLE4 in its name).  
Change the File Name to Macaque.PHT00.R.SPHERE_FINAL.coord.  Press 
the Save button. 

• Select File Menu->Save Data File.  Set the File Type to Latitude Longitude 
Files.  Set the File Name to Macaque.PHT00.R.LAT_LON.latlon.  Press the 
Save button. 

 
End of Tutorial 
 
 


