From Van Essen Lab

Jump to: navigation, search



Caret6 is designed for viewing multiple structures. Some of Caret's data files are structure dependent. These structure dependent files include Label, Metric, Shape, and Surface files. When listed in the Specification File, each of the entries for these structure dependent files contains the name of an associated structure. Other files, such as Border Projection Files, Foci Projection Files, Study Metadata Files, and Volume Files are structure independent.

When Caret reads a Specification File's data files, those data files that are associated with a specific structure are grouped together in Caret using the structure name.

When the user selects a column of a data dependent file for display (ie: a functional column) on a structure, Caret6 will examine other structures to see if they have a data column with the same name. If so, it will also be selected for display. So, if you have a right and left hemispheres loaded with the same functional data (and same column name), selecting the functional column for display on one structure will also display the correspondingly named data on the other structure(s).

Viewing Window


The controls in the toolbar will always be present. The controls will be enabled/disabled based upon the item viewed in the window.

Mouse Mode Group

  • View - Set the mouse mode back to View Mode.

Viewing Group

  • L - Left View
  • R - Right View
  • A - Anterior View
  • P - Posterior View
  • D - Dorsal View
  • V - Ventral View
  • X - Reset View

Structure Group

  • L - Toggles display of left hemisphere surface
  • R - Toggles display of right hemisphere surface
  • S - Toggles display of all sub-cortical surfaces (including cerebellum, or add "C" for cerebellum)
  • V - Toggles display of volume slices

Volume Group

  • Spin Box for selecting the volume's parasagittal slice ("i" (x-axis))
  • Spin Box for selecting the volume's coronal slice ("j" (y-axis))
  • Spin Box for selecting the volume's horizontal slice ("k" (z-axis))

Multiple Structure Viewing Windows

For each surface type that is loaded (Anatomical, Inflated, etc), there will be a corresponding "viewer". This viewer is similar to Caret5's Surface and Volume viewer. This viewer displays one surface from each structure (if it is available) and the volume slices. For example, the Anatomical viewer displays the anatomical surface from each structure and, if present, the volume slices. If there are multiple anatomical surfaces for a structure, a "to-be-determined" control will be used to selected the "primary" surface of that type for a structure. Toolbar controls will allow the user to toggle on/off the left hemisphere, right hemisphere, sub-cortical structures (all as a group), and the volume slices.

It may be helpful to scale the inflated and very inflated surfaces so that they are in the same bounding box and have the same origin as the anatomical surface. This will allow these surfaces be viewed along with the volume slices.

Single Structure Viewing Windows

  • Since most operations are performed on a single surface, single Surface Viewer(s) will be available.

Caret6 Menus

File Menu

  • Set Current Directory
  • Manage Loaded Files
  • Open Spec File
  • Open Recent Spec File
  • Open Data File
  • Save Data File
  • Capture Image

Data Menu

  • Area Color Operations
  • Border Operations
  • Connectivity Operations
  • Foci Operations
  • Metric Operations
  • Paint Operations
  • Palette Operations
  • RGB Operations
  • Study Collections Editor
  • Study Metadata Editor
  • Shape Operations
  • Vocabulary Operations
  • Map Volume to Surface Data

Surface Menu

  • Flattening
  • Geometry Operations
  • Identification Operations
  • Information
  • Region of Interest Operations
  • Registration
  • Topology
  • Transformation
  • Viewing

Volume Menu

  • Edit Volume Attributes
  • Paint Volume Operations
  • Paint->Generate Colors for Paints Without Colors
  • Region of Interest Operations
  • Segmentation Volume Operations
  • SureFit Segmentation

PlugIns Menu

  • For “plug-ins” written by others.

Development Menu

  • A menu that contains operations that are used in the development of Caret6 algorithms and testing. Only displayed if an option is set at the time of Caret6 start-up.

Window Menu

  • Bring All to Front (needed?)
  • Stack Windows (needed?)
  • Display Control
  • Error Log
  • Identify
  • SumsDB Database (upload only).
  • XNAT???
  • Transformation Matrix Editor

Help Menu

  • About Caret 6
  • Caret 6 Manual (Opens Caret 6 Wiki in Browser)
  • Caret Help Mailing List


  • caret6
  • caret6_command
  • caret6_stats
  • "Web" Caret6 (Runs in web browser)


We will try to develop a plug-in capability so that users can extend the function of Caret6. How this will be done is unknown at this time. Perhaps the user's plug-in will be in a JAR file and the user will extend a caret plugin class for interface.

Personal tools
Sums Database