Caret6:Tutorials/Tutorial1

From Van Essen Lab

Jump to: navigation, search

Contents

Caret6 Tutorial 1

Data Set

/Volumes/DS4600/johns_data/caret6_tutorials/tutorial_1

A data set consists of a set of file, typically for a single subject or a population-based atlas. A Specification File is the "directory" for the data set and it contains a list of data files and their respective file types. Some data files are associated with specific brain structures while others associate with all brain structures.

Types of Data Files

  • Annotation Text labels (not to be confused with a label file's labels) that are attached to surface nodes. Annotations allow one to identify an area of a surface similar to "this is...".
  • Border Projection Contains line segments that can identify a region of a surface. Borders can be linear (like a road) or areal (enclose an area). Linear borders are often used to identify a sulcus and areal borders are used to enclose an identified cortical area.
  • Foci Projection Foci allow the placement of symbols at absolute, three-dimensional locations. Foci can be projected which converts the three-dimensional location into a location (using barycentric coordinates) that is relative to several surface nodes. As the surface is reshaped (inflated), the foci will follow the surface and maintain their relative geometric relationship.
  • Label Associates a label (name) with each surface node. A set of labels may identify the lobes of a cerebral cortex or the parcels in a parcellation scheme.
  • Metric Associates a measurement that is a real number with each node in a surface. A common example is functional neuroimaging data (fMRI).
  • Region of Interest - Surface Identifies a subset of surface nodes for further processing. For example, regions of interest may be converted into labels.
  • RGBA Provides a red, green, blue, alpha (RGBA) coloring for all surface nodes.
  • Shape Associates a real number with each node in a surface that indicates a shape characteristic of the surface. Common types are curvature and depth. The shape data is useful when viewing an inflated surface as it denotes the sulcal and gyral patterns.
  • Study Contains information about studies (journal articles). Other caret data types, in particular foci, can be linked to studies.
  • Surface Consists of three-dimensional points (also called nodes or vertices) that are connected to form a triangular mesh. A surface forms a shell of an object such as a cerebral cortex.
  • Vocabulary Contains terms and their definitions.
  • Volume is made up of voxels with a value associated with each voxel.
    • Anatomical contains a structural MRI that shows the anatomical structure of the brain.
    • Functional contains fMRI measurements of activity throughout the brain.
    • Label associates a label (name) with each volume voxel similar to surface voxels.

Examples

Anatomical Surface Image:ExampleAnatomical.jpg
Inflated Surface Image:ExampleInflated.jpg
Inflated Surface with Annotations and Labels Image:ExampleInflatedAnnotations.jpg
Inflated Surface with Metric and Shape Image:ExampleInflatedMetric.jpg
Inflated Surface with Labels and Shape Image:ExampleInflatedLabel.jpg
Inflated Surface with Borders Image:ExampleInflatedBorders.jpg
Inflated Surface with Foci Image:ExampleInflatedFoci.jpg
Anatomical Volume Image:ExampleAnatomicalVolume.jpg
Functional over Anatomical Volume Image:ExampleAnatomicalFunctionalVolume.jpg
Label over Anatomical Volume Image:ExampleAnatomicalLabelVolume.jpg

Load Specification File

  • Start Caret6
  • Select File Menu->Open Specification File. In the Choose Spec File Dialog, select the file Tutorial.spec and press the Open button.

The Specification File Dialog lists the files contained in the Specification File that was just opened. Caret6 supports multiple structures within a single data set. Notice that surface-node based files (Surface, Label, Metric, etc.) have a structure selection that associates a data file with a specific structure. Layered files (Annotation, Border Projection, Foci Projection) are multi-structure files and have a structure associated with each data element.

  • Press the Select All button followed by the Load button to load all of the data files.

The Main Window Menus and Toolbar

The menus, toolbar, and their contents are described in the user-interface documentation.

The Main Window Toolbar

The Toolbar in the Main Window contains two rows. The top row contains buttons for standard views, volume slice selection, and quick launching of several other windows.

  • Move the mouse over a toolbar control and, after several seconds without moving the mouse, a tooltip will appear describing the function of the control under the mouse.
  • Press some of the toolbar's view buttons (L, R, etc.).
  • Move the mouse into the Main Window. Press and hold the left mouse button while moving the mouse to rotate the surface and then release the mouse.
  • Hold down the CTRL key (Apple key on Macs), press and hold the left mouse button while moving the mouse forwards and backwards to zoom the surface.
  • Hold down the SHIFT key, press and hold the left mouse button while moving the mouse to pan (translate) the surface.
  • Click (press and release) the left mouse button on the surface.

When a surface node is identified, the node is highlighted with a symbol (usually green) and information about the node is displayed in the Identification window. The information displayed will vary depending upon the files that are loaded.

Identify Window

Toolbar

  • SID When selected (default), symbols are placed at surface locations where and identification operation has been performed.
  • CID Clears (removes) any surface identification symbols.
  • Clear Clears the the text from the Identify Window.
  • Copy Copies any text in the Identify Window to the computer's clipboard.
  • Press the Filtering tab in the Identify Window.

The filtering panel enables and disables the display of various data types in the Identify Window.

  • Press the Identification tab.
  • Press the Close button.

Viewing Windows

The viewing windows allow one to view multiple surfaces and volumes simultaneously. The Toolbar contains controls nearly identical those in the Main Window's Toolbar. The mouse also performs identification operations and surface movements in the Viewing Windows.


  • Select Window Menu->Viewing Window 2.
  • In Viewing Window 2's Toolbar, use the Model control to select a CortexRight surface.
  • Select Window Menu->Viewing Window 3.
  • In Viewing Window 3's Toolbar, use the Model control to select Volume Slice Viewer.
  • Click the mouse in a Window displaying a surface. Note that the volume slice changes to the slice nearest the selected surface node.
  • Click the mouse on the volume slice. An identification symbol is placed on the surface nearest the location of the voxel on which the mouse was clicked.
  • In Viewing Window 3's Toolbar, use the Slice Axis control to switch to a coronal, C (XZ), view.

Caret6 can view multiple surfaces simultaneously.

  • Select Window Menu->Viewing Window 4.
  • In Viewing Window 4's Toolbar, use the Model control to select All Structures.
  • Use the mouse to rotate and zoom the All Structures viewer.

All structures displays a surface from each structure and volume slices in one view.

  • Leave Viewing Windows 2 and 3 open and close Viewing Window 4.

Display Control

  • Press the DC button in the Main Window Toolbar.

The Display Control is used for selecting data displayed on surfaces and volumes. At the top of the Display Control is the Page Selection control that is used to select the many pages for controlling the display of different types of data. Some pages may also have a Window Selection section that controls the assignment of data to specific windows.

Display Control of Surface Overlays

  • Use the Page Selection control to set the page to Overlay/Underlay Surface.

The Overlay Section contain several columns with each row containing controls for a overlay. An overlay displays surface related data (Metric, Label, Shape) on a surface. Multiple layers can be used to view several data types simultaneously. Typically the Underlay (bottom-most layer) is set to the Shape data type which colors the surface in a pattern, such as Folding, that reveals the shape of the surface.

  • Set the Primary Overlay Data Type to Label and its Data Column to Brodmann.
  • Click the mouse over several of the regions of the surface. The number of the Brodmann area clicked with the mouse is displayed in the Identify Window.

Notice that the surfaces in both the Main and Viewing Windows now display a pattern denoting the Brodmann Parcellation (created by the legendary neuroscientist Herr Korbinian Brodmann) of the cerebral cortex.

  • Set the Primary Overlay Data Column to Lobes (PALS atlas) to display a pattern denoting the lobes of the cerebral cortex.
  • Set the Primary Overlay Data Column to Sulcal ID to display a pattern that names the sulci.
  • Click the mouse over several sulci and their names are displayed in the Identify Window.
  • Set the Primary Overlay to Metric to view patterns of functional data on the surfaces.
  • Set the Primary Overlay Data Type to None.

Caret6 allows one to assign overlay to specific windows. This allows one to view different types of data in each window, perhaps on the same surface.

  • Use the Model Control in the Main Window and Viewing Window 2 Toolbars so that the two windows display the same surface.
  • At the top of the Display Control's Overlay/Underlay Surface page, set the Window Selection to Main Window.
  • Set the Primary Overlay to Label and the Data Column to Lobes.
  • In the Window Selection area, change Set Overlays for to Viewing Window 2.
  • Set the Primary Overlay to Label and the Data Column to Brodmann.

One should now see different types of data, on the same surface, in different windows.

  • Change the Window Selection to All Windows.
  • Set the Primary Overlay Data Type to None.
  • View a left surface in the Main Window and a right surface in Viewing Window 2.

Display Control of Volume Overlays

Volumes also have overlays.

  • Use the Display Control's Page Selection control to select the page named Overlay/Underlay Volume.
  • Set the Primary Overlay Data Type to Functional to view a pattern of functional activity over a volume slice.
  • Set the Primary Overlay Data Type to Label to view the Brodmann areas on a volume slice.
  • Set the Primary Overlay Data Type to None.

Display Control of Annotation

Annotations place text labels attached to surface nodes with sticks.

  • Use the Display Control's Page Selection control to select the page named Annotation.
  • Check the box labeled Show Annotations.
  • Rotate and zoom the surface to view the annotations.
  • Deselect Show Annotations so that the annotation are no longer displayed.

Display Control of Borders

Borders consist of line segments shown on a surface.

  • Use the Display Control's Page Selection control to select the page named Borders Main.
  • Check the box labeled Show Surface Borders.
  • Click the mouse on a border in the Main Window to view the name of the border in the Identify Window.
  • Use the Display Control's Page Selection control to select the page named Border Name.
  • Press the All Off button and then check the boxes next to several names in the list to display only those borders.
  • Return to the Borders Main page and deselect Show Surface Borders to remove the any displayed borders.

Display Control of Foci

Foci place symbols at stereotaxic (three-dimensional) locations that can be visualized on an anatomical surface. The foci can be projected to a surface which anchors the foci to a location on the surface. Once projected, the surface can be reshaped (inflated) and the foci will maintain their associated surface relationship.

Typically, foci originate from the stereotaxic locations of data reported in a journal article, such as locations of brain activity detected during functional imaging.


  • Use the Display Control's Page Selection control to select the page named Foci Main.
  • Check the box labeled Show Surface Foci.
  • Click the mouse over a focus and a large amount of information related to the focus is displayed in the Identify Window.
  • Use the Display Control's Page Selection control to select the page named Foci Class.
  • Press the All Off button and then check the boxes to some of the classes so that only foci associated with the selected classes are displayed.
  • Press the All On button.
  • Use the Display Control's Page Selection control to select the page named Foci Keywords.
  • Press the All Off button and then check the boxes next to some of the classes so that only foci associated with the selected keywords are displayed.
  • Return to the Foci Main page and deselect Show Surface Foci to remove all foci.
Personal tools
Sums Database