Caret:Documentation/ChangeLog2004

From Van Essen Lab

Jump to: navigation, search

NOTE:  Remaining changes are listed from oldest to newest.

04 April 2004 - Release version 5.1

  • (12 April) Version changed to 5.11.
  • (12 April) Changed flat multi-resolution morphing parameters.
  • (12 April) Fixed spherical registration borders (dorsal medial

wall, ventral medial wall, and calcarine) produced during full hemisphere flattening.

  • (12 April) Generate latitude longitude borders so that the north

pole is at the lateral pole which is the tip of the Central Sulcus. 

  • (12 April) Assign border colors after generating cartesian grid

or lat/lon borders.

  • (12 April) If no paint or area color file was provided at start

of flatten full hemisphere, the paint and area color file names ended up like "paint_file_#" and "color_file_#".  Now uses topo file name to get a file name prefix for paint and area color files.

  • (12 April) If borders are loaded and border display is off, turn

on display of borders.

  • (12 April) Add option to Save Data File Dialog to remove

duplicate borders/border projections when saving a border or border projection file.

  • (12 April) Add menu item to rename a border by clicking on it

with the mouse, which pops up a dialog allowing the border to be renamed.

  • (13 April) Remove some static data from node coloring.
  • (14 April) When performing multi-resolution morphing, only add

the last coordinate file to the spec file.  Other cycles are still saved, just not added to the spec file.

  • (14 April) Use meaningful names for spherical lat/long borders.
  • (14 April) Move unrecognized spec file tags to the spec file's

header.

  • (14 April) Default border saving so that it removes duplicate

borders.

  • (14 April) Spec File Dialog change to the remove from spec file

"X" button next to each file.  Now when the user presses the "X", the line is grayed out.  If the user presses the "X" again, the line is re-enabled so that the file is not deleted.  If a line is grayed out when the spec file dialog closes, the file is removed from the spec file.

  • (14 April) Add binary format

for coordinate and topology files.

  • (15 April) Add binary format

for areal estimation, lat/lon, metric, paint, rgb paint, section, and surface shape files.

  • (16 April) Replace current normals calculation that uses VTK

because  it is slow.  Replace with normals calculation using coordinates and topology.

  • (16 April) Do not classify nodes after reading a spec file.

 Instead classify as needed such as when the primary overlay is set to Edges or the surface is drawn with Links-Edges only.

  • (16 April) Add utility program "caret_file_convert" to convert

between binary and text (ascii) files.

  • (16 April) Add computation of average and deviation for each node

in the surface shape file.

  • (19 April) Enable multi-threading for multi-resolution morphing.
  • (20 April) Add a copy button to the Identify dialog to copy the

highlighted text to the clipboard.

  • (21 April) Update all projected files when surfaces are aligned.
  • (21 April) Add option to expand or shrink a surface along the

surface normals to Surface: Geometry menu.

  • (21 April) Fixed bug that prevented fast open data file dialog

close button from closing the dialog when the auto close checkbox was unchecked.

  • (21 April) Add a second light opposite of the existing light when

drawing functional volume voxels so that they do not appear dark gray in the dorsal view.

  • (22 April) Add additional functional volume mapping algorithms

for mapping functional data within Caret.

  • (26 April) Default to new column each time a functional volume is

mapped within Caret.

  • (27 April) Do not allow spec file name to be changed in

map_fmri_to_surface on the metric naming dialog.

  • (28 April) Created new program "caret_metric" for performing

clustering and smoothing of metric files at the command line.

  • (29 April) Created deformation map file version 2.  In this

version, two new items are added, the source (individual) and target (atlas) directories.  All of the source and target files are written relative to these directories.  When applying a deformation map, the source and target directory names are verified to see if they exist.  If not, the user must set them.  This change simplifies the movement of a deformation to another computer system.

  • (29 April) map_fmri_to_surface so that it will display an error

message if the atlas surface directory file (typically named "map_fmri_atlas.directory) version is 2 or greater.  map_fmri_to_surface will be replaced with a program named "caret_map_fmri".

  • (29 April) Correct problem with every other frame being black

when recording animation through volume slices.

  • (29 April) Fixed origin of AFNI volumes stored with R-A-S

orientations.  It was off by one voxel.

  • (30 April) Modify caret_file_convert to convert FreeSurfer

Surface, Patch, Curvature, and Functional files to Caret format.  Also convert VTK polydata.

  • (3 May) Rewrite some of caret_file_convert.  Add BYU and STL

file conversion.

  • (5 May) Add option on Display Control Dialog's border panel for

adjusting the stretch factor when borders are draw as unstretched lines on a flat surface.

  • (5 May) Attributes: Lat/Long: Generate Lat/Long on Spherical

Surface now assumes that the default view of the sphere is a dorsal view.  Positive latititude is along the lateral axis and negative latitude is along the medial axis.

  • (7 May) Fixed problem with metric smoothing algorithm.
  • (7 May) Added Clustering and

Smoothing for Surface Shape files.

  • (7 May) Fixed bug with caret_metric program crashing on Linux.
  • (11 May) Initial implementation of new fMRI mapper for individual

and a surface loaded within Caret.

  • (11 May) Add "?" button for RGB paint on Display Control Dialog.
  • (11 May) Add display of surface shape information in the Identify

Dialog.

  • (11 May) Add reference surface and surface used during distortion

calculations to the surface shape column comments.

  • (11 May) Add the name of the surface used for curvature

calculation to surface shape column comment.

  • (11 May) Fixed problems on histogram dialog when viewing middle

96%.

  • (11 May) Add button to set all columns to do not load when

loading a node attribute file such as paint.

  • (11 May) Add option at Caret5 startup "-loadspec

<spec-file-name>" that automatically loads the data files contained in "spec-file-name" into Caret.  The option "-spec <spec-file-name>" simply loads the spec file "spec-file-name" into the spec file dialog.

  • (12 May) Added Mathematical

Operations to Attributes: Metric and Attributes: Surface Shape.  This allows two columns to be added, one column to be subtracted from another, one column to be divided by another, two columns to be multiplied, a column to be multiplied by a scalar, and a scalar added to a column.

  • (12 May) Add standard error for metric and shape average and

standard deviation computation.

  • (12 May) Fixed some problems with probabilistic atlas coloring.
  • (12 May) Bug fix on D/C panel for prob atlas letting previous

page show thru.

  • (12 May) Split metric clustering threshold into negative and

positive.

  • (13 May) Now able to save (projected) foci associated with each

surface type.  However, only fiducial foci files are added to the spec file can Caret still only loads foci associated with the fiducial surface.

  • (14 May) Fixed cell/foci projection problem.  When

cells/foci project inside a tile, the offset of the cell or focus from the tile is saved as a vector in relation to the fiducial surface.  The problem is that a cell or focus around the inferior part of the fiducial surface may have a vector with a negative z component.  When this cell or focus is unprojected on the flat surface, it ends up under the flat surface when it really should be above the flat surface due to the offset vectors negative z component.  Now, the signed distance to the surface is combined with the surface's tile normal to properly offset the cell or focus when unprojecting.

  • (17 May) Default registration border resampling to 10.
  • (17 May) When deforming node attribute files, column names are

prefixed with "deformed".  File comments now include name of source file being deformed and the name of the deformation map file.

  • (18 May) Default probabilistic atlas to "normal" display.
  • (18 May) Add editing of surface shape column names to display

control dialog.

  • (18 May) Fix editing of metric column names so that main display

control page gets updated.

  • (19 May) Add option on save data file dialog to inhibit the

automatic appending of a file type extension to the file's name.

  • (19 May) Add button to volume attributes editor dialog to use the

params file AC to set the volume's origin.

  • (19 May) Add display of params file data in the "names" tab of

the view data file comment dialog accessed by pushing the "?" button on the View Data Files or the Spec File dialogs.

  • (19 May) Add to Surface Region

of Interest Dialog.  New query that determines correlation coefficients between one column of surface shape and all other surface shape columns.

  • (20 May) Add item to Surface:Topology Menu to use

vtkPolyDataNormals to consistently orient the triangles in the surface topology.

  • (21 May) Fixed error in metric and shape statistics that snuck in

when standard error was added on 12 May.

  • (24 May) Add option to display a surface shape color bar in

graphics windows.

  • (24 May) Do not require spec files when applying a deformation

map to deform a data file.

  • (24 May) Add "deformed with" to columns when deforming a node

attribute data file.

  • (24 May) Add check in spherical deformation for border files that

are projected to nodes at origin.

  • (24 May) Add spin boxes to color selection dialogs.
  • (28 May) Add Layers:Borders:Create Average Borders to create

average borders form border files that contain borders with the same names.

  • (1

Jun) Update Macaque flatten hemisphere template borders with URL

  • (1

Jun) Use MIstart and MIstop parameters as origin and voxel size when importing minc volumes.

  • (2 Jun) Modify surface region of interest surface shape

correlation report to enable correlation between all columns (creates NxN matrix).

  • (7 Jun) Add "version_id" to header each time a file is written.

 These version_id's will by used by SuMS to keep track of a files "heritage".

  • (10 Jun) In identify dialog, show coordinates for all open

windows with surfaces displayed.

  • (10 Jun) Create a deformation field when a spherical deformation

field is computed.  This currently only compute the individual's deformation field.

  • (11 Jun) Add Generate Deformation Field to the Attributes Menu

and display deformation fields as a layer controlled through the Display Control Dialog.

  • (14 Jun) Compute normals as first step when computing surface

curvature.

  • (14 Jun) Add optional perspective projection.
  • (15 Jun) Reduced time to make surface cuts.
  • (22 Jun) Create atlas deformation field when performing a

spherical registration or, post deformation, using the Attributes Menu.

  • (22 Jun) Add ability to deform

coordinate files so that multiple cases may be loaded and viewed simultaneously in a single Caret session.

  • (23 Jun) Add information to Smoothing Dialog to inform the user

that normals should be regenerated after smoothing a surface.

  • (23 Jun) Add Dialog to Surface Menu for averaging coordinate

files.

  • (23 Jun) Add name of deformation map file to deformed coordinate

file.

  • (24 Jun)

Increase total number of model windows from 5 to 10.

  • (25 Jun) Fixed error that gave a paint file created during

flattening of a full hemisphere an area color file extension.  Add a check at the beginning of flattening a full hemisphere for a paint file.

  • (25 Jun) Limit update of version_id in spec file to once per

caret session when saving data files.

  • (28 Jun) Add creation of topology file when deforming a flat

coordinate file.

  • (28 Jun) Add warning when saving a volume in AFNI format and the

file name does not end in an extension like "+tlrc.HEAD".

  • (30 Jun) Create binary version of deformation map file.
  • (30 Jun) Fixed bug with using a pre-loaded border file for

template cuts when flattening a full hemisphere.  Users must now use an ellipsoidal border file.

  • (1 Jul) Add Copy Spec File to

File Menu for copying spec files.

  • (2 Jul) Added an interface to

the SuMS database for downloading and uploading data sets.  This is selectable from the Comm Menu.

  • (2 Jul) Add option (defaulted on) to the Flatten Hemisphere

Dialog to smooth the medial wall of a fiducial surface during flattening of the full hemisphere.

  • (2 Jul) Add Convert Data Files

Format to File Menu to convert data files between text and binary format.

  • (6 Jul) Trim leading and trailing whitespace when reading data

file tag/value pairs.

  • (7 Jul) Implement surface editing (Surface:Edit menu).
  • (7 Jul) Possible fix for clipping problems seen in Surface &

Volume mode.  When optional perspective view was added, a call to gluLookAt() was also added but was being called for both perspective and orthographic viewing modes.

  • (7 Jul) Fixed crash after import of free surfer surface due to

colors not being assigned.

  • (8 Jul) When uploading a spec file to SumsDB, strip the path from

all of the data files listed in the spec file.

  • (8 Jul) Limit number of version_id updates to just one when a

file is written out multiple times in a caret session.

  • (8 Jul) Add selection of previous data file directories on open,

save, import, and export file selection dialogs.

  • (8 Jul) Clear file data file names on deformation dialog when a

spec file is selected.

  • (9 Jul) No longer set version_id in file header when a data file

is written.  version_id will now be updated by SumsDB.

  • (9 Jul) Added volume borders.
  • (22 Jul) Implemented new

functional volume to surface mapper.  Removed "map_fmri_to_surface" from attributes:metric menu.   "caret_map_fmri" is now command line only.

  • (22 Jul) Limit width of parameters (space, species, hem, etc) on

spec file dialog so that all are visible even if data files have very long names making dialog very wide.

  • (23 Jul) Add quick mapping of a functional volume to an atlas

surface to the Volume:Functional Menu. 

  • (26 Jul) Fix crash

if a coordinate file is read without any other files having been read.

  • (26 Jul) Limit width of previous spec files on choose spec file

dialog.

  • (26 Jul) Limit width of previous directories on open and save

data file, and import and export file dialogs.

  • (27 Jul) Added a spin box on the right side of the Identify

Window to control the number of digits to the right of the decimal point in the data display window.

  • (27 Jul) Add "All On" and "All Off" buttons to surface region of

interest attributes page.

  • (27 Jul) When reading a coord file, check its header for the

topology file used by the coord file when the coord file was last saved, and, if that topology file is loaded, assign the topology file to the coord file's surface.

  • (27 Jul) Add brain model selection to the popup menu.
  • (27 Jul) Add menu item on Layers:Borders menu to convert volume

borders into fiducial cells.

  • (28 Jul) Moved active fiducial surface (used in surface &

volume and for overlay on volume) from Surface Information Dialog to Display Control Dialog's Surface Miscellaneous panel.

  • (28 Jul) Combo box at top of Display Control Dialog now only

lists pages for data that is loaded.

  • (28 Jul) Holding down the CNTRL key (Apple on Macs) and pressing

F1, F2, ..., F15 over a caret window will switch to the surfaces and volumes as listed in the toolbar's model selection menu.

  • (28 Jul) Store and use hem_flag

in coord file header so that different hemispheres may be loaded simultaneously and toolbar buttons will work correctly.

  • (29 Jul) Add ability to set the maximum and  minimum values

for metric or surface shape on the metric/surface shape dialog.

  • (29 Jul) Add volume

mathematics.

  • (29 Jul) Add optional output file parameter for "caret_metric"

command line program.

  • (29 Jul) Add import of raw volume files.
  • (2 Aug) Add independent surface

coloring that allows each surface to have its own surface coloring.

  • (2 Aug) Add ability to set hemisphere for a surface from the

surface information dialog.

  • (3 Aug) Change independent surface coloring on display control

dialog so that the control is available on all sub-pages that deal with surface attributes.

  • (3 Aug) Fixed "New Spec" button on spec file dialog so that it

creates a spec file with all selected files.

  • (3 Aug) When using "New Spec" button and the user selects an

existing spec file, give the user the opportunity to overwrite or cancel.

  • (5 Aug) Added display lists for

surface drawing.  Significantly improves performance on Macs.

  • (5 Aug) Fixed bug that

voxels were not colored on surface and volume if a volume was not previously viewed.

  • (5 Aug) Add ability to

draw segmentation volume voxels as filled, open squares, or crosses.

  • (6 Aug) Add ability to

specify type of ouput file (binary or text) produced by the program "caret_metric".

  • (10 Aug) Add "caret_sphere_deform", a command line program for

performing spherical registration.

  • (11 Aug) Add experimental

smoothing that uses curvature and normals from an equation in a "level sets" paper.  It can produce a surface similar to the inflated surface but with some high frequency spikes.

  • (13 Aug) Add graph that pops up

when a node is identified, a metric is underlay or overlay, and popup graph is selected on metric panel of overlay underlay dialog.

  • (27 Aug) Fix bug that caused a blank image when the main window

was saved as an image with display lists on.

  • (30 Aug) Add a "Simplify Surface" item to the Surface menu to

reduce the number of polygons (and nodes) in a surface.

  • (31 Aug) When a volume file is read, default its sub-volume name

to the name of the volume.  If there is a sub-volume name in the volume file's header it will override the default name.

  • (31 Aug) Add segmentation volume editing - erosion and dilation.
  • (31 Aug) Default display lists

off if the OpenGL library is a "Mesa" OpenGL library.

  • (1 Sep) Change "Finish" button

on Map Fmri Dialog to "Map Data".

  • (1 Sep) On Map Fmri Dialog, only clear mapping surfaces if a

volume is added or deleted.  Previously, the mapping surfaces were removed when the volumes page was displayed.

  • (1 Sep) Remove Copy/Download Spec File page from Map Fmri Dialog.
  • (1 Sep) Modify Map Fmri Dialog

so that average is created for each volume and multiple surface set.

  • (2 Sep) Modify Draw Border Dialog so that it checks for rotation

when the Apply button is pressed on the Draw Border Dialog if a flat or compressed medial wall surface is being viewed.  If there is a rotation, the warning will be displayed allowing the user to remove the rotation or ignore it.

  • (2 Sep) When processing the mouse allow no mouse movement or a

very tiny mouse movement to preform and ID node operation when in View Mode.

  • (2 Sep) When computing metric/shape avg/dev/error, default the

color mapping to the min and max values in the respective columns.

  • (2 Sep) Add segmentation volume

editing flood fill and remove connected region.

  • (2 Sep) Add ability to set metrics or surface shape for nodes in

an ROI.

  • (2 Sep) Modify color file editor to that when creating a new

color, the name of the new color and its attributes are the same as the currently selected color.

  • (3 Sep) Add ability to adjust threshold for probabilistic atlas

threshold display.

  • (3 Sep) Add new Attributes:Probabilistic Atlas menu item for

converting a currently selected as overlay/underlay threshold probabilistic atlas to a paint column.

  • (3 Sep) Add hemisphere to parameters on file save dialog when

saving a coordinate file.

  • (7 Sep) Modify volume animation.  Now start on currently

viewed slice.  Have ability to set animate direction (positive or negative slice increment) and can set direction while paused.

  • (7 Sep) Fixed bug that caused a functional volume to be

incorrectly colored when there was no metric file loaded.  This probably resulted when independent surface coloring was added.

  • (8 Sep) Added Wu Region File

that when used with a ROI volume (paint volume), a graph will popup when a node is identified that is in a selected ROI showing the timecourse for the region.

  • (9 Sep) Add dialog on attributes paint menu to map a paint volume

into a paint file column.

  • (9 Sep) Changed code for updating

GUI due to data file changes to allow for more than 32 files.

  • (9 Sep) Add import of SUMA's RGB file.
  • (10 Sep) fMRI mapper - change name

to "AVERAGE - volume-name" and include names of coordinate files in the average column's comment.

  • (10 Sep) Add ability to set the column names for lat/lon file

columns.

  • (10 Sep) Add ability to selectively read columns from a lat/lon

file.

  • (10 Sep) Display lat lon column names in ID window.
  • (10 Sep) Modify Create Average Coordinate file so that a surface

shape file containing the standard deviation for each node in relation to the surfaces it was averaged from.

  • (10 Sep) Add ability to use a

surface shape column as a node position uncertainty that can be enabled on the Display Control Dialog's Surface Shape panel.

  • (13 Sep) Separate gaussian computation from Metric Mapping into

it own class.  Add gaussian smoothing to metric smoothing for both caret and command line metric smoothing.

  • (13 Sep) Add option on Open Data File dialog to indicate than an

SPM2 volume is being read that has the right on the left.

  • (14 Sep) Modify spherical registration so that it deforms

individual coordinate files to the atlas.

  • (15 Sep) Completed geodesic

distance so that a path may now be displayed from the root node to the identified node.  Geodesic data may now be saved to a geodesic distance file including multiple geodesic queries.  Display of geodesic data is controlled on the Display Control's Geodesic panel.

  • (15 Sep) Add spherical coord files to the indiv coord files that

will be deformed to the atlas when a spherical deformation is run.

  • (15 Sep) When a flat surface is selected for display, disable

surface rotation.  It may be re-enabled by selecting the rotation axis in the toolbar.

  • (20 Sep) Modify region graph to allow all time courses for

display.

  • (21 Sep) Change spin box for  Inflate Surface Dialog's

inflation factor to step by 0.01 instead of 0.1. 

  • (21 Sep) Add new palette file editor on Attributes:Palette Menu.
  • (22 Sep) Fixed problem with floating point spin box on surface

inflation dialog by replacing floats with double in the floating point spin box widget.

  • (22 Sep) Misc changes to fMRI mapper.
  • (27 Sep) If edges only is display mode,

do not allow selection of non-edge nodes.

  • (28 Sep) Do not put "Sub Volume" in volume file sub volume names.
  • (28 Sep) When a spec file is read, determing volume data files

for any volume names that are specified with only the volume's header file.

  • (28 Sep) Update SuMS interface for host

"sumsdb" instead of "brainmap".

  • (04 Oct) Make column names longer for metric, paint, shape on

Display Control Dialog.

  • (04 Oct) Show beginning of names when Opening a Node Attribute

Data file and choosing columns for loading.

  • (04 Oct) Add new Surface ROI - Statistical Report on Paint

Subregions which performs a statistical report for each unique paint name in a selected paint column.

  • (04 Oct) Add option to Display

Control Dialog to select a paint column which is checked for MEDIAL.WALL.  If it has medial wall paint, and the option is enabled, the medial wall is colored overriding any and all overlay/underlay selections.

  • (8 Oct) Add path to spec file name when starting caret and

loading a spec file (ie: caret5 -loadspec brain.spec) so that the spec file may be successfully opened using File:Recent Spec File.

  • (11 Oct) Separate OpenGL code from graphical user interface so

that it can be used by WebCaret.

  • (11 Oct) Fixed problem with changing border color line size.
  • (11 Oct) Fixed bug with copying spec file that caused files to

disappear if both the new and copied spec file were in the same directory.

  • (12 Oct) Create a default set of sections

(1mm Y-axis) when a brain set is loaded that contains a fiducial surface.

  • (12 Oct) Fixed bug for display of sections (needed to delete

display lists).

  • (12 Oct) Fixed bug for display of ROI highlighted nodes.
  • (12 Oct) Moved some code involving node display flags from

BrainModelOpenGL to BrainSet and BrainSetNodeAttribute for better WebCaret compatibility.

  • (12 Oct) Fixed bug in Metric & Surface Shape file that was

requesting way to much memory.

  • (13 Oct) Add gaussian smoothing for metric

data that uses a spherical surface for some distance cutoffs.  Updated caret_metric.

  • (13 Oct) Fixes for after contour and volume reconstruction.
  • (14 Oct) If a viewing window is open, show

the name of its brain model in the window menu.

  • (14 Oct) Replace icon on standard dialogs with the caret icon.
  • (14 Oct) Fix text for metric color palette

bar.  Skip QFont code in BrainModelOpenGL for WebCaret.

  • (14 Oct) Add volume resampling by entering

the desired voxel sizes.

  • (14 Oct) If a file is not found, prepend "(FILE NOT FOUND)" to

its name on the spec file dialog.

  • (14 Oct) Add spherical retessellation on Surface:Topology menu

when caret is started with the flag "-test".

  • (15 Oct) Add display of euler count on surface information dialog.
  • (15 Oct) Add SID button on Identify Dialog

to inhibit the display of green symbols on the surface.

  • (15 Oct) Add display control of volume crosshairs to Display

Control Dialog's Overlay/Underlay Volume page.

  • (15 Oct) Add anatomy volume thresholding (green above upper

threshold, blue below lower threshold) to the Anatomy Histogram available on the Display Control Dialog's Overlay/Underlay Volume page.

  • (15 Oct) Fix import of SUMA RGB file with color components

ranging 0.0 to 1.0.

  • (18 Oct) Add rotation to volume

display and ability to apply the rotation to the displayed volumes.  Also added ability to apply a transformation matrix volume files.

  • (18 Oct) Fix RGB coloring when it is the underlay to not allow

anything to show through.

  • (18 Oct) Add continuous rotation to the Automatic Rotation dialog.
  • (20 Oct) Add Dialog for editing parameters file.
  • (29 Oct) Fixed crash that occurred if the Map Functional Volumes

to Metric dialog was selected and at least one brain model other than a surface was loaded.

  • (29 Oct) Remove splash image and show surface after loading a

spec file (bug fix).

  • (29 Oct) "Show Surface" pushbutton on Display Control's Surface

and Volume panel had no effect when display lists were enabled (bug fix).

  • (01 Nov) After loading a volume file, do not check to see if all

voxels are less than one and delay color assignment until the first volume is loaded.

  • (02 Nov) Only allow volume  rotations when the "Rotation

Enabled" item on the Volume:Transform menu is checked.

  • (02 Nov) Fix uploading of volume files so that

the header AND the data are uploaded when only the header is selected.

  • (03 Nov) Fix crash if a spec file loaded with a coord file and no

or invalid topology file.

  • (03 Nov) Restored lost functionality that displays a cross over

the surface in other windows when a node is identified or a voxel is identified.

  • (03 Nov) Modify gaussian function so that it is now exp(x*x /

2*sigma*sigma).  Previously "2" was not in denominator.

  • (16 Nov) Replace VolumeFile with a version that

does not use VTK to store the volume data.

  • (16 Nov) Enable Map to Caret With Atlas when any surface is

loaded and atlases are available.

  • (17 Nov) Add ability to segment an anatomical volume, produce a

segmentation volume, and generate  raw and fiducial surfaces.

  • (17 Nov) Improve 3D border

drawing by determining the triangle under the cursor and using the barycentric position in the triangle to place the border point.  Previously the border points were pulled to the nearest node.

  • (18 Nov) Allow update of comments in volume files on disk through

the Open Data File dialog.

  • (18 Nov) Change "New Spec" button on Spec File Diaog to "Create

New Spec" and warn user if choosing an existing spec file name.

  • (18 Nov) Fixes for Convert Data Files Dialog.  Had two "Add

Files" button and one of them should have been "Remove Files".  Also remove all files when Close button is selected.

  • (18 Nov) When reading a segmentation volume assume any non-zero

voxel is part of the segmentation and changes its value to 255.

  • (18 Nov) Add translucent display of segmentation volumes.
  • (19 Nov) Add ability to combine two paint volume files using

Volume:Mathematical Operations  Dialog and choosing to combine paint volumes.

  • (22 Nov) Add Probabilistic Atlas Analysis to Surface Region of

Interest Dialog.

  • (22 Nov) Fix glitch with display of threshold probabilistic atlas.
  • (22 Nov) Add adjustable transparency for segmentation volume.
  • (22 Nov) Add ability to set name of output volume on volume

mathematics dialog.

  • (22 Nov) Add ability to write volume brick files gzipped.
  • (22 Nov) Add ability to read/write paint volumes from/to AFNI

volume files.

  • (23 Nov) Fix bug that caused part of the surface to be clipped at

times.  This would only happen after a volume had been viewed and the user switched back to viewing a surface.  When a volume was drawn, it was overriding the near and far clipping planes.

  • (23 Nov) Speed up surface coloring by applying coloring from

first surface to all other surfaces with the same color selections.

  • (24 Nov) Add ability to save

all volumes of a specified type (anatomy,  paint, etc) to a single multi-volume AFNI file.

  • (29 Nov) Fixed problem with deformed coordinate file being given

hemisphere "unknown" which causes standard view buttons in toolbar to work incorrectly.

  • (29 Nov) Fixed bug with a program error being printed regarding

an invalid display list when surface to volume conversions were performed.  Solution was to create an "operator equals ()" for AbstractFile and prevent the display list number from being copied.

  • (29 Nov) Provide more information on Save Data File Dialog when

saving an AFNI volume about proper file naming.

  • (29 Nov) Creating batch deformation file, omit file parameters

that are blank.

  • (29 Nov) During flattening of a full hemisphere, while creating

the landmarks for registration, remove the last link in the dorsal and ventral medial wall landmarks so that they do not overlap.  If there is an overlap, it may cause crossovers during registration.

  • (29 Nov) Fixed reading of version 0 topography files.
  • (30 Nov) Added volume region of interest dialog with

probabilistic paint analysis query.

  • (01 Dec) Additions to volume region of interest dialog.

 Added selection by segmentation volume, thresholded anatomy volume, and thresholded functional volume.  Add segmentation and paint name center of gravity queries.

  • (01 Dec) Add Compress Front Face to the Surface: Geometry menu.
  • (01 Dec) Add button to save the contents of the histogram dialog

to an image file.

  • (06 Dec) Fix combining paint volumes so that the output volume

may be one of the input volumes.

  • (06 Dec) Change separator characters in region of interest

reports to a semicolon instead of a tab.

  • (07 Dec) Display translucent

uncertainty circles on the volume slices if a "Node ID Deviation" column of the Surface Shape file is enabled on the Display Control Dialog.

  • (07 Dec) Increase initial width of Idenfity Dialog so that all of

toolbar is visable.

  • (08 Dec) Add subject to header of SpecFile and allow it to be set

on the spec file dialog.  If the species, subject, and hemisphere are valid, new file names will default to "species.subject.hem.file-type-name.date.num-nodes".  "num-nodes" is only present for node attribute files.

  • (09 Dec) Add file extension to default file names.
  • (14 Dec) Fix default peaks on histogram dialog.
  • (14 Dec) Keep track of volume file type on Save Data

File Dialog and Import File Dialog.

  • (14 Dec) Fixed problem with voxel crosshairs not jumping to

identified voxel in volume display.

  • (14 Dec) When borders projected, make border projection file

"modified".

  • (15 Dec) Update ".pro" files for FreeBSD O/S courtesy of Jason at

MCW.

  • (15 Dec) Corrections for recently installed compress

front face.

  • (15 Dec) Ignore nodes with names "GYRAL", "GYRUS", or "???" in

threshold probabilistic node coloring.

  • (15 Dec) Display all paint volume names when a paint

volume voxel is selected.

  • (16 Dec) Fix crash that occurred when a histogram dialog was

displayed without peaks.

  • (16 Dec) Add labels and comments for sub-bricks in a

volume.  When a multi-volume file is read into Caret, each sub-brick is stored in its own "volume-file" in memory.  Labels and comments can now be set for each of these using the "?" button on the view current files dialog or on the display control dialog's overlay/underlay - volume panel.

  • (16 Dec) Add item to file menu to set current directory.
  • (16 Dec) Add Text File Editor to File menu.
  • (20 Dec) Add probabilistic atlas volumes.
  • (20 Dec) Fix bug with handle finding crashing.
  • (20 Dec) Add item to Surface:Geometry menu to scale a

sphere to the surface area of the fiducial surface.

  • (21 Dec) Add Layers:Compute Average Separation Between Border

Point Pairs.

  • (21 Dec) Fix reading of an unusual AFNI volume whose Z origin was

large and in Inferior-to-Superior orientation.

  • (22 Dec) Corrections/changes to volume probabilistic atlas normal

coloring to make voxels darker if ??? (undefined) names are contributing to the voxel.

  • (22 Dec) Fixed bug with new output volume naming on the Volume

Mathematics Dialog.

  • (22 Dec) Fixed bug that did not update Display Control Dialog

probabilistic atlas volume panel when a probabilistic atlas volume was loaded after loading the spec file.

  • (22 Dec) Fix prob atlas threshold to paint conversion.
  • (22 Dec) Added Volume:Probabilistic Atlas:Convert Probabilistic

Atlas to Functional which stores in the functional voxel the number of valid identifications for that voxel in all probabilistic atlas channels and areas that are enabled.

  • (23 Dec) Changed display of voxel data in the Identify Dialog.

 All functional, paint, prob atlas, rgb, and segmentation data is shown for the voxel.

  • (23 Dec) Fixed Import Data File dialog, had forgotten

to add Prob Atlas Volume type.

  • (23 Dec) Fixed writing of volume data when the volume

data originated as a byte with a scale factor.  For now, Caret writes float volumes (unless RGB).

  • (27 Dec) Added palette coloring

for surface shape.

  • (27 Dec) Added positive and

negative minimum values for metric coloring.  This allows greater control over palette colors to non-thresholded metric values.

  • (27 Dec) Use "*" to separate file name in preferences

files since a space is a valid file name character.

  • (27 Dec) Add ability to set color and thickness for surface

outline displayed over a volume slice.

  • (28 Dec) Add export to minc volume.  When reading a minc

volume use directional cosines for orientation.

  • (28 Dec) Add progress dialog to deformation.
  • (28 Dec) Print out paint names for which there are no

area colors when assigning node colors.

  • (28 Dec) Improved 3D border drawing.
  • (29 Dec) When Display Control Dialog is launched, default to O/U

- Volume page if there are volumes but no surfaces loaded.

  • (29 Dec) Change volume cropping

stuff to that a volume may also be made larger (now "resize" instead of "crop").

  • (29 Dec) Enable Surface and

Volume anytime an anatomical volume is loaded.  A fiducial surface is no longer requried.

  • (29 Dec) Add display of segmentation volume cloud in Surface and

Volume.

  • (30 Dec) Change point assignment within closed border

to assume points have Z equals 0.0.

  • (30 Dec) Add Padding of segmentation volumes.
  • (03 Jan 2005) Corrected problem with coord and topo files
Personal tools
Sums Database