Caret:Documentation/ChangeLog2005

From Van Essen Lab

Jump to: navigation, search

Change Log 2005

  • (30 Dec 2005) Remove widget names from QT constructors in

preparation for conversion to QT4.

  • (29 Dec 2005) Fixed bug in caret_volume and Caret's Volume

Mathematical Operations that always caused a non-matching dimensions error.

  • (29 Dec 2005) Remove OSX_COMPILER_BUG stuff since compiler on Mac

was fixed long ago to properly initialize std::string that are a static member of a class.

  • (29 Dec 2005) Consolidate stereotaxic space, species, category,

and structure code.

  • (28 Dec 2005) Changes made to SpecFile code internals to support

multiple structures.

  • (23 Dec 2005) Add optional distortion correction via a metric

column for surface region of interest statistical report.

  • (20 Dec 2005) Fixed bug that caused a data file to be reported

modified when it had not been modified but just copied.

  • (20 Dec 2005) For scenes, default window placement to leave main

window at its location but place all other windows relative to the main window.

  • (19 Dec 2005) Modified Interpolate Surfaces so that surface

scaling is interpolated.  Previously, the scaling of the first surface in the sequence was used for all surfaces in the sequence.

  • (19 Dec 2005) Correct bug on Windows that caused problem with

Automatic Rotation Dialogs fixed rotation spin box.

  • (19 Dec 2005) On Volume Attributes Dialog and Surface to Volume

Dialog there is an option to get paramters from a volume file.  This option now converts the parameters read from the volume file to an LPI orientation.

  • (15 Dec 2005) Fixed some problems that were found with NIFTI file

format during various Caret operations.

  • (15 Dec 2005) When reading a VolumeFile and determining its file

type by using the file's extension, convert the extension to lowercase since MS Windows or the SFTP client we use seems to sometimes make ".HEAD" files into ".head" files.

  • (13 Dec 2005) Implement preliminary NIFTI Data File format for

Coordinates, Topology, Metric, Shape, Paint, and Probabilistic Atlas.  For Node Data files, each column is stored in a separate piece of  memory rather than one huge contiguous piece.  The NIFTI files may also be read and written in XML format.

  • (2 Dec 2005) Install kludge to get around strange problem on

windows.  Creating movies of a flat surface resulted in smeared images.  The problem was narrowed to the fact that lighting was off.  So, when capturing movies on windows of a flat surface, turn lighing on prior to capturing an image of the flat surface and turn lighting off after capturing an image of the flat surface.

  • (1 Dec 2005) Add Find Interhemispheric Clusters to

Attributes:Surface Shape menu.

  • (1 Dec 2005) Surface Shape Find Significant Clusters: allow

metric or shape file for distortion correction file.

  • (1 Dec 2005) Fix install script on Mac OSX so that it does not

try to set permissions on the no longer existing "luts" directory.

  • (30 Nov 2005) Show thresholds on Surface Shape Significant

Cluster report.

  • (22 Nov 2005) Fixed problem with reconstruction of primate brains

from volumes with unusual voxel sizes on Windows.  Solution was a new version of VTK (see 17 Nov 2005).

  • (22 Nov 2005) Add a new Palette, "PSYCH-NO-NONE", that is similar

to the PSYCH palette but does not have the NONE color.

  • (22 Nov 2005) Fix metric coloring so that nodes that are between

pos-min and neg-min are not colored.  Update labels on Display Control to add ">" to pos-min and "<equals" to neg-min.

  • (22 Nov 2005) Surface Region of Interest Dialog: Add "And Not"

selection which selects nodes that are currently selected but NOT selected in the new selection.  Allow creation of new metric and surface shape column when assigning the respective values.

  • (22 Nov 2005) Surface Shape Find Significant Clusters: compute

degrees of freedom and p-value for t-map and only use the biggest cluster from each of the shuffled t-maps.

  • (18 Nov 2005) Add

non-uniformity correction to Edit Volume Attributes: Data page.

  • (18 Nov 2005) Add surface offset to volume script builder's

Intersect Volume With Surface.

  • (17 Nov 2005) Surface reconstruction from volume polygon

decimation is now optional but decimation is defaulted on.  The decimation algorithm is failing to work properly on one PC with several primate species.

  • (14 Nov 2005) Fix palette color bar for functional volume viewing.
  • (11 Nov 2005) Fix deleting of all contours.
  • (11 Nov 2005) Prevent crash if reconstructon from contours fails.
  • (11 Nov 2005) Correct display of contours on oblique volume

slices.

  • (11 Nov 2005) Correct filtering of contour cells on Spec File

Dialog.

  • (10 Nov 2005) Fix editing of segmentation and paint volumes when

"ALL" slices are viewed in the main window.

  • (9 Nov 2005) Add AC-PC

alignment to Edit Volume Attributes dialog.

  • (8 Nov 2005) Add adjustable sampling for oblique volume slice

viewing to Display Control's Volume Settings page.

  • (8 Nov 2005) Add contour and contour cell files to the list of

available transform data files.

  • (7 Nov 2005) Change error message when orienting a surface so

that a paint named set of nodes is oriented away from the user.  This primarily occurs if the user is trying to flatten a partial hemisphere and the CUT.FACE nodes are not identified.

  • (1 Nov 2005) Fixed bug with deformation file naming that occurred

if the output spec file listed in the deformation map contained a path.

  • (1 Nov 2005) Fixed bug with deformation of a coordinate file that

occurred if the topology file could not be read.

  • (25 Oct 2005) In full hemisphere flattening, moved straggler tile

removal to prior to pushing the sphere flat.  This corrects a problem with a node along surface edge being dragged to the origin.

  • (24 Oct 2005) Use only selected shape columns for surface shape

cluster analysis report.

  • (24 Oct 2005) Contour alignment and MDplot import fixes. 
  • (12 Oct 2005) Multi-Fiducial Mapper - Fixed anomoly that if only

mapping to the averaged coord file, the algorithm was still mapping to all of the individual cases.

  • (12 Oct 2005) On Spec File Dialog, change the Select All and

Deselect All push buttons so that they only select or deselect files that are currently shown using the file display filter toolbar buttons.

  • (11 Oct 2005) Fix zooming of oblique volume slices.
  • (11 Oct 2005) When in view mode and a transformation axis is

selected, avoid performing any ID Node or Voxel operations.

  • (10 Oct 2005) Add metric deformation (nearest node or average of

nodes) to Apply Deformation Dialog.

  • (10 Oct 2005) Corrected numerics on metric palette color bar when

user scale is selected with the positive or negative minimum not eqaul to zero.

  • (07 Oct 2005) Fixed problems with display of oblique volume

slices and transformation cells on the oblique slices.

  • (06 Oct 2005) Add a Model Editor that allows the color of the VTK

Models to be changed.  This coloring now includes opacity.

  • (06 Oct 2005) Removed transformation matrix editor from the

Surface and Volume menus and placed it on the Window Menu.

  • (06 Oct 2005) Add opacity to VTK models.
  • (06 Oct 2005) Fix writing of VTK models in ascii format.
  • (05 Oct 2005) Add Log base 2 to metric/shape/volume data

operations.

  • (05 Oct 2005) Fixed bug in metric data deformation with tile

areas.

  • (05 Oct 2005) Change toolbar's model selection control so that it

when VOLUME is in it, it also lists the label/filename of the bottom most volume file.

  • (04 Oct 2005) Fix problem with Spec File Dialog buttons sometimes

cutoff the bottom of the dialog.

  • (04 Oct 2005) Fixes for slices selection in volume oblique slice

views.

  • (03 Oct 2005) Add import of MdPlot files.
  • (30 Sep 2005) Add node identification to montage volume views.
  • (30 Sep 2005) Fix centering of obliqe slices whose display is

controlled by a transformation matrix.

  • (29 Sep 2005) Allow display of transform data files (cell/foci)

even if the associated matrix's axes are not enabled for display.

  • (29 Sep 2005) Fix "Mutex" warning seen on MS Windows version of

Caret when using the GNU compiler.

  • (29 Sep 2005) Add identification of transform data files (cell,

foci) on oblique volume views.

  • (28 Sep 2005) Fix bug on transformation matrix dialog that turned

the signs of all scale values to negative if the user just set one to negative.

  • (28 Sep 2005) Add display of transform data files (cells and

foci) in volume oblique views.

  • (27 Sep 2005) Add montage for oblique slice views.
  • (27 Sep 2005) Now have only one Volume Oblique View Rotation

Matrix.  By default, the oblique slice views use the oblique view rotation matrix unless the user has selected a matrix from the transformation matrix file.  Integrate oblique view matrix with the transformation matrix dialog.  For oblique view slices, the slices in the toolbar are offsets from the oblique viewing slices.

  • (26 Sep 2005) Add 3D view to "ALL" view for oblique volume slices.
  • (23 Sep 2005) Add "ALL" view for oblique volume slices.
  • (22 Sep 2005) Add foci to oblique volume slice views.
  • (21 Sep 2005) Add oblique volume slice X, Y, and Z views. 

These slices are automatically yoked to the main windows Oblique View.  An option on the Display Control's Overlay/Underlay - Volume's Settings panel allows the oblique slices to be yoked to a transformation matrix.

   '
  • (19 Sep 2005) New Surface Vector

File.  Add a vectors submenu to the attributes menu.  The only item on the Vectors submenu creates vectors based upon the difference between two loaded surfaces.

  • (15 Sep 2005) When drawing borders and assigning the nodes within

the borders, allow the border assignment to operate when drawing 3D borders.

  • (15 Sep 2005) Add square root to mathematical operations on

metric, shape, and volume data.

  • (13 Sep 2005) Fixed crash when a focus was identified with only a

focus file was loaded and multiple fiducial surface files were loaded.

  • (13 Sep 2005) Fixed crash when an ID was performed in main window

immediately after a viewing window was closed.

  • (13 Sep 2005) Remove use of size in cell/foci file when drawing

cells/foci (see 12 Sep 2005).

  • (12 Sep 2005) If a voxel is indentified on a volume viewed

obliquely, use the oblique rotation matrix to determine the voxels coordinates.

  • (12 Sep 2005) Allow the user to identify multiple nodes by having

the user places spaces between the node numbers.

  • (12 Sep 2005) Use size from cell/foci file when drawing

cells/foci.

  • (09 Sep 2005) Fix bug with selection of loaded volumes for volume

to surface mapping.

  • (09 Sep 2005) Add operation to

Surface Region Of Interest Dialog that automatically draws borders around clusters of selected nodes.

  • (08 Sep 2005) Add "ring" symbol for cells and foci.  On

Display Control Dialog, allow user to override the color file symbol for cells and foci.

  • (07 Sep 2005) Fix display of foci diamond symbols on flat

surfaces.

  • (07 Sep 2005) Change surface to volume process by replacing

"thickness" with an inner and outer boundary.

  • (07 Sep 2005) Add "Validate Spec File" to the File Menu. 

This queries the user for the name of a spec file and then verifies that the spec file and its data files exist.  Copy Spec File and Zip Spec File now validate input spec file.

  • (06 Sep 2005) Surface Region of Interest Paint Subregion Report:

Add center of gravity for regions X/Y/Z/Lat/Long coordinates.

  • (06 Sep 2005) Add item to file

menu that "zips" a spec file and its data files.  In addition, the same functionality is provided by the new command line program "caret_zip_spec".

  • (02 Sep 2005) Pressing on

CTRL-Esc(ape) key combination on a window will pop up a file dialog for saving an image of the window.

  • (01 Sep 2005) Fix reading of MINC volumes whose data is not

stored in an LPI orientation (zspace, yspace, xspace).

  • (31 August 2005) When drawing a border and assigning the nodes

within the closed border to a new column, make the newly created paint column the selected paint column on the draw border dialog.

   '
  • Change version to 5.31.
  • (31 August 2005) For brain models, separate view scaling into X,

Y, and Z components.

  • (31 August 2005) Add some tooltips to the Transformation Matrix

Editor Dialog.

  • (30 August 2005) Increase width of scale spin boxes on graph

widget (used by SureFit operation's gray and white peak histogram panel).

  • (30 August 2005) Add button on Transformation Matrix Dialog to

set the matrix's translation by clicking the mouse on a object.

  • (29 August 2005) Fix some problems with rotation of

transformation matrix axes in screen space.

  • (10 August 2005) Add button to Map Stereotaxic Focus Dialog

Studies panel for deleting the selected study.

  • (09 August 2005) Replace graph on the SureFit Segmentation Dialog

with a new and improved graph for histogram display.

  • (09 August 2005) Correct histogram dialog on SureFit Segmentation

Dialog so that is lists the actual voxel values and not the voxels scaled 0 to 255.

  • (09 August 2005) Add high (original) and low thresholding for

removal of hindbrain during SureFit Segmentation.

  • (08 August 2005) Fixed crashing of SureFit Segmentation algorithm

if the eye and/or hindbrain removal is skipped.  Fixed auto-saving of surface files when inflated type surfaces are not generated.

  • (05 August 2005) Add additional attributes for color files: alpha

channel and symbol type.  Both alpha channel and symbol type are used by cells and foci.  With additions to ColorFile, write the color files in XML format.

  • (04 August 2005) Add Cell and

Foci Report that list attributes about cells/foci.  In addition, paint information for the node nearest to each cell/focus may also be shown in the report.

  • (03 August 2005) Add

mathematical operations to the command line program "caret_metric" used to modify metric files at the command line.

  • (02 August 2005) Fixed bug that failed to delete the intermediate

files created during the deformation process.

  • (02 August 2005) Bug fix for surface deformation.  If a data

file failed to deform, the deformation immediately terminated and no more data files were deformed.  Now, if a data file fails to deform, the deformation process stores the error message and continues with the deformation process.  After the deformation process has completed, error messages involving problems with deformation of data files are displayed.

  • (02 August 2005) Add cells and foci for display on volume slices.
  • (01 August 2005) Attributes:Metric:Convert Metric Column to

Functional Volume: Now have two options to interpolate (the existing functionality) or largest neighbor which sets the voxel to the larget metric value of the nodes that intersect the voxel.

  • (29 July 2005) Add "oblique"

volume viewing.  Include ability to yoke a surface in a viewing window to the volume for assisting with oblique volume orientation.

  • (28 July 2005) Draw Border Dialog: disable paint assignment if

the 3D selection is set.

  • (28 July 2005) Edit Volume Attributes Dialog: add buttons for

setting the Parameters File's AC or Whole Volume AC using the origin and voxel size.

  • (28 July 2005) Volume Resize Dialog: add option (defaulted on)

for updating the Params File X/Y/Z min with the minimum cropping values.

  • (27 July 2005) If loading a cell/foci or cell/foci projection

file and choosing to replace, delete cells/foci of all types.

  • (27 July 2005) Allow saving of cells for any surface type.
  • (27 July 2005) On reconstruct volume into

Volume:Segmentation:Reconstruct Into Surface Dialog, add option to create a hypersmoothed surface.

  • (27 July 2005) Add new StereotaxicSpace class and use for all

dealings with stereotaxic spaces.

  • (26 July 2005) Update Map Stereotaxic Focus Dialog that is split

into two tabs for "Focus" and "Studies".  Add additional GUI components for new foci data items.  Also, add button for deleting the selected focus.

  • (25 July 2005) Add additional data to cell/foci files and

cell/foci projection files all of which are now written in XML format.

  • (22 July 2005) Move common items from CellData class and

CellProjection class into new parent class CellBase.

  • (21 July 2005) Allow user to set the random number generators

seed value.  If not set by user, default seed to the number of seconds since 1970.

  • (20 July 2005) When applying a transformation to a volume, allow

the volume dimensions to grow so that the volume data does not get cropped.

  • (20 July 2005) Fixes/enhancements for volume transformations.
  • (20 July 2005) Fix but in new histogram dialog (14 July 2005) and

add an Apply button for graph scale axes.

  • (20 July 2005) Fix colors for cuts during flattening of monkey

brains but updating template borders with name of color file.

  • (20 July 2005) When a data file is saved with its name being

changed, properly keep track of loaded files for scene creation and loading.

  • (19 July 2005) For entering foci, convert "em" or "en" dash

characters (characters with varying length dashes, unicode charcters 8208 to 8213) to hyphens (minus signs).

  • (18 July 2005) Fix memory leak in VolumeFile operator equals() that

caused Caret to run out of memory during automatic error correction.

  • (18 July 2005) Fix up display of default gray/white peak

histogram on SureFit Segmentation Dialog.

  • (18 July 2005) Consolidate histogram selection combo boxes

scattered about into a single component.

  • (14 July 2005) Replace histogram dialog with a much improved

version that allows complete control of the axes' scale and a grid background.

  • (13 July 2005) Change

computation of standard deviation so that "N-1" is used for division in the formula.  This implies that the true mean is unknown and that the data is a sample from the  population.

  • (12 July 2005) Fix yoking so that if the surface is changed in a

viewing window, yoking remains selected.

  • (12 July 2005) For surface shape cluster analysis on ROI dialog,

warn user if no metric column is available for distortion correction.

  • (12 July 2005) Add "MFM" to multi-fiducial mapping statisitical

measurement column names.

  • (12 July 2005) Fixed bug that caused a crash if a volume file was

loaded and the metric cluster and smoothing dialog was displayed.

  • (11 July 2005) Fix bug in Surface: Region of Interest: Surface

Shape Cluster Analysis.  Any previously run cluster analyses are probably incorrect.

  • (07 July 2005) For Attributes Menu Compute Mean and Deviation on

Metric/Shape, allow user to choose what should be computed and set the column names.

  • (07 July 2005) When switching from a flat surface with rotation

axis set to OFF to a non-flat surface, default the rotation to XY.

  • (07 July 2005) Default Reference Column on Surface ROI: Surface

Shape Correlation Report to ALL.

  • (06 July 2005) Change Attributes:Surface Shape:Subtract Group

Average on Shape Files so that it operates on two surface shape files.

  • (06 July 2005) Fixed bug that occurred when the Surface Region of

Interest Dialog was open and the number of metric, paint, or shape columns was reduced.

  • (06 July 2005) Add more text about shape file to Surface Region

of Interest text report.

  • (06 July 2005) Add option on Attributes:Surface Shape menu to

normalize all columns in a surface shape file.

  • (06 July 2005) For Attributes:Surface Shape: Compute T Map

Shuffled Column, default coloring mapping to +/- 5.0.

  • (05 July 2005) Add fitting of metric or surface shape column data

to a normal distribution.

  • (05 July 2005) Fix crash that happened when loading a topography

file.

  • (01 July 2005)  Add Vector

Volumes which store a volume of vectors as a 4 component volume with the first three components being the unit vector and the last component being the magnitude.

  • (29 June 2005) Allow events to process during SureFit Error

Correction.

  • (28 June 2005) For SureFit operations, if generating a

segmentation and performing error correction, generate a surface from the initial segmentation and display it so that user can verify that there are no major problems such as the skull hanging around.

  • (28 June 2005) Fix near to planes in volume script builder.
  • (28 June 2005) Add surface shape cluster report to surface region

of interest operations.

  • (27 June 2005) Fix 3D border drawing.
  • (27 June 2005) Correct application of a transformation matrix to

a volume.

  • (26 June 2005) Add a few annotations to the Display Control

Dialog.

  • (26 June 2005) Make dialog that shows errors encountered while

checking all scenes non-modal.

  • (26 June 2005) Change warning message when unloading all files

but scene and spec and there are modified data files.

  • (26 June 2005) Enable a vector file to be written as text.
  • (26 June 2005) When reporting foci stereotaxic position, always

report the position on the active fiducial surface.

  • (26 June 2005) For scenes, retain the topology file assigned to

each of the displayed surfaces.

  • (23 June 2005) Fix scene check bug for deleted surfaces still

appearing to be present.

  • (23 June 2005) Add computation of Z-maps and T-maps for surface

shape files.

  • (22 June 2005) Allow cells and foci drawn as sphere to have a

size less than 1.0.

  • (21 June 2005) Set all volume coloring invalid when scene changed.
  • (21 June 2005) When checking scenes, verify that all needed files

are in the Spec File.


REMAINING CHANGE ARE LISTED OLDEST TO NEWEST
  • (03 Jan 2005) Corrected problem with coord and topo files

sometimes showing up as "(FILE NOT FOUND)" on the spec file dialog.

  • (03 Jan 2005) When deforming a node attribute data file (metric,

paint, etc) make sure it has a sufficient number of nodes so that it will work with the deformation map file.

  • (03 Jan 2005) Add Remove Islands to Volume: Segmentation menu.
  • (05 Jan 2005) Changed Surface:Topology:Disconnect Islands to

Remove Islands.

  • (05 Jan 2005) Added Topology

Error Report to Surface:Topology menu.  This performs a number of topological check to verify a surface is correct.

  • (05 Jan 2005) Add volume ROI paint percentage report.
  • (07 Jan 2005) Added Topology Error Report to Volume: Segmentation

Volume.  This approximately counts handles, cavities, objects.

  • (07 Jan 2005) Add generatation of cerebral hull volume

to Volume: Segmentation menu.

  • (10 Jan 2005) Fix 30 Dec change so that only assume points have Z

equals 0.0 for border inclusion check if the non-negative only flag is false.

  • (14 Jan 2005) Fixed problems with SureFit segmentation algorithm

so that the segmentation now matches that produced by the soon to be old SureFit program.

  • (14 Jan 2005) Add surface shape depth, surface shape curvature,

and paint sulcal identification to the SureFit segmentation process.

  • (14 Jan 2005) Change Edit Volume Attributes Dialog so that it no

longer requires that the volume whose attributes are being edited is in the main window.  Instead, it warns the user, allowing the user to continue or cancel.

  • (14 Jan 2005) Add item to File menu to Close the current

spec file (reset caret to its startup state).

  • (14 Jan 2005) Fix import of minc byte volume files to that 0 to

255 range is restored instead of being scaled 0 to 1.

  • (24 Jan 2005) Additional information added to Surface Topology

Report Dialog.

  • (24 Jan 2005) Do not allow assignment of a topology file to a

surface if the topology file references node numbers greater than the number of coordinates in the surface.

  • (25 Jan 2005) Add read and write support for NIFTI volume

files.  Caret can read a NIFTI file that it writes but no NIFTI files are available for testing at this time.

  • (25 Jan 2005) Fixed problem with upload of Volume File pairs

(header and data) data file not receiving the proper parent ID when a spec file is uploaded.

  • (25 Jan 2005) When uploading files to SuMS make sure all of the

files exist prior to starting the upload.

  • (26 Jan 2005) Modify data files for future support of XML

reading and writing.  Change SumsFileListFile, GenericXmlFile and CocomacConnectivityFile for new implementation of XML file reading.

  • (26 Jan 2005) Add keyboard commands for controling the view of

brain models loaded in Caret.

  • (27 Jan 2005) Added ability to write a coordinate file in

XML format with the coordinate data base64 encoded.  This is just for experimentation purposes at this time.

  • (27 Jan 2005) Correct generation of lat/long for nodes with X equals 0.

 They were getting long equals 0 but should have been +90 or -90. 

  • (28 Jan 2005) Modify keyboard commands so that they use the same

control/shift keys as the mouse.

  • (28 Jan 2005) Started adding a "transformation axis" that

will be used to project objects not in surface space into the surface space.

  • (28 Jan 2005) Added a new

drawing mode "tiles-links-nodes" designed for use with surface editing.  It first draw the surface as lighted tiles using the current coloring.  It then draws the links and nodes in blue.

  • (31 Jan 2005) Add option for metric/shape/volume math replace NaN

with zero.

  • (31 Jan 2005) Fix problem with volume attribute operations

when the volume is in the main window.

  • (2 Feb 2005) Update Mac OSX, Linux, and Windows version of

Caret5 to use QT 3.3.4.

  • (2 Feb 2005) Fix errors in flat multi-resolution morphing caused

by 24 Jan 2005 change that checked for topology file compatibility with coord files.

  • (2 Feb 2005) Add transformation matrices available to each

loaded VTK model file.

  • (3 Feb 2005) Switch mouse mode between view and transformation

axes when the axes are clicked with the mouse.

  • (3 Feb 2005) Modify rotation of transformation axes so that the

mouse and keyboard controls rotate and pan in screen space.

  • (3 Feb 2005) With a surface or volume viewed, pressing the

"m, l, d, v, a, p, r " keys switches to the default view medial, lateral, dorsal, ventral, anterior, posterior, and reset.

  • (4 Feb 2005) Now have

thresholding separate for each column in a metric file.  Thresholds are initially set while mapping functional volumes.  Also, an option has been added to show below threshold nodes in green.

  • (7 Feb 2005) Corrections for spherical lat/long border generation.
  • (8 Feb 2005) New "average" threshold column for metric and set

the average threshold during mapping of a functional volume.

  • (8 Feb 2005) Allow application of a transformation matrix to

border, cell, foci, and vtk model files.

  • (8 Feb 2005) Add writing of VTK model files.
  • (9 Feb 2005) Change SuMS interface so that files are sorted by

most recent date.

  • (9 Feb 2005) Modify transformation matrix dialog to get the

matrix from displayed surface or transformation axes and transfer matrix to transformation axes view.  Also load view for volume or surface and volume.  Apply matrix to surface and volume.

  • (9 Feb 2005) Replace scale bar with axes that optionally show

tickmarks and orientation labels.

  • (10 Feb 2005) Corrections for latitude and longitude +/-.
  • (10 Feb 2005) Combine the Map

Functional Volume to Metric and the Map Paint Volume to Paint File into a single item on the Attributes Menu named Map Volume(s) to Surface(s).

  • (11 Feb 2005) Add volume

montage display mode controlled on the Display Control Dialog's Overlay/Underlay - Volume panel.

  • (15 Feb 2005) Fix problem with an OpenGL error when selecting a

transformation axis with the mouse.

  • (15 Feb 2005) Fixed appending of Transformation Matrix Files.
  • (17 Feb 2005) Add ability to view a transformation matrix as a

set of coordinate axes.

  • (21 Feb 2005) Add Show Deformation Variability to Surface:

Deformation menu.

  • (21 Feb 2005) Added FLIRT and

MRITOTAL fmri mapping data files.

  • (21 Feb 2005) During deformation, set the configuration_id to

flat or spherical for the resampled deformation borders.

  • (23 Feb 2005) Add info to project cells/foci dialog, that in most

cases, the fiducial surface must be in an AC centered space.

  • (25 Feb 2005) Add ability to read some files (cells, foci, and

vtk models) that are displayed in the space of a transformation matrix axes.

  • (3 Mar 2005) Correct origin for AFNI Talairach volume provided by

VolumeFile.

  • (9 Mar 2005) Add initial implementation of automatic error

correction to segmentation process.

  • (10 Mar 2005) Create some default matrices for AC to Native and

Native to AC transformations.

  • (11 Mar 2005) Create a command line program "caret_volume" for

performing operations on volumes at the command line.  Current capabilities include thresholding and segmentation.

  • (14 Mar 2005) Remove spaces from surface type names in

BrainModelSurface which fixes a bug for file names added to the spec file on MS Windows.

  • (14 Mar 2005) Fix date in default file naming for windows which

was putting in the memory address instead of the date.

  • (14 Mar 2005) Add new dialog for creating the name of a spec file

when the user chooses to create a spec file.

  • (14 Mar 2005) Fix problem with Compressed Medial Wall surface

being upside down during flattening.  I'm not sure what caused this but it may have been caused by some of the transformation changes made in February.

  • (14 Mar 2005) When a topology file is loaded, update topology

selection on the surface ROI dialog.

  • (15 Mar 2005) On Flatten Hemisphere Dialog, try to automatically

determine if the fiducial surface is AC-centered.

  • (15 Mar 2005) Add button to Volume Attributes Dialog to set a

volume's origin using the Main Window Crosshairs as the Anterior Commissure location.

  • (16 Mar 2005) Add a scroll

widget for contents of the Display Control Dialog due to its panels becoming too large for some monitors.

  • (16 Mar 2005) Add padding to partial hemisphere segmentation.
  • (17 Mar 2005) Add a check in flat deformation to ensure that both

source and target have borders that begin with the name "LANDMARK", "landmark", "morph.", or "MORPH.".  The flat_fluid program only uses borders with these extensions.

  • (21 Mar 2005) When generating a surface from a segmentation,

remove any islands.

  • (21 Mar 2005) Put lots of C-library functions such as sqrt or

atan in the std:: namespace which is required by the Borland C++ compiler for MS Windows.

  • (22 Mar 2005) Correct problem with volume cropping crosshairs

sometimes incorrectly being shown.

  • (25 Mar 2005) If the only

command line argument passed to Caret5 is a spec file, automatically load the Spec File into the Spec File Dialog.  This allows Microsoft Windows User's to double click spec files to start Caret5.

  • (25 Mar 2005) When writing a Volume File, set the file type

(AFNI, SPM, etc) based upon the header file's name's extension.

  • (25 Mar 2005) Fixed crash that occurred when Cancel button was

pressed on Create Spec File Name Dialog.

  • (25 Mar 2005) Make sure there is surface coloring after the

initial stage of flattening a full hemisphere.

  • (25 Mar 2005) Fix bug that occaisionally erroneously reported

premature end of file when reading a Palette File.

  • (25 Mar 2005) Change a couple of float spin boxes on the

Deformation - Flat Dialog to line edits due to a problem noticed only on Linux.

  • (25 Mar 2005) When reconstructing a volume to a surface, set the

surface's orientation to the volume' s orientation.

  • (28 Mar 2005) Remove progress dialog when deformation exists due

to an exception such as a missing file.

  • (28 Mar 2005) Hide volume to surface mapping dialog while

operation is executing.

  • (28 Mar 2005) Pack items on various display control dialog pages

to take up less space.

  • (28 Mar 2005) Identify Dialog: do not display voxel info when "V"

is unselected, remove "N" node option, change "All" to "All-N" for all node information.

  • (30 Mar 2005) Rearranged some items on the Display Control

Dialog's Overlay/Underlay pages for both surface and volume.

  • (31 Mar 2005) Add a "Deselect All" to the Spec File Dialog to

deselect all files.

  • (31 Mar 2005) Change volume drawing so that there is only one

threshold, not a min and max.

  • (31 Mar 2005) Embed a histogram dialog into the SureFit

segmentation dialog to set the anatomy volume's gray and white matter peaks.

  • (31 Mar 2005) NOW VERSION 5.2.
  • (1 Apr 2005) Allow volume specified in spec file to be minc

volumes.

  • (1 Apr 2005) If Open Data File Dialog is used to open a border

file and there is no configuration_id in the border file, allow the user to specify the type of border file.

  • (4 April 2005) Add ability to delete the border projection file

on the view current files dialog.

  • (4 April 2005) If the user tries to open a coordinate or topology

file of an unknown type, ask the user for the type of the file.

  • (4 April 2005) When reconstructing a segmentation volume into a

surface, a hole in the surface will result if any voxels in the edges slices are on.  So, during reconstruction, pad the volume by one slice to prevent this problem.

  • (4 April 2005) Fix problem with column widths for metric and

paint that occurred when the display control dialog was displayed prior to loading a metric or paint file.

06 April 2005 - Release Caret 5.2

  • (8 April 2005) Fixed independent surface coloring. 
  • (13 April 2005) Initial

implementation of scene which saves the state of overlays and underlays, windows open, window contents, and window positions.  This data file is in XML format.

   
  • (13 April 2005) Mac users can

now start Caret5 by double-clicking a spec file in the finder Prior to double-clicking any spec file for the first time, the user must press the mouse once to select the and choose Get Info from Finder's File Menu.  Click the menu below "Open with:" and select other and then find the Caret5 application.

  • (13 April 2005) Speed up node coloring when a surface has

identical coloring as the first brain model.

  • (13 April 2005) Remove SureFit Crossover Check and set primary

overlay to crossovers if any crossovers are found.

  • (13 April 2005) When using SureFit Segmentation Dialog to set the

anatomy volume histogram, draw the thresholded regions in translucent green.

  • (13 April 2005) Do not require that voxel sizes be 1.0 in SureFit

Segmentation.

  • (13 April 2005) Require voxel range in SureFit Segmentation to be

[0, 255].

  • (14 April 2005) Add a multi-slice volume view that shows the

horizontal, parasaggital, and coronal views in one window.  This view is selected by selecting "All" from the volume slice control in the main or viewing window toolbar.

  • (14 April 2005) Change version to 5.201.
  • (14 April 2005) Added an option on the spec file dialog to select

a transformation matrix.  If a matrix is selected, the matrix will be applied to raw and fiducial border, cell, coord, foci, and volume files.

  • (15 April 2005) Add identification to volume slice ALL view.
  • (15 April 2005) Fix comment updater for XML files.
  • (15 April 2005) When saving scenes, always save highlighted

nodes, properly use deformation field vectors, and always save surface shape.

  • (15 April 2005) Position Display Control and Identify Dialogs and

Viewing Windows just off the Main Window.

  • (18 April 2005) Fixed setting of palette from a scene file.
  • (18 April 2005) Fixed widths of some sub-widgets on D/C Dialog.
  • (18 April 2005) Add Save As Image pushbutton to D/C Dialog.
  • (18 April 2005) Changes made to read newer CoCoMac files. 

On Open Data File Dialog, allow CoCoMac files to use ".xml" extension.

  • (18 April 2005) Add copy sub-volume to segmentation volume

editing.

  • (18 April 2005) Add volume label to Save Data File Dialog.
  • (19 April 2005) Caret5 was

crashing on a Windows XP system while "initializing data" during Spec File loading.  OpenGL library vendor was listed as Intel.  Installing Microsoft's software OpenGL libraries into Caret5's "bin" directory eliminated the problem.

  • (20 April 2005) Add ability to generate create a segmentation by

just thresholding an anatomical volume.

  • (20 April 2005) When generating a surface from a segmentation

volume allow the user to choose between generating a brain model surface or a vtk model file.

  • (20 April 2005) Add a segmentation voxel editing mode that allows

the user to select a piece of segmentation and discard all segmentation voxels not connected to the selected voxel.

  • (21 April 2005) Add option on Display Control Dialog's Surface

and Volume page to inhibit drawing of black voxels when volume slices are drawn.

  • (21 April 2005) Correct reading of VTK model files.
  • (21 April 2005) Add option to set volume coordinates using Params

File's Whole Volume AC location.

  • (21 April 2005) Add default transformation matrices if AC Whole

Volume parameters available.

  • (21 April 2005) Add identification of VTK model files.
  • (21 April 2005) Add scene saving for Surface and Volume

parameters.

  • (22 April 2005) On MS Windows, sometimes received a "File is not

writable" message.  Code to check for file being writable has been disabled.  May be a Samba issue (http://lists.trolltech.com/qt-interest/2004-01/thread00623-0.html).

  • (26 April 2005) Modify scene

implementation so that it keeps track of all loaded files.  If files needed for a scene are not in memory, Caret5 will automatically load them so that the scene is correctly displayed.

  • (26 April 2005) Add opacity for VTK model display.
  • (26 April 2005) Transformation Matrix Editor.  When a new

matrix is created, allow the user to choose the default values from an identity matrix, the current matrix, the current volume slices' stereotaxic coordinates, or the item at the center of the window when a surface is displayed.

  • (26 April 2005) Show axes letters (x, y, z) for transformation

axes in volume view.

  • (27 April 2005) Modify saving of scene for transformation axes

display.

  • (27 April 2005) Add Layers Menu items for converting borders,

cells, and foci to VTK models.

  • (27 April 2005) Fix flickering hourglass during volume

segmentation voxel editing.

  • (27 April 2005) Add scene replacement on Display Control Dialog's

Scene page.

  • (27 April 2005) Changed copy spec file so that it always copies

the scene file.  This is necessary since the scene file contains paths that are typically relative to the spec file.

  • (27 April 2005) When user is saving a scene, warn user if there

are any unsaved data files (except scene file).

  • (27 April 2005) Add a scene filter button on the Spec File Dialog

toolbar.

  • (28 April 2005) Various changes for scene processing.
  • (28 April 2005) Fixes for one millimeter error in coordinates of

WU NIL ifh volumes.

  • (28 April 2005) Show name of spec file on the View Current Files

Dialog.

  • (28 April 2005) Add button on volume attributes to set the

spacing and origin for a volume using standard stereotaxic space parameters.  Only those spaces with matching dimensions are shown.

  • (28 April 2005) Update projected files when surface scaled or

translated.

  • (29 April 2005) Update non-projected files (borders, foci, cells)

when surface scaled or translated.

  • (29 April 2005) Add a voxel scaling operation to the Volume

Attributes Dialog's Data page.

  • (29 April 2005) Made some fixes for scene operations with

cocomac, prob atlas, and node IDs.

  • (3 May 2005) Add many more operations to the command line program

"caret_ volume".

  • (4 May 2005) When reset button in toolbar is pressed, it is

possible that the voxel with the (0, 0. 0) stereotaxic coordinate may be outside the volume.  In this case, get as close to this voxel as possible.

  • (4 May 2005) Fixed drawing of volume borders.
  • (4 May 2005) Corrected label on Transformation Matrix Dialog for

applying a transformation matrix to a volume.

  • (5 May 2005) Fix bug with volume border drawing.
  • (5 May 2005) Fix bug with applying volume rotation.
  • (5 May 2005) Initial

implementation of volume operation script builder.

  • (9 May 2005) Fix some scene bugs: small jumps in window

positions, deformation field never removed, surface outline color on volume slice, and surface shape palette selection.

  • (9 May 2005) Add image viewing

windows selectable from the Window menu.

  • (10 May 2005) Fix display of scene files on Spec File Dialog when

all files shown.

  • (10 May 2005) Incorporate image windows into scenes.
  • (11 May 2005) Made changes to correctly read WU-NIL ifh volume

header files.

  • (11 May 2005) Add a Print Main Window item to the file menu to

print an image of the main window.  Note: printing does not seem to work on Windows versions of Caret5.

  • (11 May 2005) Add option to Volume Math Dialog to copy a volume.
  • (12 May 2005) On Spec File Dialog, if only volume files are

shown, also show area colors files if there are any paint or prob atlas volumes listed.

  • (12 May 2005) When drawing borders on a volume, allow assignment

of paint volume voxel within the closed border.

  • (12 May 2005) Add editing of paint volume voxels.  Voxels

are editing similar to segmentation voxels in that the mouse pointer functions as a paint brush.

  • (13 May 2005) Transformation Matrix Editor - when new matrix

created, add option to set its values to the main windows view transformation matrix.

  • (13 May 2005) Scene fixes including failing to keep track of

files that are loaded via the toolbar's "spec" button.  Remove restrictions on names of scenes.

  • (13 May 2005) Fixed bug that was failing to unregister closed

image windows that would cause Caret to crash at a later time.

  • (13 May 2005) Eliminate some messages about data files modified

when saving or recreating a scene.

  • (16 May 2005) Draw surface outline over volume slices using

triangles instead of links.

  • (16 May 2005) In metric comment for mapping functional volumes to

surfaces, add the unit "mm" for neighbors in the comments.

  • (16 May 2005) Limit width of channel and area pages for

probabilistic atlas on Display Control Dialog.

  • (16 May 2005) Correct update of active fiducial surface on

Display Control Dialog's Surface Miscellaneous Page.

  • (16 May 2005) Save active fiducial surface to the scene file.
  • (16 May 2005) When mapping a volume to a multi-fiducial atlas,

list the surfaces in alphabetical order.

  • (16 May 2005) When a coordinate file is saved, the topology file

used by the coordinate file is placed into the header of the coordinate file.  When loading the coordinate file and its cooresponding topo file is not loaded, automatically load the needed topo file.

  • (16 May 2005) Check for duplicate node attribute file column

names when creating/replacing or showing a scene.

  • (17 May 2005) When mapping a volume to multiple surfaces, try to

determine the case name and include case name in the metric data column name.

  • (17 May 2005) While uploading files to SuMS, hide the SuMS

interface dialog.

  • (17 May 2005) Fixed bug that caused the "map to caret" buttons on

the volume to surface mapper dialog to be incorrectly disabled.

  • (17 May 2005) Do not let the Animate or Histogram buttons on the

Display Control's Metric page be the default button.

  • (17 May 2005) If a spec file is loaded and only scene files were

selected, popup the Display Control Dialog and show its scene page.

  • (18 May 2005) Add option to determine the minimum and maximum

columns when performing multi-fiducial mapping of functional volumes to surfaces.

  • (18 May 2005) When showing all 3 volume slices in a window, also

show the fiducial surface.

  • (18 May 2005) When uploading a scene file to SuMS, strip the

paths off any of the files listed in the SpecFile section of the SceneFile.

  • (19 May 2005) Add opacity for volume overlays.
  • (19 May 2005) Minor changes for items on map volume to surface

dialog.

  • (19 May 2005) Add average for math operations on metric, shape,

and volume files.

  • (20 May 2005) Add choice of color for identified node symbols on

the Display Control Dialog's Surface Miscellaneous page.

  • (20 May 2005) Remove all model viewing windows when changing the

scene.

  • (20 May 2005) Make entry of volume thresholds when mapping

functional volumes optional.

  • (23 May 2005) Add an Image Editor to File Menu that allows

viewing and editing (annotating, cropping, and resizing) of images.

  • (24 May 2005) Add item to Layers menu to copy the volume borders

to the fiducial borders.

  • (24 May 2005) Add item to Volume Menu to create a new volume.
  • (24 May 2005) Add image opening and saving to image editing

window.

  • (24 May 2005) Enhance the text file editor.
  • (25 May 2005) Fixed bug with replacing a scene.  Now saves

all settings, not just those for selected data types.

  • (25 May 2005) Fix crash caused by a color palette referencing a

non-existant color.

  • (26 May 2005) Correct reading and writing of AFNI volume origins.
  • (26 May 2005) Add printing to image editor window.
  • (26 May 2005) Add printing to the text file editor.
  • (27 May 2005) Add some additional operations: find limits,

intersect volume with surface, make plane, and pad volume to the caret_volume command line program.  Updated script builder for these new commands.

  • (31 May 2005) When applying a transform to a volume use nearest

neighbor interpolation for paint, prob atlas, segmenation, and rgb volumes and cubic interpolation for anatomical and functional volumes.

  • (31 May 2005) On Transformation Matrix Editor, correct loading of

main window volume view transform.

  • (31 May 2005) Fix possible problem with current directory being

altered when mapping a volume to a surface.

  • (31 May 2005) Allow specification of voxel data type when writing

a volume file.  Save Data File dialog only shows voxel data types that are valid for the type of volume file selected.

  • (1 June 2005) Corrected problem with mapping to multi-fiducial

but only outputting the average.

  • (1 June 2005) When saving a volume file, warn user if the voxel

values of the volume are outside the valid values for the selected data type.

  • (1 June 2005) Change display of images so that the center of the

image is placed in the center of the main window.

  • (1 June 2005) Set the Z value of an image so that it is "far

behind" the model in the main window.

  • (1 June 2005) Fix problem with main window resize handle not

being on the right side of the status bar.

  • (2 June 2005) Add some more information to error message during

deformation of a border projection file.

  • (2 June 2005) Add the program "caret_edit" for editing text

files.  This is just a stand alone version of the text file editor available on the File Menu.  This simple text editor handles all of the different platform dependent line feeds.

  • (3 June 2005) Fixed bug with brain model viewing windows only

showing up some of time when a scene was selected.  The GUI system need to time to process its events so that it could close the windows when a scene was selected, prior to reopening the windows.

  • (6 Jun 2005) fMRI Mapping: average fiducial coord file now added

to atlas spec files.  Selection of average, deviation, etc. is now made each time a mapping atlas is selected.

  • (6 Jun 2005) When saving a gzipped volume, make sure ".gz"

extension is on the data file's name in the spec file.

  • (6 June 2005) Add "Load Scene(s)" push button to Spec File

Dialog.  This will load all scene files and nothing else.

  • (7 June 2005) When loading node attribute file (metric, paint,

etc) from Open Data File Dialog or Toolbar Spec button, if Erase All Columns is selected, switch the comment option to Replace.

  • (7 June 2005) Require at least an overlay or underlay volume for

drawing borders on volumes.

  • (7 June 2005) When the viewed image in an image viewing window is

changed by the user, preserve the view scaling.

  • (7 June 2005) Fixed deletion of surface shape file on view

current files dialog.

  • (7 June 2005) On both Open and Save Data File Dialogs, corrected

saving of previous directories (was one level too high) and update viewed files using selected filter when a previous directory is selected.

  • (7 June 2005) Add separate control for display of palette color

bar on volume display.

  • (7 June 2005) Change version to 5.3.
  • (7 June 2005) If there is a selected deformation map file, make

it the default deformation map on the Apply Deformation Map Dialog.

  • (7 June 2005) When showing a scene, avoid closing any model

viewing windows that are needed by the new scene.

  • (7 June 2005) Fix crash that occurred when the Display Control

Dialog was popped up for the first time after opening and closing a model viewing window.

  • (8 June 2005) Add more mathematical operations for metric, shape,

and volume.  New operations set a range of values (inclusive or exclusive) to zero.

  • (8 June 2005) Add slice thickness when drawing volume borders.
  • (8 June 2005) Default rotation for surfaes is now XY.
  • (8 June 2005) Fix so opacity for VTK models allows transformation

axes to be seen.

  • (9 June 2005) Hide SuMS Database Dialog while files are

downloading.

  • (9 June 2005) Add Identify Dialog to scenes.
  • (10 June 2005) Avoid scrolling list of scenes in Display Control

Dialog when a scene is selected for viewing.

  • (13 June 2005) In the caret_volume program, disregard the debug

on setting in the user's preferences file.  When caret_volume is run from Caret's script builder and output from caret_volume is 8173 characters, caret_volume gets stuck writing I/O.  caret_volume still works fine from the command line.

  • (13 June 2005) Fix size of model combo box on model viewing

windows.

  • (13 June 2005) Make Display Control: Shape: Settings page wider

so full name of palette may be seen.

  • (14 June 2005) Use full path to caret_volume program in volume

script builder.  Warn if the environment variable CARET_DEBUG is on since excessive output causes programs executed with QProcess to hang.

  • (14 June 2005) Fix command line switch for make sphere operation

in caret_volume program.

  • (17 June 2005) Add scene insertion.
  • (17 June 2005) Print more information if Caret runs out of memory

including an option to exit Caret.

  • (17 June 2005) Add option on Display Control Scene page to cycle

through scenes and verify that they are valid.

  • (17 June 2005) Add ability to send scenes from one Caret

application to another.

  • (20 June 2005) Various fixes for caret_volume command line

program.

  • (20 June 2005) Fix Volume to Surface Mapper for Mapping

Individual to Spec File.

20 June 2005 - Release Caret 5.3

Personal tools
Sums Database