Caret:Documentation/ChangeLog2006

From Van Essen Lab

Jump to: navigation, search

Contents

Change Log 2006

  • (26 Dec 2006) Added volume yoking which is selected witht the

Yoke button on a Viewing Window Toolbar.  When on, the selected slices in the main window and the yoked viewing windows will be the same anytime a selected slices is changed by using the slice controls in the Toolbars or by identifying a voxel with the mouse.

  • (22 Dec 2006) When reading a Comma Separated Value File (such as

one that contains foci), check for unicode's various dash codes (em-dash, en-dash, etc.   0x2010 to 0x2015) and underscores.  If any are found convert them to minus signs.  In addition, print a warning message for any text to floating point number conversions that fail.

  • (15 Dec 2006) Fixed bug in surface areal smoothing that set a

node's XYZ coordinate to (0, 0, 0) if the node and its neighbors all have the exact same XYZ coordinate.  The smoothing algorithm uses the area of triangles formed by a node and its neighbors and since the nodes all have the same XYZ coordinate, the area of these triangles was zero.  The area of the triangles is used as a weight which results in the weighted average of the neighbor's coordinates becoming (0, 0, 0).  Since we use a smoothing strength of 1.0, a smoothed node's new coordinates are entirely that of the neighbor's coordinates' weighted average.  The smoothing algorithm now performs no smoothing of a node if the node and its neighbors all have the same XYZ coordinate.  In particular, this problem was noticed with deforming a hull surface from one individual to another.  It may also be the cause of occaisional problems noticed in multi-resolution morphing.

  • (13 Dec 2006) Add one-sample T-Test, Paired T-Test, and

Interhemispheric Clusters to Statistical Algorithm Dialog.

  • (12 Dec 2006) On statistical algorithm dialog, enabled running of

two-sample T-Test and Wilcoxon into Two-Sample T-Test operations.  Split surface files and cluster search parameters into separate pages.

  • (12 Dec 2006) Add ability to run the metric/shape statistical

permutation algorithms (one-sample t-test, two-sample t-test, paired t-test, etc.) using caret_command.

  • (11 Dec 2006) Add distance and (x,y,z) components to output

metric file of the metric/surface shape t-map coordinate group difference.

  • (11 Dec 2006) Add opacity to border, cell, and foci display.
  • (11 Dec 2006) Add a polygon reduction option to caret_command's

-volume-segment operation.

  • (08 Dec 2006) Enable the cluster search used in the shape/metric

file statisical permuation algorithms to run as multiple threads in order to reduce execution time.

  • (08 Dec 2006) Modified SureFit segmentation algorithm so that it

may produce volume types other than AFNI (such as NIFTI).

  • (06 Dec 2006) Allow a choice of symbols (OpenGL-points, squares,

boxes, rings, spheres, diamonds) for border drawing.

  • (06 Dec 2006) Add "square" symbol for drawing foci.  This is

similar to the existing point symbol, except that the square scales with the size of the surface.  This is unlike the Point symbol (which is draw using OpenGL's GL_POINT) which remains fixed in size even though the size of the surfaces changes.

  • (06 Dec 2006) Add median and abs-median to Surface Region of

Interest Statistical Report.

  • (06 Dec 2006) Fixed crash that occurred if Caret was unable to

open a file for writing.

  • (05 Dec 2006) Fixed problem in segmentation automatic error

correction that prevented reporting of problems to the user due to an improperlay handled exception.

  • (04 Dec 2006) Fixed failure to display crossovers on initial flat

surface at the end of flattening.

  • (01 Dec 2006) Add command line option "-notext" that disables

OpenGL text rendering.  Some Linux systems have a problem with the FreeType library that will cause Caret to crash.

  • (01 Dec 2006) Change XML file identification to look for the

first ascii character that is not a space, tab, newline, or linefeed.  If this first ascii character is a '<' it will assume the file is an XML file.

  • (28 Nov 2006) Modify GuiBrainModelOpenGL to delete the memory for

BrainModelOpenGL when all windows are closed.

  • (27 Nov 2006) Added "Integrated Folding Index" to the Surface

Region of Interest Dialog.  Integrated Folding Index is for each surface shape column and equal to SUM(Ai * Fi) / SUM(Ai) where Ai is the area of a triangle and Fi is the average of the surface shape value's for the triangle's three nodes.

  • (22 Nov 2006) Added a new method named "crossover search" that

searches for topological defects in a segmentation volume.  This method operates by generating a spherical surface from the segmentation volume, smoothes the spherical surface, and then checks for crossovers in the spherical surface.  Any crossovers are mapped into the segmentation volume's space to an RGB volume and to the RGB paint file on the surface.

  • (20 Nov 2006) Added -surface-to-volume option to caret_command

for creating a volume from a metric/paint/shape surface file.

  • (20 Nov 2006) Speed up mouse processing for contour alignment

translation on Linux and Windows.

  • (20 Nov 2006) Fix contour set scaling when the scaling has

already been set.

  • (17 Nov 2006) Bug fix to make checkable the Enable Rotation on

Volume->Transform menu item.

  • (17 Nov 2006) Changes to OpenGL code for offscreen rendering.
  • (16 Nov 2006) Added to the caret_command program:

-caret-data-file-compare which compares the data contents of two Caret data files of the same type.

  • (15 Nov 2006) Enable volume yoking so that a volume in the Main

Window may be yoked to a volume in one or more Viewing Windows.  Yoking is selected by using the Yoke button in the Viewing Window(s) Toolbar.

  • (15 Nov 2006) Add button to Toolbar in Viewing Windows, label

"UO" (Underlay Only), that is shown when the window displays a volume.  If this button is toggled on, only the underlay volume is shown.  This option has been added to assist in segmentation volume voxel editing where the Main Window contains an anatomical volume overlayed with the segmentation volume.

  • (15 Nov 2006) Had some problems with exceptions messages (such as

an error reading a file) displaying incorrectly.  Replacing C-character strings with QStrings seems to have fixed the problem.

  • (15 Nov 2006) Fixed some paint file reading error messages.
  • (14 Nov 2006) Fixed reading of NIFTI volume file when the

orientation is not X {L,R}, Y {P, A}, Z {I, S}, such as AIL, so that the voxel sizes and spacing are correctly set.

  • (14 Nov 2006) When creating an MPEG1 or MPEG2 movie, check to see

if the movie file name is writable.  If not, pop up an error message.  Unfortunately on MS Windows, if the file is writable but the directory is not writable, QT still reports the file as writable.  The MPEG encoder will then crash Caret when it tries to open the movie file.

  • (13 Nov 2006) Looked into a problem with the colors being

incorrect in the temporary images used to create a movie file with the program mpeg_create on MS Windows.  The problem is that the bytes are being written in the wrong endian when writing the temporary PPM image file.  However, the program mpeg_create expects them to be in this incorrect order, so, fixing the writing of the PPM images cannot be done as mpeg_create would no longer work correctly.

  • (10 Nov 2006) When saving a foci file, allow the user to choose

saving of the original stereotaxic coordinates or the coordinates of the foci projected to left and/or right surfaces.

  • (10 Nov 2006) When a node is identified on a surface in a window,

also show the coordinates of that node for surfaces displayed in other windows.

  • (09 Nov 2006) Fix error message for PALS foci projection when the

foci's coordinate is invalid.  Remove debug print message when saving a foci file.

  • (07 Nov 2006) Change version to

5.502.

  • (07 Nov 2006) Made a changes to Flatten Full Hemisphere so that

there are not two compressed medial wall surfaces at the step in which the medial wall and cuts are edited.

  • (07 Nov 2006) When saving a topology file, default the topology

file selected in the Save Data File Dialog to the topology file used by the main window surface.

  • (06 Nov 2006) When reconstructing contours into a surface, create

a section file containing the sections corresponding to the nodes.

  • (06 Nov 2006) Popup a message when cleanup contours is run.
  • (06 Nov 2006) Fix View Current Files dialog so that border files

are not always listed, even when no borders are loaded.

  • (06 Nov 2006) When a node was identified Caret was not updating

the toolbar in windows viewing volumes.

  • (06 Nov 2006) When saving a foci file, allow the user to choose

both left and right surfaces for the unprojection of foci projections into a foci file.  Also, Caret was erroneously setting the file modification status of the foci projection file when saving a foci file.

  • (02 Nov 2006) When translating a surface using one of the Surface

Menu->Transform menu items, do not transform cells or foci since they should be loaded as projection files.

  • (02 Nov 2006) Fix setting of contour Z-coordinate when drawing

and reading contours.

  • (02 Nov 2006) Add identification symbols to contours.  If a

contour point highlighted and a surface is loaded, hightlight the corresponding node in the surface.  If a node in the surface is identified, hightlight the corresponding contour point.

  • (02 Nov 2006) Replace left/right hemisphere checkboxes with a

structure selection control on contour reconstruction dialog.

  • (02 Nov 2006) Change colors of contours to a darker green.
  • (01 Nov 2006) Add a cross at the origin of contour drawing.
  • (01 Nov 2006) Inhibit the drawing of cells in their original

color and position when being aligned.

  • (01 Nov 2006) Slow mouse speed used during contour alignment.
  • (01 Nov 2006) Using a depth test for image drawing messed up

surface rendering (See 31 Oct 2006).  Instead, set the Z-value for the image near the far clipping plane.

  • (31 Oct 2006) Fixed bug that caused contours to disappear that

were in the same section as that of a new contour being drawn while the new contour was being drawn.

  • (31 Oct 2006) Fixed bug that caused some contour cells to

disappear when new contours in a different section were being drawn.

  • (31 Oct 2006) When drawing contours and only single section is

being displayed, set the selected to the section of the new contour when drawing of the new contour is completed.

  • (31 Oct 2006) If the contour number in the draw contour dialog is

changed, set the mouse mode to contour drawing.

  • (31 Oct 2006) Add legends describing necessary mouse clicks to

Contour Set Scale Dialog.  Fix setting of contour scaling.

  • (31 Oct 2006) Add Hide All Contours to Contour Selection Dialog.
  • (31 Oct 2006) Change image Z-value so that contours with negative

Z-values show up in front of the image.

  • (30 Oct 2006) If mapping a NIFTI functional volume, add the

intention and TR to the metric column comment.

  • (30 Oct 2006) Fix bug that caused Caret to crash if there were

contours loaded and an MDPlot file was imported without appending selected.

  • (27 Oct 2006) Add a Help button to the Display Control Dialog

that shows the dialog's help page.

  • (27 Oct 2006) Add the title of the Main Window's current spec

file to the title of the Display Control Dialog.

  • (27 Oct 2006) Fix determination of caret installation directory

for command line programs on Mac OSX.

  • (26 Oct 2006) Fixed reading of CSV foci file Study Info Comments.
  • (24 Oct 2006) Decrease the minimum scaling for contours so that

the user may zoom out further.

  • (24 Oct 2006) Made fixes for reading MDPlot contour files.
  • (24 Oct 2006) Rewrote and moved identification code into

BrainModelIdentification which is located in the BrainSet.  This eliminates code duplicated in WebCaret and results in WebCaret showing the exact same text as Caret when an item is identified.

  • (20 Oct 2006) Add image comparison (-image-compare) to

caret_command.

  • (19 Oct 2006) Add a flag to the BrainSet that is only set by

WebCaret.  If set and a scene file is read, paths associated with any file listed in the scene file will be removed.  This is because SuMS stores all files associated with a spec file in a single directory.

  • (19 Oct 2006) Modifiy

caret_command so that if it is run with "-help", a list of all of the commands is displayed.  Running caret_command with "-help-full" will show full information on each command.

  • (19 Oct 2006) Modify caret_command's "-show-scene",

"-show-surface", and "-show-volume" so that the volume file is optional, and, if not specified, the image of the scene/surface/volume is not saved in a file but is displayed in a window on the user's display.

  • (19 Oct 2006) Add "-image-view" to caret_command which displays

an image file in a window on the user's display.  Due to a limitation on Macs (the program is built as a simple executable and not a Mac Application), scrollbars are available only on Linux and Windows.

  • (19 Oct 2006) Add "-show-volume"

to caret_command which generates an image of a volume.

  • (18 Oct 2006) When saving a scene, save the width and height of

the OpenGL widget so that it may be used later when caret_command cxommands a scene for diplay.  This ensures that the window size exactly matches the width and height of the saved window.

  • (13 Oct 2006) Add "-show-scene"

to caret_command with renders the main window image of a scene to an image file.

  • (13 Oct 2006) When constructing a BrainSet from a topo/coord file

pair, set the BrainSet's structure to that of the coord file.

  • (13 Oct 2006) Fix Spec File's remove paths from filenames.
  • (13 Oct 2006) Add

"-show-surface" to caret_command which generates an image of surface in one or all of the standard views.

  • (12 Oct 2006) Make color names in the color key dialog appear as

hyperlinks if vocabulary information is available.

  • (11 Oct 2006) Simplify cropping on the image editor window.
  • (11 Oct 2006) Fix default file naming for border and border

projection files.

  • (11 Oct 2006) Use QT's QFile::errorString() when Caret is unable

to read or write a file.

  • (04 Oct 2006) Fix removal of watch cursor when loading a border

file through the open data file dialog.

  • (03 Oct 2006) Add an optional "point radius" to border and border

projection links that will be used, in some cases, a variability measurement.  Add two new Border Drawing modes that show the border link variability with or without connected line segments.

  • (03 Oct 2006) When generating average borders, also add a

variability measurement to the links of the average border.

  • (03 Oct 2006) Add -surface-border-variability to caret_command

that resamples a border file so that the borders have the same number of links as borders with corresponding names in another border file and set the variability.

  • (03 Oct 2006) Add -surface-border-nibbler to caret_command that

remove links from a named border in a border file.  The user may use a surface node or extrema to set a plane used for removing links.

  • (03 Oct 2006) Add -surface-border-extrema that lists the extrema

(bounds) for a surface and a border in a border file and also shows the difference.

  • (27 Sep 2006) Fixed a bug with editing the comment in a

multi-brick volume file on disk using the data file comment editor from the Open Data File Dialog.  The bug resulted in the volume containing only one brick instead of all of the bricks in a multi-brick volume file.  Now, none of the bricks are lost.

  • (27 Sep 2006) Fixed a bug that caused Caret to crash if a

probabilistic atlas volume with only one channel was loaded.

  • (26 Sep 2006) Modify the node attribute selection combo box to

prevent problems with it if there is more than one spec file loaded.

   '
  • (25 Sep 2006) Add a new toggle

button, labeled "S", to the toolbar that is displayed when viewing a volume.  When the button is toggled on and the volume is being viewed in an orthogonal axis, the slice numeric controls instead show stereotaxic coordinates.

  • (25 Sep 2006) Use common widget for entering and editing studies

for foci and vocabulary.

  • (25 Sep 2006) When loading a file via the Toolbar's "Spec"

button, only ask Append/Replace if there is data of the corresponding type loaded.

  • (25 Sep 2006) Change Caret version to 5.501.

Release Caret 5.5 (22 September 2006)

  • (22 Sep 2006) Add Layers->Borders->Create Borders From

Paint Regions which creates borders around all paint regions in a selected column.  It will probably work best on a surface with a closed topology.

  • (20 Sep 2006) Fix setting of column names for old, old, version 0

paint files.

  • (20 Sep 2006) Change Layers->Foci->Delete Non-Displayed

Foci to "Delete Foci Not Displayed on Main Window Surface".  When choosing foci for deletion, also use status of show foci on correct hemisphere only option.

  • (20 Sep 2006) Fix problem with reading files containing long

lines.  This problem was traced to a bug in Trolltech's QT Software

Bug Report

which would only read the first 4095 characters in a line.  So, any files with lines longer than 4095 were not read correctly.

  • (19 Sep 2006) When creating a new spec file on the spec file

dialog, close current spec file and reopen the new spec file into a new spec file dialog.

  • (19 Sep 2006) Require a volume's existing voxel sizes to be

positive and the resampling voxel sizes to be positive.

  • (19 Sep 2006) When saving a volume file using the Save Data File

Dialog, default the volume to the volume of the selected type that is selected on the Display Control Dialog's Volume - Overlay/Underlay page.

  • (19 Sep 2006) Enable double-clicking of a cell in the file

viewing table for editing the cell's contents in a text editor.

  • (19 Sep 2006) Multi-Fiducial Metric Mapping changes: (1) Default

column names are now AFM for average fiducial mapping and MFM for multi-fiducial mapping.  When available, include hemisphere in column name.  (2) Default comments are now "Average Fiducial Mapping (AFM)" and "Multi-Fiducial Mapping (MFM)".  (3) The cells in the metric naming table may be double-clicked to display and more easily edit the cell's text.

  • (15 Sep 2006) Fixed writing of cell/foci files in Comma Separated

Value (CSV) file format.

  • (15 Sep 2006) Fixed bug that produced some print statements when

saving a border file.

  • (14 Sep 2006) Change key command used to capture an image of

caret dialogs to CTRL + SHIFT + F1.

  • (14 Sep 2006) Fixed crash that occurred if capturing an image of

part of the main window but without any of the main window selected.

  • (12 Sep 2006) Improve text editor with better search

options.  Pressing the Find toolbar button brings up a dialog for searching and replacing include case sensitive and backwards searches.

  • (12 Sep 2006) Add generation of a border grid for analysis with a

third party program.

  • (12 Sep 2006) Add foci highlighting.  A focus is highlighted

by clicking on the foci's color in the Foci Color Key Dialog.

  • (12 Sep 2006) Add vocabulary abbreviations to name selection

dialog.

  • (12 Sep 2006) Fix Surface->Transform->Apply Current View

when both translation and rotation were applied.

  • (12 Sep 2006) Got shell command window to work on Windows.
  • (11 Sep 2006) Modify Interpolate Surfaces so that it applies the

current view to the surfaces used for interpolation.

  • (11 Sep 2006) Fix Edit Paint Names Dialog.
  • (11 Sep 2006) Fix deletion of probabilistic atlas file on view

current files dialog.

  • (11 Sep 2006) Save override border colors with area colors to

scene.

  • (11 Sep 2006) Correct Metric/Shape statistics dialogs that

mistakenly read "Type II Error" but should have been "Type I Error".

  • (08 Sep 2006) Change version to

5.5.

  • (08 Sep 2006) Add Vocabulary Editor to Attributes Menu.  If

the user clicks on a name in a color key and there is a corresponding entry in the vocabulary file, information from the vocabulary file will be displayed in the Identify Window.

  • (07 Sep 2006) Made some changes to reading of cells/cell

projections from comma separated value files.

  • (06 Sep 2006) Have Identify Window's CID button clear both border

highlighting in addition to node highlighting.

  • (05 Sep 2006) Change border and paint color keys so that if the

user clicks on the color swatch, the nodes are highlighted or the border point/line size is doubled.  Clicking on the color swatch of a highlighted item turns of highlighting.  Add item to Layers->Borders menu and popup menu to clear border highlighting.

  • (05 Sep 2006) Add menu item to Attributes->Vectors Menu that

copies the main window surface's normal vectors to the surface vector file.

  • (01 Sep 2006) Fixed scene problem with node attribute files

(metric, paint, etc.) when the number of surfaces loaded exceeded the number of columns in the node attribute file.

  • (01 Sep 2006) When generating an areal estimation file, add the

border file and uncertainty value to the comment.

  • (01 Sep 2006) Increase far and near values for orthographic

projection so that the surface does not get clipped as quickly and user can zoom in further.

  • (01 Sep 2006) Add coordinate files for PALS SPM95 and SPM96 to

mapping files for use by PALS foci projection.

  • (01 Sep 2006) Add SPM96 and MACAQUE_F6 to stereotaxic spaces.
  • (31 Aug 2006) Add color key displays to the popup menu.
  • (31 Aug 2006) Add color key windows to scenes.
  • (31 Aug 2006) Add an areal estimation page to the Display Control

Dialog so that column names may be changed.

  • (31 Aug 2006) Add Color Keys for Areal Estimation, Probabilistic

Atlas, Volume Paint, and Volume Probabilistic Atlas.

  • (30 Aug 2006) Add option to Display Control Dialog's Border Page,

that overrides border colors with area colors.

  • (30 Aug 2006) Upgrade QT on Mac to 4.1.4.
  • (30 Aug 2006) Add some additional file filters to the text

editor's open/save dialogs.

  • (29 Aug 2006) Fixed file filters so that existing files are

displayed on Capture Image of Main Window Dialog's file selection dialog.

  • (29 Aug 2006) Increase width of scene selection box on Display

Control Dialog.

  • (29 Aug 2006) Move "CID" button (clears ID symbols from surface)

to the left side of the Identify Window so that is easier to access.

  • (29 Aug 2006) Modify interpolate surfaces dialog so that the

number of surface selections is equal to the number of surfaces that are loaded.

  • (29 Aug 2006) Fix problem with the surface radically changing

size at the end of the interpolate surfaces action.

  • (29 Aug 2006) Add color key

dialog for borders, cells, foci, and paint.  The color key dialog shows the names of all displayed items and a swatch of the assigned color.

  • (28 Aug 2006) Add a new metric selection option on the

Display Control Dialog.  If the "L-to-L, R-to-R Matching..." checkbox is selected and the user selects a metric column, look in the selected column's name for "left" (or "right") and and apply it to all left (or right surfaces).  Then, find the corresponding column for the other hemisphere and apply it to the remaining surfaces.

  • (28 Aug 2006) Fixed saving of Paint Medial Wall Override to a

scene.

  • (11 Aug 2006) Add spherical deformation to the caret_command

command line program.

  • (11 Aug 2006) Add optional surface shape file that will contain

uncertainty to caret_command -surface-average.

  • (11 Aug 2006) Add item to Layers->Foci menu that deletes all

colors that do not match the start of any foci name.

  • (10 Aug 2006) Add a Surface Distance metric/shape test to the

Metric/Shape Statistical operations menu.

  • (09 Aug 2006) Add surface smoothing to caret_command.
  • (09 Aug 2006) Add item to Layers->Foci menu that deletes all

non-displayed foci.

  • (07 Aug 2006) In metric/shape statistical operations, use the

topology file specified by the user.  Note: some coordinate files contain the name of a topology file in the header that is automatically loaded and assigned to the coordinate file when the coordinate file is loaded.

  • (04 Aug 2006) Add button on Display Control's Scene Page "Create

Spec From Selected Scenes" which prompts the user for a scene file name and a spec file name.  This creates a new scene file containing only the selected scenes and a spec file containing the files from the selected scenes.

  • (04 Aug 2006) Change Check All Scenes so that it unloads all file

prior to estabilishing a scene.

  • (04 Aug 2006) Fix ID window text problem that resulted in new

text being blue and underlined if a hyperlink had been clicked.

  • (03 Aug 2006) Add a new surface shape selection option on the

Display Control Dialog.  If the "L-to-L, R-to-R Matching..." checkbox is selected and the user selects a surface shape column, look in the selected column's name for "left" (or "right") and and apply it to all left (or right surfaces).  Then, find the corresponding column for the other hemisphere and apply it to the remaining surfaces.

  • (03 Aug 2006) Change message on Display Control's Scene page when

unloading all files but spec and scene.

  • (03 Aug 2006) When a focus is identified, display its position on

all fiducial surfaces with valid stereotaxic spaces.

  • (03 Aug 2006) Fix crash if trying to access a color but no colors

are loaded during probabilistic atlas coloring.

  • (03 Aug 2006) Fix normal/threshold probabilistic atlas selection

on Display Control.

  • (03 Aug 2006) Remove min/max section numbers from Main Window

Status Bar.

  • (03 Aug 2006) Change cell and foci left/right display to a single

check box Show Cells/Foci on Correct Surface only.

  • (01 Aug 2006) Add section control to scenes.
  • (01 Aug 2006) Do not require a class when entering foci on the

map stereotaxic foci dialog.

  • (01 Aug 2006) Transformation Matrix Dialog, attempt to get new

matrices created with oblique volume views to work.

  • (01 Aug 2006) When a voxel is identified in volume montage

display, center the selected volume slice in the montage.

  • (31 July 2006) Fix voxel identification for volume montage

viewing mode.

  • (31 July 2006) Change volume montage slice orders to that the

slices increase going right to left and then down to the next row of slices.

  • (31 July 2006) Allow main window transformation axes to be turned

on/off by clicking on the axes in any of the viewing windows.

  • (31 July 2006) Make volume crosshairs consistent so X is red, Y

is green, and Z is blue.

  • (28 July 2006) Add projection

of Foci to PALS atlas.  Foci are mapped to the surface that is in the same stereotaxic space as the focus.

  • (27 July 2006) Fix shortcut keys for Identify and Transformation

Matrix Editor menu items on Windows menu.

  • (27 July 2006) On transformation matrix editor and applying a

transform, have cancel button cease the process.

  • (24 July 2006) Add Levene's Test for Equality of Variance to

Metric/Shape Statistical processing.

  • (24 July 2006) Use Dcdflib for statistical P-Value computations
URL.
  • (21 July 2006) Reorganize/rewrite statistical functions and

place them in their own library.

  • (18 July 2006) Make text boxes for scene names wider on Display

Control Dialog.

  • (18 July 2006) Add item to

Caret Help Menu to search the Caret website.

  • (18 July 2006) Fix default directory selection on Copy Spec File

Dialog and add a previous directory selection.

  • (18 July 2006) Add comment button to Spec File Dialog.
  • (18 July 2006) Upgraded the

Linux version of QT to 4.1.4.  This appears to correct a bug that caused Caret to crash on startup when the style being used was Plastique.  Only some Linux systems default to the Plastique style and I do not know how this is chosen.

  • (18 July 2006) Added preliminary support for storing cells and

foci as comma separated value (CSV) files.

  • (14 July 2006) Fixed computation of P-Values when the T-Value is

less than zero.

  • (13 July 2006) When using the CTRL-Escape Key (Apple-Escape Key

on Macs) which captures an image of any caret dialog or window, allow the user to choose to copy the image to the clipboard, print the image, or save the image to a file.

  • (13 July 2006) Add one more bucket to histogram so that all

values are shown (largest value was at left side of last bucket).

  • (13 July 2006) Make range of X-min/max unlimited on graph dialog.
  • (13 July 2006) Add False Discovery Rate to T-Map generation

dialog (this may get changed soon).

  • (12 July 2006) Fix crash when displaying Volume Region of

Interest Dialog.

  • (12 July 2006) Fix surface shape clustering and smoothing.
  • (11 July 2006) Add help buttons to metric/shape statistics

dialogs that link to appropriate help page.

  • (10 July 2006) Change style of Caret data file XML headers to

remove limitations on header tag name characters.

  • (10 July 2006) Add some additional stereotaxic spaces: T88, SPM,

SPM95, SPM5.

  • (07 July 2006) Add comment section to Create Spec File Dialog and

SureFit Segmentation Dialog.  Add View/Edit comment to Open Spec File Dialog.

  • (07 July 2006) Add ticks in second plane for surfaces axes and

add an offset for the surface axes controlled through the Display Control's Surface Miscellaneous page.

  • (07 July 2006) Mac OSX Only - Modify QT source for Q3FileDialog

to set the style of the Filter Combo Box to Plastique since Mac style is way to long and stretches off the screen.

  • (07 July 2006) Fix error that made histogram dialogs modal.
  • (07 July 2006) Allow Set Topology Dialog to remain displayed at

all times instead of closing upon topology selection.

  • (05 July 2006) Change the decimation algorithm from

vtkDecimateCaret to vtkDecimatePro.  vtkDecimate was dropped from VTK version 5 so I converted it to work with VTK5 but it was difficult to control the polygon count and it is a patented algorithm.  vtkDecimatePro produces very similar surfaces with a slightly smaller polygon count the VTK4's vtkDecimate.  vtkDecimatePro is easier to use with non-human surfaces and there are no patent issues with vtkDecimatePro.

  • (05 July 2006) Fixed bug in the math utilities function

signedDistanceToPlane when converting floats to doubles in order to call a VTK math function.  This bug caused a problem with sulcal depth generation.

  • (05 July 2006) Add option (defaulted on) to the Spherical

Deformation Dialog to enable one iteration of smoothing of deformed coordinate files (except flat coordinate files).  Previously, one iteration of smoothing was always performed.  Option also added to Apply Deformation Map Dialog.

  • (03 July 2006) Surface

Registration Fixes: First, when creating the deformation map file, indicate the type of surface (flat or spherical) to BrainModelSurfacePointProjector so that it can properly projection target nodes onto the deformed source surface.  Second, the deformation map file always has the closest of the three source nodes listed first.  When the first node was not the closest, the nodes and barycentric areas were being swapped but the barycentric areas were not properly swapped. These problems were first noticed when the source surface had far fewer nodes than the target surface.

  • (30 June 2006) Add Caret Tips Window which is selectable from the

Help Menu and is automatically displayed (but can be disabled) after loading the first spec file in a caret session.

  • (30 June 2006) Update graphics window's popup menu.
  • (29 June 2006) Update the Mac Application for File Open Event.


Release Caret 5.402 Update (29 June 2006)

  • (29 June 2006) Fix Display Control's Surface Shape Min/Max

mapping spin boxes so that they allow negative values

  • (28 June 2006) Now version

5.402.

  • (28 June 2006) Fixed bug that

caused the current directory to be set to the caret installation directory during SureFit Segmentation.  This typically occurred if caret was started in a directory other than the directory containing the volume for segmentation such as on Window when double-clicking a shortcut to Caret on the Desktop.

  • (28 June 2006) Allow several surfaces, in addition to the average

fiducial, to be shown over the volume slices.

  • (27 June 2006) Add variance smoothing to metric and shape file

statistical operations.

  • (27 June 2006) Copied and

modified VTK's vtkMPEG2Writer class so that it writes MPEG1 video files.  This allows Mac users to create MPEG movies that are playable by the standard version of QuickTime media player.  It also eliminates the need to use the command line program mpeg_create to create movies although it is still supported.  This will also help windows users since mpeg_create often crashed or hung when creating movies.

  • (26 June 2006) Added an active hull surface that may be displayed

over volume slices.

  • (26 June 2006) Updated caret_command to combine surface shape

files.

  • (26 June 2006) Added Surface->Measurements->Generate

Distance: Surface A to Surface B which creates a surface shape column that contains the three-dimensional distances between two surface's coordinates.

  • (23 June 2006) Added MPEG2 movie writing using a VTK class. 

At this time, only the latest Windows Media Player run on MS Windows and mpeg2play on Linux can play MPEG2.  According to Apple, an upgrade to Quicktime (that cost $) will allow Quicktime to play MPEG2 movies.

  • (22 June 2006) Change File Menu's "Record as MPEG" to "Record

Main Window Images as Movie".

  • (22 June 2006) If the user attempts to map an ".hdr" volume to a

surface, warn the user that the volume must contain an SPM originator to be mapped correctly.

  • (22 June 2006) Enable/Disable menu items using QT4.
  • (22 June 2006) Replace

vtkDecimate with vtkDecimateCaret since vtkDecimate was dropped from VTK5.  There might be polygon reduction issues with rodent brains.  Upgrade to VTK5.

  • (21 June 2006) Replace QtFloatSpinBox with QDoubleSpinBox.
  • (21 June 2006) Compiled with QT3 support off to eliminate calls

to class methods that are not QT4 compatible.  QT4 conversion will be complete once additional widgets can be added to QFileDialog.

  • (19 June 2006) When text added to Identify Dialog automatically

scroll to the bottom of the text.

  • (19 June 2006) Fixed loss of cell class information when

projecting or unprojecting.

  • (16 June 2006) Add capture of 6 standard view image to Capture

Image of Main Window Dialog.

  • (16 June 2006) Upgraded Recording Dialog to QT4.
  • (16 June 2006) Add a page to

the SureFit Segmentation Dialog that shows the current directory and prevents the user from continuing if the current directory is the caret installation directory.  The current directory may be the installation directory if Caret was started by a shortcut on the Windows Desktop or from the Mac's Dock.

  • (16 June 2006) Add a menu item for reverse the order of points in

a contour.

  • (15 June 2006) Added drawing modes for contours so that contours

may be drawn as lines, points, or points and lines.  If drawing the first contour point in red, make the first contour point size double that of the normal contour points.

  • (15 June 2006) Fixed crash that occurred when adding a new color

using the Edit Colors dialog.

  • (15 June 2006) Upgraded SuMS Database Dialog to QT4.
  • (15 June 2006) On Surface to Volume Dialog, change "Thickness

Step" to "Intersection Step".

  • (14 June 2006) Now version 5.401.
  • (13 June 2006) Added identification of contours and contour cells

in view mode.  Enhance legends for contour append mode.

  • (13 June 2006) Upgraded code for Map Volumes To Surfaces to QT4.
  • (12 June 2006) Upgrade to QT 4.1.3.  This seems to have

corrected problems with windows popping up under the current window on Macs and fixed directory selection problems when using Set Current Directory from the File Menu.

  • (09 June 2006) Fix problem with copy/zip spec file when the

volume consisted of a header file and a volume file and the volume was in a different directory than the source spec file.


Release version 5.4  (09 June 2006)

  • (09 June 2006) Destroy the SureFit Segmtation Dialog when it is

closed so that segmentation can be restarted without having to exit and restart caret.

  • (08 June 2006) Version 5.4
  • (08 June 2006) Handle http URL's in Caret web help by displaying

the page in a web browser.

  • (07 June 2006) Fixed writing of gzipped volume files on Windows

by updating the zlib library and using buffered writing instead of unbuffered writing.

  • (05 June 2006) On Volume Math Dialog, change "Volume C" to

"Volume Output".

  • (05 June 2006) When loading a scene, do not load any scene file

from the spec file saved within the scene.

  • (05 June 2006) Move shape file statistical processing from

Surface Shape Menu to new Metric and Shape Statistical Processing Menu.

  • (05 June 2006) Save data file timeout from SuMS Dialog in the

preferences file.

  • (05 June 2006) When adding a new color, place it in its name

sorted position.

  • (02 June 2006) Correct problem with uploading volume data files

to SuMS.

  • (02 June 2006) Add one-sample and two-sample T-Tests for Metric

and Surface Shape.

  • (01 June 2006) Correct problems with interpolate surfaces not

updating the model in the main window.

  • (31 May 2006) When displaying a scene, do not let viewing windows

to be shown off the screen.

  • (30 May 2006) When mapping to the Average Fiducial Surface, set

the column threshold to the threshold entered for the respective functional volume.

  • (30 May 2006) Correct uploading of volume data files to SuMS.
  • (25 May 2006) Add NIFTI gzipped file to volume files supported by

script builder.

  • (25 May 2006) Disable image file save dialog if there are no

image files loaded.

  • (23 May 2006) Fix writing of WU NIL volumes on little endian

architectures (Intel x86, typically windows and linux).

  • (22 May 2006) Fixed problem with loading a Hull Coord File using

the Open Data File Dialog.

  • (22 May 2006) Added scroll bars to Volume Math Dialog since

dialog was getting too tall.

  • (18 May 2006) Added missing '*' to .ifh volume file filters.
  • (18 May 2006) Add update deformation path, create spec file, and

add file to spec file to the script builder.

  • (18 May 2006) Remove message about undo stack size printed when

editing segmentation voxels.

  • (17 May 2006) Now version 5.332.
  • (17 May 2006) Fix display of web page when a hyperlink is clicked

in the file comment editor (QT4 upgrade problem).

  • (17 May 2006) Make sure a display list is valid prior to deleting

it.

  • (17 May 2006) Remove multiple sets of scrollbars from Display

Control Dialog.

  • (16 May 2006) Add Clean Up Contours to the Layers->Contours

menu.  Clean Up Contours will remove consecutive, duplicate points from contours and it will remove contours with less than 3 points.  These types of contours cause problems during reconstruction.

  • (16 May 2006) Replace line edits with spin boxes on Surface to

Volume Dialog..

  • (16 May 2006) Restore volume animation that was broken during

upgrade to QT4.

  • (16 May 2006) When adding a volume file entry to a spec file,

only write the data file name if it is different than the header file name (ie: NIFTI volume is stored within a single file).

  • (16 May 2006) Scene modifications: track volume oblique slice

sampling size and the matrices associated with transformation data files.

  • (15 May 2006) NIFTI volume

reading and writing including zipped files, paint volumes, and support for the AFNI extension.

  • (12 May 2006) Add "plus_" and "minus_" to name in the paint

created by the Find Significant Clusters operation.

  • (12 May 2006) Fixed bug that prevented mapping to average

fiducial surface using the map volume to surface dialog.

  • (09 May 2006) Fix spec file update when the volume header file

name is the same but the data file name changes.

  • (03 May 2006) When page selection changed on Display Control

Dialog, scroll the page to the left and top.

  • (02 May 2006) Corrected problems with left hemisphere foci not

appearing.

  • (27 April 2006) Improved support for reading and writing NIFTI

volume files.

  • (21 April 2006) Eliminated all

QT 3 version support code from the Display Control Dialog.  This appears to have corrected two problems.  The first correction eliminates lots of little windows (border names, colors, foci, etc checkboxes) from appearing prior to the Display Control Dialog.  The second correction appears to eliminate the very slow time (minutes) that elapsed while displaying the dialog on computers with limited amounts of memory.

  • (17 April 2006) Add option to caret_command that sets the source

and target paths.

  • (13 April 2006) Now version

5.331.

  • (12 April 2006) Fixed bug found in shape file T-Map calculation

that occurred if the first shape file had fewer columns that the second shape file.

  • (04 April 2006) Replace Volume Animate start/resume/pause/stop

with a single Animate button that goes through all slices.  This change has been made because the volume animate thread does not work  in QT4.

  • (03 April 2006) Fix triangle area calculation that was replaced

vtk's triangle area a few days ago.

  • (03 April 2006) Fixed problem with bizarre characters in surface

region of interest report.

  • (31 March 2006) Fix editing of file column comments.
  • (31 March 2006) Move Image Editor and Text File Editor menu items

from the File Menu to the Window Menu.

  • (31 March 2006) Fix initial directory on Zip Spec File dialog's

choose zip file button.

  • (31 March 2006) Replace use of function tmpnam() and replace with

QDir::tempPath().   tmpname() is a possible security hole.

  • (31 March 2006) Add printing, font selection, and search/replace

to text editor.

  • (31 March 2006) Fix creation of wrong column on metric/shape

inclusive range operations.

  • (29 March 2006) When merging contours, beep if a contour is not

selected with a mouse click.   In addition, when  two contours are merged, resample the new contour so that the region between the contours will contain points.

  • (29 March 2006) Started adding an "index tree" to the help window.
  • (27 March 2006) Fixed problems with absolute paths that should

not have been on files added to the spec file in the windows version of caret.

  • (27 March 2006) For file open/save/import/export dialogs, set the

directory to the current directory.

  • (27 March 2006) Add application of a deformation map to a data

file to caret_command.

  • (24 March 2006) Fix selection of contour cells when aligning a

region of a contour.

  • (24 March 2006) Change contour region box from solid to outline

so that contours/cells are visible.

  • (24 March 2006) Warn that contour region alignment will not

function if contours are rotated.

  • (24 March 2006) Fix writing of WU ".ifh" header files.
  • (17 March 2006) Fix reading of version 1 cell projection files.
  • (17 March 2006) Fix bug that failed to create new metric/shape

column in mathematical operations.

  • (17 March 2006) Work around QT4 bug that prevented reading of

version 0 cell files.

  • (17 March 2006) Fix bug with missing items on image editor resize

dialog.

  • (16 March 2006) Force all volumes written by surefit segmentation

process to be written as floats.

  • (16 March 2006) Fixed Display Control images selection page on

windows.

  • (16 March 2006) Work around QT4 bugs for SuMS file transfers.
  • (13 March 2006) Fixed bug that prevented writing a file when the

all files preferred write type and the files read type were the same but not acceptable for an output format.

  • (13 March 2006) Fixed crash when combine paint volumes was

selected on Volume Mathematical Operations Dialog.

  • (13 March 2006) Third volume optional on volume math with script

builder.

  • (13 March 2006) Shrank font for node number on ID dialog.
  • (13 March 2006) Fixed bug on script builder that prevented

creating the script without executing the command.

  • (13 March 2006) Fixed crash that caused Caret to crash when

saving a coordinate file.

  • (10 March 2006) Fix bug that listed an invalid cerebral hull

volume as a segmentation volume.

  • (10 March 2006) Fixed script builder.
  • (10 March 2006) Put updated mingwm10.dll in windows distribution.
  • (09 March 2006) Since caret cannot handle scenes with more than

one spec file, do not allow a scene to be created if there is more than one spec file loaded.

  • (09 March 2006) Add checks for invalid surface type or topology

type when importing a surface file.

  • (09 March 2006) Add generation of sulcal depth to caret_command.
  • (07 March 2006) Fix crash when loading a paint file for a

scene.  This is a QT4 bug.

  • (07 March 2006) Fix missing Metric Mathematical Operations.


Release Version 5.33   03 March 2006

  • (03 March 2006) Fixed display of caret help on Windows.
  • (03 March 2006) Changes to set directory dialog.
  • (03 March 2006) Fix crash when space button pressed on Create

Spec File Dialog.

  • (02 March 2006) Move caret_morph command line program operations

in caret_command.

  • (01 March 2006) Add projection and unprojection of cell and foci

data.

  • (01 March 2006) Add projection and unprojection of borders to

caret_command program.

  • (01 March 2006) Add new dialog for

capturing an image of the main window to the file menu.  The menu item is named Capture Image of Main Window.  The dialog allows the user to capture an image of the entire main window or a region selected with the mouse.  The captured image may be copied to caret's loaded images, copied to the clipboard so that it can be pasted into other programs, printed, and/or saved to a file.

  • (27 Feb 2006) Update Linux compiler to GCC 4.0.2 with static

libraries to fix crash on some Linux systems with shared object libraries different that out build system.  This fixes the failure to catch exceptions that were thrown.

  • (24 Feb 2006) Fix crash in spherical deformation if the original

coordinate file contained a full path in its name.

  • (24 Feb 2006) Default align sphere checkbox checked on align

surfaces dialog.

  • (22 Feb 2006) Add conversion between caret paint file and free

surfer label files to caret_file_convert.

  • (21 Feb 2006) Add ability to generate inflated, ellipsoid, et al

using caret_command.

  • (21 Feb 2006) Add generation of hull surface when determining

sulcal depth.

  • (21 Feb 2006) Added some kludges to get around bugs in QT4.1 that

prevented writing caret files in binary format.  All file writing preference to be set to binary.

  • (20 Feb 2006) Figured out how to create simple executables for

command line programs on Mac OSX  instead of app bundles.

  • (14 Feb 2006) Replace "QtPlot" graphs with Qwt graphs.


  • (13 Feb 2006) The QT4.1 bugs

appear to also cause problems with writing files in binary format.  So, for now, the preferences always report that the user wants to write ASCII format files.

  • (13 Feb 2006) There are bugs in the QT4.1 software that cause it

to report invalid file read position and end of file status.  Code has been added to Caret5 to get around this bug until Trolltech (the writer of the QT software) corrects the problem.  All of the added code is within "#define QT4_FILE_POS_BUG".

  • (13 Feb 2006) For all color files, add the color for "???", the

unknown color, when the first color is added to the color file.

  • (10 Feb 2006) Modify caret_command so that it can add files to a

spec file.

  • (09 Feb 2006) List the name of the spec file on the File Menu's

Close Spec File menu item.

  • (07 Feb 2006) Convert SpecFile dialog and other dialogs to QT4 to

fix problems on Windows.

  • (06 Feb 2006) Fixed problem with JPEG and QT 4.
  • (06 Feb 2006) Added a FreeBSD version of Caret5 to the download

page.  This version was built by Jason at MCW.

  • (06 Feb 2006) Limit sizes of dialog windows to less than the

height of the desktop.

  • (06 Feb 2006) When a scene is selected, do not alter the main

window and position other windows relative to the main window.

  • (06 Feb 2006) Add selection for surface and topology types on

Import Data File dialog.

  • (01 Feb 2006) Add importing of Free Surfer binary format "curv"

files.

  • (01 Feb 2006) Add importing of Free Surfer binary format "w"

(weight, functional) files.

  • (01 Feb 2006) Add importing of Free Surfer binary format surface

and surface patch files.

  • (31 Jan 2006) Replace FileOperationException and FileIOException

with FileException.

  • (31 Jan 2006) Make some qmake .pro fixes for the elimination of

Borland C++.

  • (30 Jan 2006) Split toolbar into two rows with model selection

control in the bottom row.

  • (30 Jan 2006) Modify file reading to throw exception if reading a

binary format Caret file due to a bug in QT4.  Similar problem with version 0 topology file.

  • (30 Jan 2006) Modify the multi threaded algorithm class to avoid

unlocking mutexes due to a bug in the QT4 windows software.

  • (27 Jan 2006) Change Identify Sulci process in SureFit

Segmentation.  When determing the sulci for paint geography, use the CerebralHull.erode.3 volume (the cerebral hull eroded three times) instead of Sulci.3.dilate.

  • (26 Jan 2006) In Segmentation voxel editor, the size of "undo's"

was unlimited.  Now, the total "undo" size is limited to 10 Meg with a minimum of one item.  This will hopefully fix some crashes that have occurred during voxel editing.

  • (26 Jan 2006) Correct problem in error measurements at beginning

of automatic error correction noticed on Windows.

  • (24 Jan 2006) Add item to surface menu that creates a

segmentation volume from a surface.

  • (24 Jan 2006) Move script builder from Volume Menu  to

Window Menu.  Command line program caret_volume has been renamed to caret_command since it now performs non-volume operations.

  • (23 Jan 2006) Prevent possible crash in TopologyHelper with a

nodes that has zero neighbors.  Crash is noticed on Windows Caret while creating inflated surfaces.

  • (13 Jan 2006) Add support for universal binaries (power pc and

intel architectures) for Mac OSX.

  • (12 Jan 2006) Upgrade Caret5 to

use user interface software QT 4.1 (www.trolltech.com).  Caret5 runs but a QT bug prevents proper file reading.

  • (11 Jan 2006) Replace all uses of std::string with QString.
  • (06 Jan 2006) Add ability to

load multiple spec files into Caret.  All brain models are available for display.  In addition, if multiple spec files have been loaded and there are at least two active fiducial surfaces, add a selection to show all fiducial surfaces simultaneously.

  • (04 Jan 2006) Correct 3D border drawing when metric and/or shape

color palette bars are displayed.

  • (01 Jan 2006) Happy New Year !!!
Personal tools
Sums Database