Caret:Documentation/ChangeLog2007

From Van Essen Lab

Jump to: navigation, search

Change Log 2007

  • (26 Dec 2007) Remove leading and trailing whitespace from study names and

foci names so that comparing the names functions correctly when updating foci study links by matching foci names to study names.

  • (26 Dec 2007) Upgrade to QT 4.3.3 on Linux and Windows.
  • (24 Dec 2007) Added "-surface-roi-statistical-report" to

caret_command.  This new operation runs a statistical report on the nodes selected in a surface region of interest file.

  • (20 Dec 2007) Added the list of drives to sidebar of the File Dialog.
  • (19 Dec 2007) Added new Surface

Overlay System that make each overlay independent from the others.  As a result, this allows the use of a different data type in multiple overlays.  For example, three metric columns may be displayed with each column in a different overlay.  In addition, there are now three overlays and one underlay.

  • (19 Dec 2007) Fixed problem with updating study metadata links

for foci by matching the focus name to the study name.  This operation failed when a focus did not have any study metadata links.

  • (18 Dec 2007) Fixed scene problem with probabilistic atlas

volumes.

  • (13 Dec 2007) Added a "JPEG Image" movie mode to the Record Main

Window Images Dialog.  The intent is to use a program such as Apple's iMovie, Apple's QuickTime Pro, Adobe Premiere, or Microsoft's Media Encoder to convert the JPEG image sequence into a movie.

  • (13 Dec 2007) Added a button to the Viewing Window Toolbar

labeled "Swap".  When pressed, the brain model in the viewing window and the main window are swapped.

  • (07 Dec 2007) Updated QT to 4.3.3 on Mac OSX.
  • (06 Dec 2007) Added two search

capabilities to the Caret Help Window.  The first search method searches the loaded help page.  The second search method searches all help files.

  • (06 Dec 2007) Fixed problem with metric animation interpolation

using an invalid index to get/set node coloring during color interpolation.

  • (05 Dec 2007) Add All On/All Off buttons to Identify Dialog's

Filter tab.

  • (05 Dec 2007) Modifies reading of areal estimation files for

selective column loading.  Added an Areal Estimation submenu to the Attributes Menu that allows for clearing of Areal Estimation File columns and moved the Generate Areal Estimation Map menu item to this submenu.

  • (05 Dec 2007) Fixes for recording on the Recording Dialog and the

Metric Settings Display Control page.

  • (05 Dec 2007) Add control that sets the maximum distance a focus

may be from the surface to the Foci Attribute Assignment Dialog.

  • (04 Dec 2007) Modified SureFit algorithms partial hemisphere

padding so that the padding receives a light amount of erosion.  Without this erosion, most nodes in the CUT.FACE region were removed by the polygon simplification algorithm leaving many sliver triangles in the surface.

  • (03 Dec 2007) Add option to set the number of padding slices when

processing a partial hemisphere with the SureFit segmentation algorithm.

  • (30 Nov 2007) Added import of MNI OBJ Polygon File.
  • (30 Nov 2007) Finished removal of all QT3 Support code.
  • (30 Nov 2007) Add Paint Name page to the Display Control

Dialog.  This page allows selection of paint names for display.

  • (29 Nov 2007) Fixed problem with padding of partial hemisphere

segmentations.  The padding was using the last slice but should have been using the second to last slice.  See http://brainmap.wustl.edu/pub/donna/ARCHIVE/BAD_LAST_SLICE/bad_last_slice.html.

  • (29 Nov 2007) Removed mouse mode control (13 Nov 2007). 

Modified the Toolbar View button so that it now contains a small arrow.  Pressing this arrow displays a menu for common mouse modes.  In addition, the context menu (right click on Linux and Windows, CTRL-Click on Macs) display a mouse mode menu.

  • (28 Nov 2007) Improved reading of NIFTI volumes that use QFORM

for orientation information but probably not totally correct.

  • (28 Nov 2007) Fixed crash when File Menu->Set Current

Directory was used.

  • (27 Nov 2007) Scenes changes now only retain surfaces and volumes

(except probabilistic volumes).  An option for retaining foci, foci colors, and study metadata has also been added.

  • (26 Nov 2007) Changed version

to 5.512.

  • (19 Nov 2007) Add "-volume-create",

"-volume-create-in-stereotaxic-space", and "-surfaces-to-segmentation-volume-mask" to caret_command.

  • (19 Nov 2007) On Save Data File Dialog, hide prob atlas volume

selection combobox so that all prob atlas volumes are saved to a file.

  • (19 Nov 2007) Add StudyMetaDataLinks to Areal Estimation, Prob

Atlas Surface File, and Prob Atlas Volume File.

  • (19 Nov 2007) Default the File Open Dialog to the current

directory.

  • (19 Nov 2007) When a paint is identified, do not show linked

study metadata if the paint name begins with a question mark (?).  In addition do the same for metric values of zero.

  • (19 Nov 2007) On Foci Attribute Assignment Dialog, allow

deselection of a hemisphere for assignment.

  • (19 Nov 2007) Fixed display of foci geography attribute in

identification dialog.

  • (16 Nov 2007) Add "-color-file-create-missing-colors" which adds

random colors to a color file for some data files when the data file name does not have a matching color.

  • (14 Nov 2007) Fixed bug with Surface Region of Interest Dialog,

which enabled the display of ROI nodes when displayed but failed to check recheck the Show Selected Nodes checkbox.

  • (14 Nov 2007) Fixed bug that prevented the Surface

Menu->View->Switch to User View menu from being loaded with saved user views.

  • (14 Nov 2007) Fixed bug that resulted in the a WuQFileDialog

always asking the user to confirm overwriting a file even if the file did not exist.

  • (13 Nov 2007) Add import of MDPlot and Neurolucida files to

caret_command -file-convert.

  • (13 Nov 2007) Add mouse mode control to main window toolbar.
  • (12 Nov 2007) Fix -cog option for caret_command

-surface-place-foci-at-limits.

  • (12 Nov 2007) Add "Contour Information" to Layers->Contours

menu to show the geometric and section extent of the contours loaded in Caret.

  • (09 Nov 2007) Add a smoothing option to "caret_command

-surface-border-merge".

  • (08 Nov 2007) caret_command -show-scene: Fixed problem with

transformations being incorrect for windows other than the main window.  This was due to the  drawing always drawing in the "main window" and using its transformation instead of the transformation for the viewing window.

  • (07 Nov 2007) Add multiple file writing preferences.
  • (02 Nov 2007) Fix Display Control crash that occurred when a

paint column was selected on the Paint page prior to creation of the Overlay/Underlay Surface page.

  • (02 Nov 2007) Fix crash when choosing a directory on the Copy

Spec File Dialog.

  • (02 Nov 2007) Fix very slow update of Display Control Dialog's

Shape Selection Page when loading additional surface shape file data.

  • (02 Nov 2007) Fix reading of "Nearest Node" option on Border

Projection Dialog.

  • (02 Nov 2007) Fix directory only mode on WuQFileDialog.
  • (01 Nov 2007) Reformat preferences dialog.
  • (01 Nov 2007) Remove speech generation.
  • (31 Oct 2007) Add "-file-read-time" to caret_command to time the

reading of a spec file's data files and also some caret data files such as coordinate, border projection, foci projection, metric, spec, surface shape, and topology files.

  • (31 Oct 2007) Modify file filters used on Open Data File Dialog

so that shape files can be opened as metric files and metric files can be opened as shape files.

  • (30 Oct 2007) Remove QT3 compatibility flag from qmake files so

that Caret no longer uses QT3 Support library.

  • (30 Oct 2007) Added

multi-threaded spec file reading which can reduce the time to read a spec file by 30% or more.  To enable multi-threaded spec file reading, go to the Preferences Dialog (on the File Menu for Linux and Windows and Caret menu on Mac OSX) and set the File Reading Threads to at least 2.  A good setting may be 2 times the number of cores per CPU times the number of CPUs.

  • (24 Oct 2007) Add Study Data Type and Study Data Format to Study

Metadata.

  • (23 Oct 2007) Fix appending of study meta data files so that

provenance data is not lost.  When saving a study metadata file, prompt for provenance data if there are any studies without provenance data.

  • (23 Oct 2007) Fix Layers-Border option on Display Control's

Overlay/Underlay Surface page.

  • (22 Oct 2007) Add an option, "-allow-start-end-the-same", 

to "caret_command -surface-border-draw-geodesic" that allows the output border to contain only a single link.

  • (22 Oct 2007) Added support for 64-bit signed and unsigned

integer data types for NIFTI volume files.

  • (19 Oct 2007) Replace QFileDialog with WuQFileDialog, an improved

File Dialog.

  • (19 Oct 2007) Fixed problems on Open Data File Dialog involving a

copy data file error and selection of file type when using the "any" file filter.

  • (19 Oct 2007) Fixed problems on Save Data File Dialog involving

incorrect file extension (.border) added to a border projection file and not initializing the filter to the previous file filter.

  • (19 Oct 2007) Fixed Sums Dialog's upload file dialog so that it

initializes to the current directory.

  • (19 Oct 2007) Fixed prepending of column prefixes when deforming

node data files.

  • (19 Oct 2007) Fixed update of column names on Shape Math Dialog

when the column names are changed on the Display Control Dialog.

  • (17 Oct 2007) Add support for multiple Study Metadata Links.
  • (12 Oct 2007) Add a command that finds duplicate studies in

StudyMetaDataFile's to caret_command.

  • (09 Oct 2007) Add Open Inventor as one of the surface conversion

output formats for caret_command's "-file-convert".

  • (08 Oct 2007) Combine Open Data

File, Import File, and Open Image File Dialogs into a single dialog using a new and improved file dialog.  When opening files, multiple files may be selected.

  • (08 Oct 2007) Combine Save Data

File, Export File, and Save Image File Dialogs into a single dialog using a new and improved file dialog.

  • (05 Oct 2007) caret_command updates: (1) add

"-deformation-map-create" to create a deformation map file from two spherical coordinate files; (2) add conversion of caret shape file column to a free surfer curvature file.

  • (01 Oct 2007) Fixed bug that failed to display the Area attribute

on the Cell/Foci report dialog.

  • (01 Oct 2007) Added "Attribute Assignment" to the Layers->Foci

menu that is used to assign the Area and Geography attributes of Foci.

  • (28 Sep 2007) Fixed a bug that sometimes resulted in a node

attribute file (e.g. metric) having a blank column shown as selected on the Display Control even though there is data loaded.

  • (28 Sep 2007) Fixed problem with unicode characters in strings

returned by PubMed.

  • (20 Sep 2007) Fixed cell density to metric operation crash that

occurred if the metric file contained one or more columns.

  • (18 Sep 2007) Consolidate volume to surface metric and paint

mappers into a single mapper.

  • (18 Sep 2007) Fixed bug, was using maximum voxel neighbors in

strongest voxel neighbors algorithm for volume to surface metric mapping.

  • (17 Sep 2007) Add backward and forward push buttons for page

selection.

  • (17 Sep 2007) Added a variable input command to caret scripting.
  • (13 Sep 2007) Added Provenance to StudyMetaData.
  • (12 Sep 2007) Add "Generate Colors for Paints Without Colors" to

the Attribute Paint Menu.  When selected, this will generate a random color for any paint names that do not have a matching color with the exact same name.

   '
  • (12 Sep 2007) Add new caret

script builder to the Window Menu.

  • (07 Sep 2007) Fixed display of missing toolbar volume controls

when a volume in the 2nd or later brain set was selected for display.

  • (04 Sep 2007) Change version to 5.511.
   '
  • (31 Aug 2007) Completed rewrite

of "caret_command".  "caret_command" now includes the functionality of the programs "caret_file_convert", "caret_copy_spec", "caret_zip_spec", "caret_metric", and "caret_map_fmri".  As a result, these programs have been eliminated.  Since "caret_command" has been rewritten, the Script Builder Window, available from the Window Menu, has also been eliminated since it is incompatible.  In place of it, for now, is "Caret Command Executor", which provides a user-interface for executing all of caret_command's operations.  Since all of the metric/shape statistical operations are in "caret_command", and Caret Command Executor provides an interface to them, the Attributes Menu->Metric and Shape statistical operations menu has been eliminated.

  • (27 Aug 2007) Do not limit the size of foci.  If being drawn

as OpenGL points do not allow the size to  exceed the maximum OpenGL allowed size.

  • (27 Aug 2007) Add "Strongest Voxel" algorithm for mapping

functional volumes to surfaces.  For each node, its value is the value of the voxel that is furthest from zero in the local neighborhood.

  • (23 Aug 2007) Allow cell/foci report dialog to function with both

left and right hemispheres.

  • (10 Aug 2007) When "Update Focus PubMed ID if Focus Name Matches

Study" no longer clears the study link when the PubMed ID is not equal to the Project ID.

  • (31 July 2007) Fixed reading of gifti data arrays that had base64

encoding.  Using "const QByteArray ba equals text.toAscii(); and const char* textChars equals ba.constData();" instead of "const char* textChars equals text.toAscii().constData();" fixes the problem.

  • (27 July 2007) Allow multiple spec files to be selected on the

Open Spec File Dialog.  Multiple spec files are selected on the dialog by using the CTRL or SHIFT keys and the mouse to select files.

  • (24 July 2007) When caret is started with "-loadspec

spec-file-name" allow the entry of multiple spec files so that multiple spec files my be loaded simultaneously.

  • (19 July 2007) In Caret file name generation, ignore and no

longer use the date in the file name.

  • (17 July 2007) Add buttons on Surface Region of Interest Dialog

for dilating and eroding the selected nodes.

  • (17 July 2007) Modify automatic linear border drawing to generate

an error message if the starting and ending nodes in the border are not connected in the region of interest.

  • (16 July 2007) Fixed bug so that the color file symbol is

properly handled when appending a color file.

  • (13 July 2007) Add buttons on the Surface Region of Interest

Dialog for saving or loading the current node selection.

  • (06 July 2007) Fixed abort that occurred when creating a new spec

file on the spec file dialog.

  • (05 July 2007) Display study information when a vocabulary entry

with a link to study metadata is identified.

  • (05 July 2007) Correct reading/writing of study metadata links

for vocabulary files.

  • (03 July 2007) At the beginning of surface flattening, check the

surface for topological errors (handles).

  • (29 June 2007) If subject/species/hem not provided by spec file,

guess at their values by examining coord and topo file names.

  • (29 June 2007) Add "-paint-composite" to caret_command.
  • (22 June 2007) Add a full width half maximum algorithm to metric

smoothing.  This algorithm smooths until the FWHM is achieved or the maximum number of iterations is reached.  The FWHM estimation is based upon formula 2 of the Hagler et. al. article from NeuroImage 33 (2006) 1093-1103.

  • (20 June 2007) Add a "1.0 - value" operation to volume and metric

math operations.  The intended use is convert P-Values to "Q-Values".  If the users wants to threshold, say less than 0.05, it cannot be done in Caret since caret thresholds "above" values.  So, using this operation will allow the user to threshold greater than 0.95.

  • (19 June 2007) Remove all metric smoothing options except average

neighbors from the MetricFile.  All algorithms remain in BrainModelSurfaceMetricSmoothing.

  • (19 June 2007) Add

multi-fiducial mapping of paint volumes to surfaces.  These options include mapping to the PALS atlas' individual cases, mapping to the average fiducial surface, and in place of average to all cases a most commonly mapped ID for each node.

  • (19 June 2007) Fixed problem with paint "?" not properly enabled

on Display Control's Overlay/Underlay Surface page.

  • (18 June 2007) When creating a new Study, have user enter the

PubMed ID if it is available.  If the PubMed ID exists in another study, do not allow the user to create a study using the same PubMed ID.

  • (18 June 2007) Add provenance (submitter/originator) to Study

Meta Data File.

  • (18 June 2007) Fixed parsing of caret data file names that

contained "LR" for the structure.

  • (15 June 2007) Fixed reading of binary format latitude longitude

files.

  • (14 June 2007) Add "-surface-to-cerebral-hull" to caret_command

for generating a cerebral hull volume from a fiducial surface.

  • (13 June 2007) Add selection of nodes within a latitude/longitude

range on the Surface Region of Interest Dialog.

  • (13 June 2007) Fix volume handle finder handle selection so that

it uses stereotaxic coordinates which will work when the underlay volume is a different dimension than the segmentation volume.

  • (12 June 2007 Add -metric-or-shape-stat-kruskal-wallis to

caret_command which performs a Kruskal-Walllis (non-parameteric one-way ANOVA).

  • (12 June 2007) Increase number of surface outlines shown over

volume slices and move the controls from Display Control's Volume Settings page to a new page, Volume Surface Outline.

  • (12 June 2007) Rebuild QWT libraries due to new QT libraries

installed on 08 June.

  • (11 June 2007) Added a method to the foci projection file that

eliminates all foci not in a list of specified indices.  This will be used by WebCaret.

  • (11 June 2007) Changed the following caret_command operations so

that they only the name prefix is specified for all output files: "-metric-or-shape-stat-paired-t-test", "-metric-or-shape-stat-one-sample-t-test", "-metric-or-shape-stat-interhemispheric-clusters", "-metric-or-shape-stat-anova-one-way", "-metric-or-shape-stat-two-sample-t-test", "-metric-or-shape-stat-coord-diff".

  • (11 June 2007) Changed to version 5.510.
  • (11 June 2007) Fixed cell/and foci reports so that they appear on

top of the main window.  They were, for some reason, appearing behind the main window.

  • (08 June 2007) Switch to QT version 4.3.0.  Gulp.

Release Caret 5.51 (07 June 2007)

  • (07 June 2007) Changed version to 5.51.
  • (06 June 2007) Added "-metric-or-shape-set-column-name" to

caret_comand which sets the name of a column.

  • (06 June 2007) Added "-metric-or-shape-file-info" to caret_comand

which prints names and min/max values for all columns.

  • (06 June 2007) Added "-metric-or-shape-set-column-to-value" to

caret_comand which sets all values in a column to a scalar value.

  • (06 June 2007) Added "-metric-or-shape-create" to caret_comand

which creates a metric or shape file with specified number of nodes and columns.

  • (06 June 2007) Added "-metric-or-shape-correlation-map" to

caret_comand which creates a correlation map between two metric/shape files.

  • (05 June 2007) Added a page to www.wikipedia.org for CARET.
  • (04 June 2007) Added keyboard commands for panning an zooming

contours.

  • (30 May 2007) Modified algorithm that creates borders around

clusters so that it now creates borders around small clusters which it did not do in the past.  In addition, there is now an option to automatically project the new borders and borders are automatically displayed.

  • (29 May 2007) Add Surface ROI option that creates a border from

an ROI that represent the fundus of a sulcus or crown of a gyrus.

  • (24 May 2007) Fixed bug that borders were not displayed if they

were first enabled using the pop-up menu.

  • (24 May 2007) Add option to Draw Borders Dialog that

automatically projects a border immediately after the border is drawn.

  • (22 May 2007) Add -surface-roi-coord-report" to caret_command.
  • (18 May 2007) Add ability to read free surfer patch files which

had their format changed in free surfer version 3.0.5.

  • (17 May 2007) Add "-volume-histogram" to caret_command which

prints a histogram of the input volume to the terminal window.

  • (17 May 2007) Add "-volume-scale-percent-min-max-255" to

caret_command which rescales voxel values excluding  percentages of the minimum and maximum values.

  • (17 May 2007) Add "-volume-anatomy-peaks" to caret_command which

prints estimates of intensity values for CSF, gray, and white matter.

  • (09 May 2007) When cropping a volume, save the cropping

parameters to the parameters file.

  • (09 May 2007) Save gray and white peaks to the parameters file

when segmenting (it previously did this only for the GUI, not command line).

  • (07 May 2007) List the values of the estimated CSF, Gray, and

White peaks on the SureFit segmentation dialog.

  • (07 May 2007) When reading a Neurolucida file, use "SID"

attribute of a contour's <point> as the section number.

  • (04 May 2007) Remove use of vtkDecimateCaret and use

vtkDecimatePro instead.

  • (03 May 2007) Fixed problem with ID node by number

(Surface->Identify menu item) not placing green ID symbols on surface.

  • (01 May 2007) At start of surface flattening algorithm, enable

the display of borders needed due to 26 April change.

  • (30 April 2007) Add "Smooth" button to SureFit segmentation

dialog to smooth the histogram and help find gray/white peaks.

  • (30 April 2007) Improved consistency of volumes so that

crosshairs are at the center of a voxel.

  • (27 April 2007) Correct problem with foci name selections not

being saved to a scene.

  • (26 April 2007) Default the display of borders OFF.
  • (25 April 2007) Throw exception if reading a comma separated

value file is read and it is missing the "csvf-section-end" tag at the end of the last data section.

  • (25 April 2007) Fixed crash with View Current Files that occurred

if no surfaces were loaded.

  • (24 April 2007) Make improvements in algortithm that estimates

the gray and white matter peaks in an anatomy volume.

  • (23 April 2007) For statistical cluster finding algorithms,

generate a region of interest statistical report for each input/shape file.

  • (20 April 2007) For structure names allow a single character (L)

in addition to the full name (Left).

  • (20 April 2007) When reading a foci file in CSV format, if the

structure is not specified, allow the sign of the X-coordinate to imply the structure (minus implies left, positive implies right).

  • (19 April 2007) Add left-to-left and right-to-right coloring

selections for paint and RGB paint.

  • (19 April 2007) Add check to see if studies from a meta-analysis

already exist when working with Study Metadata.

  • (19 April 2007) When importing data from a meta-analysis file,

allow appending or replacement of existing study metadata.

  • (17 April 2007) Modify surface information reports so that the

surface extent is only for connected nodes.

  • (17 April 2007) Add option "-vc" to caret_file_convert to convert

between volume file formats.

  • (17 April 2007) Change version to 5.503.
  • (17 April 2007) Add button to color selection dialogs that allows

selection of commonly named colors as defined by the world wide web consortium.

  • (16 April 2007) Added import of

MicroBrightfield's Neurolucida XML files that contain contours and markers.

  • (12 April 2007) Add a page to SureFit Segmentation Dialog that

allows the user to set the type of volume files that the segmentation process will write.

  • (10 April 2007) Added Bias

Correction of Anatomical Volumes.  The algorithm was taken from AFNI's program 3dUniformize.

  • (10 April 2007) Added ID filtering of study meta-analysis

information on Identify Window.

  • (09 April 2007) Add new meta-analysis file which contains one

meta-analysis study and a list of the studies contained in the meta-analysis.

  • (06 April 2007) When adding studies contained meta-analysis, make

retrieval of data from PubMed optional.

  • (06 April 2007) Fix retrieval of Medical Subject Heading data

when retrieving Study Information from PubMed.

  • (06 April 2007) Add a "link" button next to PubMed ID in study

editor to show the web page for the study.

  • (06 April 2007) Show meta-analysis info for a study in the

Identify Window.

  • (06 April 2007) Add ability to delete a group of studies by name

on the Study Metadata Editor dialog.

  • (06 April 2007) Fix read of foci x-coord from a comma separated

value file.

  • (06 April 2007) When study metadata editor dialog is launched and

there are no studies, create an empty study so that the dialog is properly sized.

  • (05 April 2007) Added option on

SureFit Segmentation Dialog to generate topologically correct surfaces.  This option is off by default.  If turned on, a dialog informs users about issues and limitation of this option.

  • (05 April 2007) When generating a surface and maximum polygons is

selected, do not perform any polygon decimation.  Previously, if maximum polygons was selected, there was some polygon decimation performed if it could be done with very minimal or not change in the shape of the surface.

  • (04 April 2007) Fix naming of surface shape files produced by

SureFit segmentation method so that the file name contains the number of nodes.

  • (04 April 2007) Add range of values to data type labels on volume

rescale dialog.

  • (04 April 2007) Add -surface-information and

-surface-topology-disconnect-paint-nodes to caret_command.

  • (03 April 2007) Add a PubMed ID to each Caret file.  This ID

is entered on the File Menu->Save Data File Dialog.

  • (02 April 2007) Add a Link button next to the DOI/URL on the

Study Metadata Editor.  When pressed, it will use the DOI/URL to show the article in a web browser.

  • (02 April 2007) Add Meta-Analysis to Study Meta Data.
  • (02 April 2007) Save cell/foci highlighting to scene..
  • (29 Mar 2007) For Thesholding an Anatomical Volume into a

Segmentation Volume, an upper threshold was added, the thresholds are now floats, and allowed to have a floating point values.

  • (28 Mar 2007) Correct lighting problem with export to VRML files.
  • (28 Mar 2007) Correct iterations problem with Paired T-Test.
  • (26 Mar 2007) Enable reading of NIFTI volumes that are stored in

an analyze hdr/img file pair.

  • (26 Mar 2007) Add option to pop-up menu to project the border

under the mouse.

  • (23 Mar 2007) Changed reading of Caret data files in Comma

Separated Value File format so that the column names are case insensitive.

  • (22 Mar 2007) Added -volume-segment-mask-creation, which creates

a volume mask from a group of volumes, and -volume-mask-volume, which applies a mask volume to a volume file, to caret_command.

  • (22 Mar 2007) Added "Correct

Fiducial Surface Topology (Remove Handles)" to the Surface-Topology menu.  This operation will remove all topologial errors (handles) in the main window fiducial surface.  It does this by discarding nodes around handles and retessellating the surface.  While the resulting surface is topologically correct it is not necessarily anatomically correct.

  • (22 Mar 2007) When drawing 3D borders, allow the mouse to rotate

the surface if the ALT key is depressed.  This should help with drawing flattening and registration borders as it will allow the borders to be drawn on 3D (inflated, fiducial) surfaces instead of the flat map and the compressed medial wall surface.

  • (22 Mar 2007) Add selection of nodes that are crossovers to

surface region of interest dialog.

  • (21 Mar 2007) Add "-surface-topology-neighbors" which generates a

list of neighbors for each node in a topology file.

  • (20 Mar 2007) Fixed problem that occurred on some Linux

workstations with the Recording Dialog.  On some Linux workstations the function that reports if a file is writable always returns unwritable.

  • (19 Mar 2007) Add "Update Focus' PubMed ID if Focus Name Matches

Study Name" which updates the PubMed ID in the focus' study metadata link if the focus name is the same as the name of a study.

  • (19 Mar 2007) Add a "Fetch All PMIDs" button on the Study

Metadata Editor Dialog.  This will update all studies with valid PubMed IDs with data retrieved from www.pubmed.gov.

  • (16 Mar 2007) When retrieving PubMed Info from the PubMed

website, append year, volume, and pages to journal name.

  • (16 Mar 2007) Add Name and MESH (Medical Subject Headings) to

Study Metadata.  Remove URL and combined it with DOI since DOI should always go to the correct document.

  • (15 Mar 2007) Implemented left-on-left, right-on-right coloring

option for surface probabilistic atlas.

  • (14 Mar 2007) Added "Create Interpolated Borders" to the

Layers->Borders Menu.  This allows the user to create new borders that are interpolated between two selected borders.

  • (13 Mar 2007) Add a "Fetch"

button in the PubMed ID row on the Study Metadata Editor Dialog.  When pressed, it grabs the currently entered PubMed ID and queries the PubMed database for title, author, citation, DOI, and abstract and places the results into the currently edited study.

  • (12 Mar 2007) Fixed problem with foci disappearing when old study

data was moved from the foci file to the study metadata file.

  • (12 Mar 2007) Implemented the addition of a study metadata link

for volume files.

  • (12 Mar 2007) Modify caret_command's two-sample T-Test to have an

option of using pooled or unpooled variance.  Previously it always did unpooled variance.

  • (12 Mar 2007) Add "-volume-resize" to caret_command.
  • (12 Mar 2007) Speed up shuffling of metric columns.
  • (09 Mar 2007) Fix option on Volume Attributes Editor and Volume

Creation dialog for setting the attributes (dimension, spacing, and origin) of a volume.

  • (07 Mar 2007) For use with permuted metric/shape surface

statistics, add a metric file that shows the clusters.  The metric file contains two columns, the statistic and (1 - p-value).  Use (1- p-value) to threshold the clusters.  A new palette "plus_minus" was also added to assist with cluster display.

  • (07 Mar 2007) Link to Study Metadata Dialog should now be

properly initialized when there is an existing link.

  • (07 Mar 2007) Add information to the project cells/foci dialog

that informs user that the sign of the cell/focus is used to determine the associated hemisphere.

  • (06 Mar 2007) Add "Edit" buttons on spherical deformation dialog

that allow editing of the individual and atlas borders.  This allows the user to view the borders in a border file, change the names of borders, and/or delete borders.

  • (02 Mar 2007) Add one-way ANOVA

to caret_command.  Using two input files, comparing the results of a one-way ANOVA with a two-sample T-Test with pooled variance results in the exact same clusters and the F-Statistics equal to the square of the T-Statistic.

  • (02 Mar 2007) Eliminated print statement "unknown paint file tag:

tag-version" message printed when reading a paint file.

  • (01 Mar 2007) For foci identification in identify dialog and

filtering selection on the identify dialog change "Size" to "Extent".

  • (01 Mar 2007) Fixed selection of a study on the link to study

metadata dialog.  This is a QT issue as the signal cellChanged() was no longer emitted so the signal was changed to cellClicked().

  • (28 Feb 2007) Add "-metric-or-shape-copy-columns-to-new-file" to

caret_command.  This new command creates a new metric file from column copied from an existing metric file.

  • (28 Feb 2007) Add metric/shape in group difference, which

computes the difference between all possible column combinations, to caret_command.  Use the "-metric-or-shape-in-group-diff" option.

  • (27 Feb 2007) Fix use of optional inner and outer boundaries for

surface to volume conversion run with caret_command.

  • (27 Feb 2007) Add buttons to Study Metadata Editor Dialog that

allows selection of studies by name or title.

  • (27 Feb 2007) When deforming a coordinate file, preserve

structure, surface type, etc.

  • (27 Feb 2007) Add entries on deformation and apply deformation

map dialogs to set the node data file deformed column name prefix.

  • (27 Feb 2007) On apply deformation map dialog, add

"*.atlas.paint" to atlas file filter.

  • (26 Feb 2007) Fixed scrolling of volume slice spin boxes when

holding down the mouse button.

  • (26 Feb 2007) Fixed reading of NIFTI volume that required

rotation to become an LPI orientation.

  • (26 Feb 2007) Add "Bring All to

Front" and "Stack Windows" to the Window Menu.  "Bring All to Front", available on Mac OSX only, places Caret's windows on top of windows from any other applications.  "Stack Window" places all open dialogs/windows over the main window with a small offset.

  • (23 Feb 2007) Add filtering for all remaining study metadata

items.

  • (23 Feb 2007) When displaying a scene, assign colors to borders,

cells, and foci.

  • (22 Feb 2007) Add filtering for study table data on Identify

Dialog.

  • (22 Feb 2007) Add option on Display Control's Foci Page, "Show

Foci Pasted Onto 3D Surfaces" which "pastes" foci onto all 3D surfaces to help expose subcortical foci.

  • (22 Feb 2007) Correct Foci Color Key when foci are colored by

class name.

  • (21 Feb 2007) When loading files through the spec file dialog and

if there are foci (or foci projection) files selected and there are study metadata files but no study metadata files are selected, warn the user.  Also, list study metadata files when the foci filter button is selected on the Spec File Dialog.

  • (21 Feb 2007) When the name on a Foci Color Key is clicked, try

to find the corresponding study and display the study metadata in the Identify Dialog.

  • (21 Feb 2007) Automatically add a subheader when a new table is

created on the Study Metadata Editor Dialog.

  • (20 Feb 2007) Add filtering of study information on the Identify

Dialog.

  • (20 Feb 2007) Add filtering of foci information on the Identify

Dialog.

  • (20 Feb 2007) Fixed uploading of files to SuMS Database. 

This problem was a result of a bug that was supposed to have been fixed in QT 4.2.2 (See 15 Feb 2007) but was not actually fixed.

  • (15 Feb 2007) When reading cell/foci files and cell/foci

projection files, check for an invalid structure for a cell/focus.  If the structure is "invalid" set the structure to "right" if the X-coordinate is greater than zero or set the structure to "left" if the X-coordinate is less than zero.

  • (15 Feb 2007) Some cell/foci files were not having their

structure read correctly but it seems to now be fixed as a result of updating QT to QT 4.2.2.  This problems was found when unit testing of foci rendering failed.

  • (15 Feb 2007) Added unit testing comparison for cell & foci

files.

  • (14 Feb 2007) Updated QT to QT

4.2.2 since it is supposed to contain fixes to bugs that I had reported.  Unfortunately, not all the bugs they claim to have fixed are corrected and they have added new bugs such as a Q3FileDialog that is too large to fit on the screen. 

  • (14 Feb 2007) Fixed crash that occurred when the current node

coloring was used to create a new rgb paint column.

  • (12 Feb 2007) Corrected number of non-twin comparisons performed

in caret_command's -metric-or-shape-twin-comparison.

  • (09 Feb 2007) Add options on the foci sub pages to display foci

without a class assignment, foci without a color assignment, foci without a link to a study with keywords, and foci without a link to a study table subheader.

  • (09 Feb 2007) Change "Color" tab on D/C Foci page to "Name" since

foci colors are almost always the names of foci.

  • (09 Feb 2007) Add option to assign the class name to all

displayed foci.

  • (09 Feb 2007) Add option on D/C's Foci Main page to color foci by

focus name or by focus class name.

  • (08 Feb 2007) Add display control of foci based upon the linked

study's keywords and table sub header names.

  • (07 Feb 2007) Correct projection of foci to PALS atlas that broke

as a result of adding the new Study Metadata File.

  • (02 Feb 2007) Fix cleanup paint names when there are multiples of

an identical name.

  • (02 Feb 2007) Add deformation of cell/foci projection files.
  • (02 Feb 2007) Move some stuff from the MathUtilities class to the

caret_statistics library.

  • (01 Feb 2007) Add a new file, TextFile, for simpler reading and

writing of text files and comparison of text files.

  • (01 Feb 2006) Enable metric/shape files to be read and written as

comma separated value files.  Unfortunately, Microsoft Excel (prior to Excel 2007) limits the number of rows to 65536.  OpenOffice Calc is also limited to 65536 rows.

  • (31 Jan 2007) Fixed normalize distribution in a metric

file.  Modified normalization algorithm so that it works with a small number of values.

  • (30 Jan 2007) Correct deformation of Foci files.
  • (29 Jan 2007) Fixed deformation of probabilistic atlas files

(result of node attribute to gifti conversion).

  • (29 Jan 2007) Fixed reading of StudyMetaData file's that

contained StudyMetaDataTableSubHeader elements.  StudyMetaDataTableSubHeader was replaced with StudyMetaDataSubHeader when SubHeaders were added to pages.

  • (29 Jan 2007) Corrected problem with provenance being updated for

all studies when a StudyMetaDataFile was both read and saved.  The modification status was triggered when tables and figures were read and added to studies when the file was read.

  • (29 Jan 2007) Fixed writing of Comma Separated Value File that

resulted in elements being enclosed in double quotes when they did not need to be enclosed in double quotes.

  • (26 Jan 2007) Add new implementation of Volume Region of Interest

Operations which adds a new "wizard" dialog, additional voxel selection options, display of selected voxels, and additional operations on selected voxels.

  • (23 Jan 2007) Fixed P-Value generation for Levene's Test and

Metric T-Test, a result of 19 Jan change.

  • (22 Jan 2007) Add "-metric-or-shape-twin-comparison" to

caret_command for use with twin subject comparisons.

  • (19 Jan 2007) Rewrite and simplify some of the statistical code.
  • (19 Jan 2007) Slow mouse speed for panning of contours in view

and alignment modes.

  • (18 Jan 2007) Add generation of Root Mean Square (RMS) for metric

and shape files.

  • (18 Jan 2007) Reorganize the basic statistics and move it to

caret_common/StatisticUtilities.h/cxx.

  • (17 Jan 2007) Add item to Layers->Contours Menu to resample

all contours.

  • (17 Jan 2007) Enable Transformation Matrix Editor to apply a

matrix to main window contours and contour cells.

  • (16 Jan 2007) Print a count of the number of points in each

contour when reading a contour file.  This is used to find contours with an excessive number of points.

  • (16 Jan 2007) Corrected identification text for voxels which was

mistakenly show the identification data more than once.

  • (16 Jan 2007) The data type for study metadata table number,

subheader number, figure number, and page number were changed from integer to string since they may contain non-numeric characters.

  • (16 Jan 2007) Fixed scene bug that caused identified node symbols

to not be displayed.  This was a result of new identification code from 02 Jan 2007.

  • (12 Jan 2007) Add "Page Reference" to Study Metadata File and

update Study Metadata editor.

  • (11 Jan 2007) Rewrote the code that rotates a volume 90 degrees

clockwise about an axis looking from the positive end of the axis to the negative end of the axis.

  • (08 Jan 2007) Initial implementation of new Study Metadata File.
  • (08 Jan 2007) When loading a spec file turn off node highlighting

(blue) cross.

  • (02 Jan 2007) Redesign of

Identify Window.  The window now has tabs that show the identification text or a page that shows the identification filtering selections.  The filtering selections were previously on the window's toolbar.

Personal tools
Sums Database