Caret:Documentation/ChangeLog2008

From Van Essen Lab

Jump to: navigation, search

Change Log 2008

  • (16 Dec 2008) Add foci color list id to study collection file.
  • (15 Dec 2008) Changed "caret_command -deformation-map-apply" by

replacing METRIC with METRIC_AVERAGE_TILE and METRIC_NEAREST_NODE.

  • (10 Dec 2008) Fixed bug that caused caret_command to always turn

off the debug settings in the preferences file.

  • (07 Dec 2008) Add the foci SuMS items to the foci report.
  • (05 Dec 2008) Add "caret_command -study-metadata-file-validate"

to validate the contents of a study metadata file.

  • (04 Dec 2008) Add "caret_command -surface-foci-study-validate" to

find problems with foci linking to studies.

  • (04 Dec 2008) When writing a foci file in CSV format, insert a

space at the beginning of the area field if the area field begins with a number.  Otherwise, Excel will convert something like "9/6" into "6-Sep" and hose everything up.

  • (25 Nov 2008) Remove "Page Number" from Study Metadata Link

Dialog.  Ignore "Page Number" listed in any foci, foci projection, or study metadata link files.  "Page Number" conflicts with the "Page Reference" that may be associated with a study.

  • (24 Nov 2008) Added "caret_command

-surface-roi-node-areas".  Also added a page the Surface ROI Dialog to compute node areas.

  • (19 Nov 2008) Changed version

to 5.610.

  • (19 Nov 2008) For Surface->Measurements->Generate Distance

Surface A to Surface B, do not allow selection of column and automatically create the dx, dy, and dz columns.

  • (14 Nov 2008) Disable "Fetch from PubMed" button on Study

Metadata Editor if there are no studies.

Release Version 5.61  (12 Nov 2008)

  • (12 Nov 2008) Added Study Page Reference Page Number and Study

Page Reference Subheader to the Foci Report.

  • (12 Nov 2008) Added Study Page Reference Page Number and Study

Page Reference Subheader to the CSV Foci File Format.

  • (12 Nov 2008) Modify setting of class name with Table Subheader

Short Name to also use Figure Panel Description and Page Reference Subheader Short Name.

  • (11 Nov 2008) Add "caret_command -surface-distortion".
  • (10 Nov 2008) Verify structure in each of the input cooridnate

files used by the landmark identification algorithm.

  • (10 Nov 2008) Added study collection ID to study collection

editor.

  • (10 Nov 2008) Added a button to the study metadata editor that

allows selection of a study by the study's name.

  • (10 Nov 2008) Added FociList_ID to study collection file and

reorder items listed on study collection editor.

  • (10 Nov 2008) In foci report, provide additional information if

there are mismatched foci in a foci report.

  • (06 Nov 2008) Fixed writing of FreeSurfer Functional Data Files.
  • (03 Nov 2008) Fixed creation of new Study Collection so that the

studies are the correct "x" studies and not the first "x" studies.

  • (03 Nov 2008) "caret_command -color-file-create-missing-colors"

now accepts border, cell, or foci files.

  • (03 Nov 2008) Added foci counts to Foci Attribute Report.
  • (03 Nov 2008) Fixed ROI Text Report so that it shows the correct

coordinate file name.

  • (28 Oct 2008) In Foci Report, change "Study Name" label to "Study

Title" since it actually displays the title.

  • (28 Oct 2008) Fix label on Display Control Scene Page "Itentity"

to "Identify".

  • (28 Oct 2008) Add ZIP file filter for SuMS Dialog's upload files

selection.

  • (28 Oct 2008) In Foci Report, always show PubMed ID, even if it

does not link to a study.  Report foci whose name does not match a study name and PubMed ID's that do not match a study.

  • (14 Oct 2008) Correct processing of arguments for brainfish and

gaussian algorithms with "caret_command -volume-map-to-surface".

  • (13 Oct 2008) Fixed foci search when matching is none-of and the

attribute is empty.  Changed label on dialog for entering foci spatial search.

  • (10 Oct 2008) When adding a new foci search set, allow user to

choose location of where the new foci search set is inserted within the existing search sets.

  • (09 Oct 2008) Allow foci density to be computed in density per

cubic centimeter in addition to the current density per cubic millimeter.

  • (07 Oct 2008) Catch all errors during "caret_command -show-scene".
  • (07 Oct 2008) Fixed display of Label and File Button for Variable

List parameters in Caret Command GUI.

  • (07 Oct 2008) Fixed scene display.  If the previous scene

used an L-to-L R-to-R, the new scene did not display correctly.

  • (07 Oct 2008) Add Species to Foci Search.
  • (06 Oct 2008) Fix separation of study metadata file keywords that

are separated by "*"or "|".

  • (03 Oct 2008) Add "caret_command -surface-folding-measures".
  • (03 Oct 2008) Fixed bug with default parameters for command

"caret_command -volume-histogram".

  • (03 Oct 2008) Add optional computation of the volume displaced by

a surface to "caret_command -surface-information".

  • (03 Oct 2008) Allow editing of report in Surface Region of

Interest Dialog.

  • (03 Oct 2008) Fixed bug in Surface ROI Paint Statistical Report

that occurred if a paint region contained no nodes in the ROI.

  • (03 Oct 2008) Add previous directories to history section at top

of Text File Editor's Open and Save File Dialogs.

  • (02 Oct 2008) Modify Volume Resizing Dialog so that it updates

the cropping slices after the Apply button is pressed.

  • (01 Oct 2008) May have fixed crash during scene correction when

there was not a foci search page resulting from 22 Sep 2008 save selected foci search to scene change.

  • (30 Sep 2008) Add "-add-files-in-directory" option to

"-spec-file-create" that examines all files in the current directory to see if they are Caret data files using the file name's extension.  If the file is recognized as a Caret data file, it is added to the spec file.

  • (29 Sep 2008) Changed way classes static variables are

initialized in the caret_files directory.  This fixes an error where the linker was unable to locate a static variables from a class.

  • (23 Sep 2008) When reading a NIFTI volume file, allow sform_code

to have precedence over qform_code.

  • (23 Sep 2008) Add Foci Attribute Report to Layers->Foci menu.
  • (23 Sep 2008) List number of studies from which matching foci

originate on the Display Control's Foci Search page.

  • (23 Sep 2008) Corrected foci search attribute display when loaded

from a Foci Search File.

  • (22 Sep 2008) Save selected Foci Search in the Scene.
  • (22 Sep 2008) Fix Delete Foci Not Displayed Due to Display

Control Selection so that it functions if a cerebellum is in the Main Window.

  • (22 Sep 2008) Foci Report: Add option for only displayed

foci.  Add All On, All Off, and Core On buttons to foci attributes section.  Add All On and All Off buttons to paint attributes section.  Add scroll bars to entire dialog.

  • (19 Sep 2008) Fixed problem reading an NIFTI volume that had

qform set, but not sform set, and units other than millimeters.

  • (19 Sep 2008) Add "Attribute ID" to cells/foci.
  • (19 Sep 2008) Add assignment of AttributeID to "caret_command

-surface-foci-attribute-assignment" and to Layers Menu->Attribute Assignement.

  • (18 Sep 2008) If a topology file is loaded due to it being

specified in a coordinate file header, add the topology file to the spec file.

  • (18 Sep 2008) Variable Value's in Script Builder now have a

button which pops up a file dialog for easy file selection.

  • (17 Sep 2008) Fixed crash that occurred if a spec file was loaded

that contained coordinate files but no topology files.

  • (17 Sep 2008) Do not print message about CARET_DEBUG when caret

is started.

  • (17 Sep 2008) Fixed bug that occurred when reading foci files in

CSV file format.  Trolltech's QFile::peek() appears to now read one less character than requested.

  • (16 Sep 2008) When generating a cerebral hull volume, add 7

slices around all faces to prevent the dilation from hitting the edge of the volume file.

  • (16 Sep 2008) Added stereotaxic space to cell/foci report.
  • (16 Sep 2008) Fixed display of Areal Estimation Color Key.
  • (16 Sep 2008) Fixed selection of areal estimation column on

Display Control's Areal Estimation page.

  • (16 Sep 2008) Added species to study metadata.
  • (09 Sep 2008) Add new full hemisphere flattening to Surface Menu.
  • (09 Sep 2008) Fixed Segmentation Volume Topology Report which was

reporting an incorrect number of objects.

  • (08 Sep 2008) When applying cuts, also remove islands from the

surface.

  • (05 Sep 2008) Add generation of compressed medial wall so surface

generation process.

  • (04 Sep 2008) Fixed various compilation warnings that occur on

Linux, typically "no newline at end of file".

  • (04 Sep 2008) Fixed problem with execution of a caret script when

a comment contained a variable name prior to defining the value for the variable.

  • (04 Sep 2008) Add Study PMID to focus report.
  • (04 Sep 2008) Make all file filters available for GUI to add to

spec file command line command.

  • (04 Sep 2008) Fixed problem with the variable list parameter of

the Caret Command GUI when there was only a newline separating some text.

  • (03 Sep 2008) Modified algorithm that generates sulcal

identification that is used in automatic flatten and registration landmark generation.  Specifically, the depth tolerance for the hippocampal fissure (SUL.HF) was too low which resulted in no hippocampal fissure being identified.  An iterative process has been added that gradually reduces the depth tolerance so that the hippocampal fissure is identified.

  • (03 Sep 2008) If landmark border drawing of a segment from dorsal

part of hippocamapl fissure to the poster part of the corpus callosum while following negative curvature fails, draw using the geodesic method event though border may be incorrect.

  • (03 Sep 2008) Added new structures, "all", "cerebrum_cerebellum",

and "subcortical".

  • (03 Sep 2008) Add "caret_command -surface-foci-projection-pals"

which projects foci to the PALS atlas.

  • (02 Sep 2008) Only allow selection of transformation axes in the

main window.

  • (02 Sep 2008) Add volume cells and transformation cell files to

the cell color key.

  • (29 Aug 2008) Fixed Caret Script/Command problems involving

parameters enclosed in double quotes containing blank characters.

  • (29 Aug 2008) Fixed problems with cell/foci attribute assignment

when not all surfaces are provided.

  • (29 Aug 2008) When reading foci from a CSV format file, always

create a study meta data link.

  • (28 Aug 2008) Add creation of flattening and registration

landmark borders to Border Operations Dialog.

  • (28 Aug 2008) When using "caret_command

-surface-foci-attribute-assignment" allow the user to specify NONE for the coordinate and topology file of a surface that is not to be used for attribute assignment.

  • (27 Aug 2008) Added button to Color Key Dialog that clears the

highlighting.

  • (27 Aug 2008) Added "caret_command

-surface-border-create-average" which creates an average border file from two or more border files.

  • (26 Aug 2008) Added "Caret User's Email Archive" which displays

the archive of postings to the caret-users email list.

  • (25 Aug 2008) Added categoryID to Study Collections.
  • (25 Aug 2008) Fixed operation of Close button on SumsDB Dialog.
  • (25 Aug 2008) Fixed login to Sums that broke as a result of

recent QT library update.  Used to get "set-cookie" now get "Set-Cookie".

  • (25 Aug 2008) Added Study Table Number, Study Table Subheader,

Study Figure Number, Study Figure Panel, Study Page Number to Foci Report.

  • (22 Aug 2008) Added mslID, parentID, coreDataCompleted,

completed, and publicAccess to StudyMetaData.  Add entries on Study Metadata Editor but do not let users alter the values.

  • (21 Aug 2008) Update QT GUI libraries to 4.4.1.
  • (20 Aug 2008) Removed "Shell Command Window" from Window Menu.
  • (20 Aug 2008) Removed SuMS Tutoria and Altas menu items for the

Help Menu.

  • (20 Aug 2008) Removed "Surface Menu->Geometry Menu->Nearest

Spherical Border Distance" menu item.

  • (20 Aug 2008) Removed "Clear All or Part of XXX File" from

Attributes Menu->  Areal Estimation, Lat/Long, Metric, Paint, and Surface Shape menus.  These functionalities are now available on the File Menu->Manage Loaded Files.

  • (20 Aug 2008) Removed "Compute Average Separation Between Border

Points" from Layers->Borders Menu.

  • (20 Aug 2008) Fixed bug that failed to set the algorithm for

"caret_command -volume-map-to-surface-pals".

  • (20 Aug 2008) Replace Surface->Project to Plane Menu with a

dialog.  Also add projection options for X and Y planes.

  • (19 Aug 2008) Added "caret_command

-surface-foci-attribute-assignment" which is the command line equivalent of Layers Menu->Foci->Attribute Assignment.

  • (18 Aug 2008) Add "Update Focus' Class Name With Table Subheader

Short Names" to the Layers Foci Menu.  If a focus is linked to a table subheader, the focus' class name is replaced with the short name from the table subheader.

  • (15 Aug 2008) Added "caret_command_test -volume-topology-report"

to report topological information about segmentation volume files.

  • (15 Aug 2008) On Volume Menu->Segmentation->Reconstruct

Into Surface Dialog, if hypersmooth surface is requested, generate an inflated surface.

  • (15 Aug 2008) Allow mapping to RAW surface when mapping volumes

to surfaces.

  • (14 Aug 2008) Removed old Surface Region of Interest item from

Surface Menu.

  • (11 Aug 2008) Removed Study Meta-analysis file.
  • (08 Aug 2008) Add yoking to scenes.
  • (08 Aug 2008) Fixed Display Control bug that caused the node ID

symbols to become black when the Surface Miscellaneous page was displayed.

  • (08 Aug 2008) Fixed bug that failed to set the scene files

modification status when a scene was replaced.

  • (08 Aug 2008) Made corrections to volume to surface mapping's

interpolated voxel algorithm.

  • (07 Aug 2008) Fixed problems with some of the volume to surface

mapping algorithms that were not using the "voxel box size" correctly.

  • (05 Aug 2008) Added StudyCollectionFile for use by WebCaret.
  • (05 Aug 2008) Add transformation matrix to loaded file management

dialog.

  • (05 Aug 2008) Fixed use of Neighbor Box Size when mapping volume

to surface that broke during the 29 July voxel center revision.

  • (05 Aug 2008) Add new RGB Paint Selection Page to Display Control

Dialog.

  • (04 Aug 2008) When reading a file's header, convert the

"hem_flag" tag to "structure".  This problem was noticed when trying to project foci to the PALS atlas.

  • (04 Aug 2008) Enable Overlay in "Coloration Applies To" on

Display Control's RGB Paint page.

  • (30 July 2008) Added GIFTI Time Series File to the Open Data File

Dialog's list of file types.

  • (29 July 2008) Revised volume

processing so that the origin and any coordinates are at the CENTER of the voxel.

  • (29 July 2008) Fixed possible segmentation glitch.  Prior to

segmentation, an extra slice (padding) is added around all six faces of the volume.  If any of the face slices of the volume contained non-zero voxels prior to padding, these non-zero voxels were added to the padding.

  • (28 July 2008) Installed new MINC and NETCDF libraries on the Mac

OSX version of Caret in order to fix reading of MINC volumes on Mac Intel computers.

  • (25 July 2008) Add new coloring mode that blends the colors of

the three overlays.  It is selected near the bottom of the Display Control's Overlay/Underlay Surface page.

  • (25 July 2008) Fixed preservation of color and cell/foci

filenames when data read from comma separated value files.

  • (25 July 2008) Fixed some missing file type labels on Manage

Loaded Files Dialog.

  • (24 July 2008) Add Sums Color ID to ColorFile.  Add SuMS

Version Number and SuMS MSLID to foci/foci projection files.

  • (24 July 2008) Add Donna's modification for non-human species to

SureFit Segmentation algorithm.

  • (24 July 2008) Changed how Caret handles stereotaxic spaces and

species since these values are critical for operations such as segementation and automatic landmark border generation.

  • (23 July 2008) Fixed bug that caused Caret to hang when

displaying oblique volumes and the Display Control's Volume Settings page.

  • (22 July 2008) Transformation Matrix Editor Window - Fixed crash

that occurred when creating a new matrix initialized to the Main Window Surface transformation.

  • (21 July 2008) Added "caret_command -image-format-convert" to

convert images to different formats.

  • (21 July 2008) Fixed a bug that prevented the name of a volume

file from being reported if there was an error reading volumetric data.

  • (17 July 2008) Added "Generate Colors for Paints without Colors"

to Volume->Paint menu to generate colors for volume region (paint) names without corresponding area colors.

  • (15 July 2008) When identifying nodes, both the nearest node and

the nearest tile under the cursor are selected.  If both a node and tile are identified, use a node from the tile if the tile is nearer the viewer than the identified node.

  • (15 July 2008) Manage Loaded Files Dialog now has a button for

saving all files detected as modified and also updates the spec file.

  • (15 July 2008) Allow deletion of transformation data files

through the Manage Loaded Files Dialog.  Set structure when cell transform data files have a matrix applied so that they become surface cells.

  • (14 July 2008) Added a preliminary automatic landmark borders to

the SureFit segmentation algorithm.

  • (14 July 2008) Fixed default naming of volume files.
  • (14 July 2008) Use CTRL-M as a shortcut to launch the "Manage

Loaded Files" dialog.

  • (11 July 2008) Fixed writing of RGB volumes.
  • (11 July 2008) Corrected drawing

of volumes slices.  The volumes slices are now drawn by placing the voxel's coordinate in the center of the voxel.  Previously, voxels were draw as if the coordinate was at the corner of the voxel.

  • (10 July 2008) Added "caret_command -image-to-web-page" that

assembles a set of images into one or a set of web pages.

  • (09 July 2008) Corrected problem with Display Control's

Topography page selection of Eccentricity and Polar Angle.

  • (09 July 2008) Fixed crash when deforming a topography file.
  • (09 July 2008) Fixed setting of source and target directories on

Apply Deformation Map Dialog.

  • (09 July 2008) Fixed problems with saving histogram as an image.
  • (09 July 2008) Fixed problem with not mapping surface selected

when mapping volume to surface and using map to caret surface with atlas with only Average Fiducial Mapping selected.

  • (09 July 2008) When generating inflated, very-inflated, etc. from

fiducial, use the fiducial surface that is in the main window instead of the "active" fiducial surface.

  • (09 July 2008) When automatically aligning a surface after

multi-resolution morphing, add the name of the border projection and the bordedr projection file to the coordinate file's comment.

  • (08 July 2008) Added Tim's surface affine registration command.
  • (08 July 2008) Add previous data file directories to open and

save data file dialogs.

  • (03 July 2008) Add opacity to the surface.  Opacity is

controlled on the Display Control's Surface Miscellaneous page.  Draw VTK models prior to drawing the surface so that the VTK model can be seen when the surface opacity is lowered to allow transparency.  Otherwise the Z-buffer prevents one from seeing VTK models that are within the surface model.

  • (03 July 2008) Fixed resizing of main window when displaying a

scene with Window Positioning set to Use All Window Positions From Scene.

  • (03 July 2008) Fixed update of metric scaling column combo box on

Display Control's Metric Settings page.

  • (02 July 2008) Now version

5.601.

  • (02 July 2008) Add NIFTI GZIP as a volume type for segmentation.
  • (02 July 2008) Write PNG images as compressed when capturing an

image and saving to an image file. 

  • (01 July 2008) Add TIFF for writing of images.  TIFF

provides a lossless compression scheme (small file with no reduction in quality).

  • (30 June 2008) Add "-RANDOMSEED" option to all caret_command

operations so that the random seed can be set for statistical operations.

  • (30 June 2008) File Open Dialog - If both a paint and area color

files are selected for reading, read the color file first so that a message stating "no area colors" loaded is not displayed.  Perform similar prioritizing for other color files and study metadata.

  • (30 June 2008) Add /Volumes to File Dialog.  Do not allow

consecutive duplicate entries in directory history combo box.

  • (30 June 2008) After cleaning up paint names, update the GUI.
  • (10 June 2008) Fixed path for caret_command when used by Command

Executor.


Release Version 5.6 (09 June 2008)

  • (09 June 2008) Fixed Help Menu->Go To SuMS Database menu item.
  • (09 June 2008) Updated WU IFH file now that its header file

contains the byte order.  Previously, all IFH volumes were big endian.

  • (29 May 2008) Version 5.6
  • (29 May 2008) Enable the

writing of GIFTI formatted data files.  GIFTI is a standard file format for the exchange of surface-based neuroimaging data.  It was created by the developers of AFNI/SUMS, BrainVisa, BrainVoyager, Caret, CRkit, FreeSurfer, and VisTrails.  Caret is able to read and write GIFTI format coordinate, functional, label, shape, surface, and topology files.  For more information visit http://www.nitrc.org/gifti.

  • (29 May 2008) Corrected problem with Create Spec File Dialog not

using the correct directory.

  • (28 May 2008) Add SuMS ID number, repeat number and parent cell

base ID to Cells, Foci, Cells/Foci Projections for use by SuMS.

  • (28 May 2008) View Current

Files (on the File Menu) is now Loaded File Management.  Not only can the user view and delete files in memory, but the user can also remove columns from node attributes files and also check the modification status of files and save the files.

  • (23 May 2008) Added "caret_command -image-resize" to resize

images including settings the resolution (dots per inch/meter).

  • (22 May 2008) Add a search coordinate to each focus.  When

foci have been projected to the PALS atlas, the foci may be in several stereotaxic spaces.  So, during projection to the PALS atlas, a focus' search coordinate is always set to the position of the focus on a FLIRT surface.  During normal foci projection (to a surface, not PALS), the search coordinate is set to the projected position.  Remove spatial search surfaces from the Foci Search page on the Display Control.

  • (20 May 2008) Added "caret_command -volume-map-to-vtk-model"

which maps a functional volume to a VTK surface model file.

  • (19 May 2008) Do not perform surface identify operations when

surface viewing mode is hidden.

  • (19 May 2008) Fixed recent bug in caret_command that prevented

locating the caret home directory.

  • (16 May 2008) Make the default size of the caret command executor

dialog larger.

  • (16 May 2008) Added "caret_command -scene-create" which is used

to create scene files on the command line.

  • (16 May 2008) Added "caret_command

-surface-register-prepare-slits".  This command is used prior to spherical registration when an interspecies registration is performed and there are functional areas not present in one species that are present in the other.

  • (15 May 2008) Add "Layers->Borders->Duplicate Border By

Name" that makes a copy of a border with a new name.

  • (14 May 2008) Fixed problem with "Links (No Backside)" drawing

mode.

  • (12 May 2008) Added "caret_command -surface-border-cutter" which

cuts surfaces using border projections.

  • (12 May 2008) Added a new drawing mode "Tiles With Lighting No

Backfacing Tiles".  With this drawing mode, the backsides of tiles are not drawn which makes missing tiles appear as holes in the surface.

  • (07 May 2008) Add "-surface-inflate" to caret_command for

inflating surfaces.

  • (05 May 2008) Added support for reading GIFTI data files that use

NIFTI_INTENT_NODE_INDEX that indicate the file contains data for only a subset of nodes.

  • (05 May 2008) Add support for multiple transformation matrices

with GIFTI NIFTI_INTENT_POINTSET (coordinate) data arrays.

  • (01 May 2008) Fixed bug in metric clustering so that it ignores

disconnected nodes.  This was found during one-way ANOVA testing.

  • (01 May 2008) Fixed bug in statistical clustering.  If a

metric file was used it would cause a crash.

  • (01 May 2008) Disabled generation of "Sulci ID" paint column in

the SureFit algorithm.

  • (01 May 2008) Added option to GUI and command line

multi-resolution morphing to align the resulting surface to standard orientation.  It requires a border projection that identifies the central sulcus.

  • (25 Apr 2008) Add the "-CHMOD <permissions>" parameter to

ALL caret_command operations.  This allows the user to set the permissions on all files written during the commands operations.

  • (25 Apr 2008) Aded "caret_command -spec-file-directory-clean"

which finds files in the current directory, but that are not in the spec file, and either deletes the files, moves the files, or lists the files.

  • (23 Apr 2008) When creating standard or analysis grid borders,

clear out any existing borders.

  • (18 Apr 2008) Add "caret_command -spec-file-clean" which takes a

spec file name as an argument and removes all entries from the Spec File for which the corresponding file does not exist.

  • (15 April 2008) When writing paint, shape, and area color files

in the SureFit Segmentation Algorithm, give them the description "Initial" rather than the default such as "paint_file_##".

  • (14 April 2008) Rewrote class that runs external programs so that

it is consistent across platforms and can capture output.

  • (09 Apr 2008) Fixed a bug in the volume to surface mapper that,

on occaision, displayed the error "No Volume Provided" when mapping a volume that was stored in a file.

  • (08 Apr 2008) Add the "-CHDIR <directory-name>" parameter

to ALL caret_command operations.  When this parameter is specified, caret_command will run in the specified directory.  It does not affect the current directory of the shell that runs caret_command.

  • (04 Apr 2008) When creating the analysis grid borders, only warn

if the surface is not flat.  After creating the analysis grid borders, turn border display on.

  • (01 Apr 2008) Added "Caret Help (Online)" to the Help Menu. 

This displays the very latest help information from the Caret website.  This help information may be for a version of Caret that is newer than the version the user is running.

  • (01 Apr 2008) Add "caret_command -file-subsitution" which finds

and replaces text in a file.

  • (18 Mar 2008) Add an erase mode to the Draw Border Update

Dialog.  This new mode is used to erase part of a border.

  • (18 Mar 2008) Modify reading of CSV file so that it reads Unicode

instead of ASCII.

  • (17 Mar 2008) Correct update of Foci Attribute Assignment when

paint files are loaded.  Add Cerebellum surface selection to Foci Attrribute Assignment Dialog.

  • (17 Mar 2008) Eliminated warning about modified palette when

trying to create a new scene.

  • (14 Mar 2008) Add "Short Name to Foci Class" button to Study

Table Sub Header.  If pressed any foci linked to this Sub Header have their class changed to the Sub Header's Short Name.

  • (12 Mar 2008) Added a button to create a new search by copying an

existing search to the Display Control's Foci Search page.  Also change the "Search Number" label to a button so that a search can be selected by name.

  • (11 Mar 2008) Default new Foci Search Categories to ALL.
  • (11 Mar 2008) Fixed bug so that all vocabulary files are listed

on the View Current Files Dialog.

  • (11 Mar 2008) Modified Display Control's Scene Page's Transfer

Identify Filters so that they may be transferred to the current Identify Window.

  • (11 Mar 2008) Corrected problem with initialization of Foci

Spatial Search Surfaces when the spec file is changed.

  • (11 Mar 2008) Added a 2mm FLIRT stereotaxic space.
  • (11 Mar 2008) Fixed a crash that occurred when a scene was

created after deleting all surfaces of a specific hemisphere.

  • (11 Mar 2008) Fixed problem with cerebellum volume/surface

interaction.

  • (10 Mar 2008) Correct origins for some 711* stereotaxic spaces.
  • (07 Mar 2008) Added "caret_command

--surface-align-to-standard-orientation" which aligns a flat or spherical surface to standard orientation.

  • (07 Mar 2008) Fixed bug with flat surface alignment.  It was

failing to translate the surface so that the ventral tip of the central sulcus was at the origin. 

  • (06 Mar 2008) Added "caret_command_test -volume-file-merge" which

combines volumes representing left and right hemispheres into a single volume file.

  • (06 Mar 2008) Fixes for proper coloring of multiple probabilistic

atlas volumes or when changing probabilistic atlas volumes.

  • (05 Mar 2008) Fixed display of cerebellum surface selection on

unproject foci to volume dialog.

  • (03 Mar 2008) Add foci structure to ID window filtering.
  • (03 Mar 2008) Add highlighting for probabilistic atlas color key.
  • (03 Mar 2008) Do not report table metadata when focus color

selected on foci color key dialog.

  • (03 Mar 2008) Add Cerebellum to

PALS atlas for functional mapping and stereotaxic foci projection.

  • (03 Mar 2008) Controls have been added to the Display Control's

Surface Misc page that allows selection of the left, right, and cerebellar surfaces used during surface and volume interaction.

  • (27 Feb 2008) Add Draw Border Update to the Layers->Borders

Menu.  This menu item allows the replacement of a segment in a border

  • (25 Feb 2008) Fixed display of RGB Paint data so that underlaying

data is displayed when RGB is (0, 0, 0).

  • (22 Feb 2008) Add caret_command "-image-insert-text" and

"-image-combine".

  • (22 Feb 2008) Change inputs to "caret_command -show scene" so

that user may choose how images of multiple windows are assembled.

  • (22 Feb 2008) Fixed problem with Map Volume To Surfaces that

showed both Metric and Paint options when mapping to Caret Surfaces with PALS atlas.

  • (20 Feb 2008) Change "Layers->Foci->Delete Foci Not

Displayed on Main Window Surface" to "Delete Foci Not Displayed due to Display Control Selections".  It now deletes all foci that are not displayed due to Display Control Selections with a possible popup to also remove those not on the Main Window Surface.

  • (20 Feb 2008) When identifying a focus, link Area, Geography, and

ROI to Vocabulary.

  • (20 Feb 2008) Change foci attribute assignment dialog so that it

is non-modal and add an option to clear the attribute.

  • (20 Feb 2008) Add Focus ROI to focus search.
  • (20 Feb 2008) Add Focus ROI and Comment to Name Selection Dialog

data types.

  • (20 Feb 2008) Fix highlighting of volume foci (foci are

highlighted by clicking the color bar in the foci color key).

  • (19 Feb 2008) Add foci comment to foci search.
  • (19 Feb 2008) Discovered that MNC volumes written on Microsoft

Windows cause the MNC API to abort when reading the file on a Apple Macintosh with an Intel processor.  This problem will not be fixed.  The solution is to write the volume in a different format, such as NIFTI on Windows, and then transfer the file to a Macintosh.

  • (18 Feb 2008) Add an interpolation method to volume resampling

(Edit Volume Attributes Dialog or caret_command) so that paint and probabilistic volumes can be resampled.

  • (18 Feb 2008) Surface Region of Interest Dialog: rearrange

selection page a little bit and set the style to modern style to reduce size of dialog on Macs.

  • (18 Feb 2008) Add "-surface-border-reverse" to caret_command to

reverse the order of links in a border.

  • (15 Feb 2008) Fixed crash that occurred when toggling volume

probabilistic atlas areas.

  • (14 Feb 2008) Changed "caret_command

-surface-sulcal-named-all-identification" so that it assumes volume files listed in the input CSV file are located in the same directory as the input CSV file.

  • (14 Feb 2008) Add "Transfer Identity Window Filters" to the

Display Control's Scene page.  Pressing this button allows the user to choose a scene and then the Identity Window Filters are transferred from this scene to all of the scenes selected on the Display Control's scene page.

  • (14 Feb 2008) Add Ontology Source and Term ID to Vocabulary.
  • (13 Feb 2008) In the Identify Window, for PubMed ID, show only

the PubMed ID, not the full URL.

  • (13 Feb 2008) When creating spec and scene files from selected

scenes, add proper filename extensions, if needed.

  • (13 Feb 2008) Add Labels to foci search parameters.  Add

Stereotaxic Space, Data Format, and Data Type to Foci Search.  Replace "Apply Search" button with "Search All" and "Search Displayed" buttons.

  • (13 Feb 2008) Added "-volume-prob-atlas-to-functional" and

"-volume-file-combine" to caret_command.

  • (04 Feb 2008) Add region of interest category to foci.
  • (04 Feb 2008) Add using the the image on the clipboard as the

captured image on the Image Capture Window.

  • (01 Feb 2008) Fix problems with selection of a Selection File

column.

  • (31 Jan 2008) Improved Image

Capture Window is compelete.

  • (31 Jan 2008) Add additional windows to Capture Image of Image

window.

  • (31 Jan 2008) Add capture of Main Window and all Open Viewing

Windows into a composite image to the Capture Image of Window Dialog.

  • (30 Jan 2008) Add option to automatically crop the captured image

to the Capture Image of Window Dialog.

  • (30 Jan 2008) Add option to modify the captured image's size on

Capture Image of Window Dialog.

  • (30 Jan 2008) Removed Save As Image button from Display Control

since an image of the Display Control can be captured using the File Menu->Save Window as Image Dialog.

  • (30 Jan 2008) Update dialog for capturing Main Window images by

adding ability to capture image of Main Window, any Viewing Window, and some of the common Dialog Windows.

  • (30 Jan 2008) Replace Image Editor's Resize Dialog with one that

allows the user to set the size of the image in cm, inches, or mm and the resolution of the image (pixels per cm/inch/mm).

  • (30 Jan 2008) Fixed writing of multi-brick paint volumes which

requires synchronizing the region names of all of the volumes.

  • (29 Jan 2008) Add border report options to caret_command's

"-surface-border-variability".

  • (28 Jan 2008) On Display Control's Surface Shape Settings page,

default the color mapping column to the highest priority selected surface shape column.

  • (28 Jan 2008) Fixed reading and writing of Surface Vector Files

in binary format.

  • (28 Jan 2008) Fixed selection of surface vector file data on the

Display Control Dialog.

  • (28 Jan 2008) ZIP NIFTI volumes when compress checkbox is checked

on the Save Data File Dialog.

  • (25 Jan 2008) Add Foci Density to Functional Volume to the

Layers->Foci menu.

  • (25 Jan 2008) Fixed problem with slow drawing of functional

volumes.

  • (25 Jan 2008) Added a button to the color editor for changing the

name of the selected color.

  • (25 Jan 2008) Fixed file filter used when choosing a volume on

the surface to volume dialog.

  • (25 Jan 2008) Changed foci uncertainty limits to RGB paint so

that nodes without nearby foci are assigned the color (-1, -1, -1) which is the RGB Paint "clear" color that allows the underlay to show.

  • (25 Jan 2008) Fixed problems with layout of RGB information in

the Identify Window.

  • (24 Jan 2008) Added "Resize Viewing Windows" to the Windows

Menu.  This allows the user to resize all of the viewing windows so that the graphics area displaying the brain models is same size as one of the viewing windows' or the Main Window's graphics area. 

  • (24 Jan 2008) Fixed crash of cell/foci report dialog that

occurred if a cell's study info index was invalid.

  • (23 Jan 2008) Add "Unproject Foci to Volume" to the

Layers->Foci menu that unprojects foci to left and right surfaces in order to set the volume coordinates for the foci.

  • (23 Jan 2008) Eliminated volume

foci.  Foci loaded as a foci or foci projection file will show up on volume slices.  This change was made so that all foci (either on the surface or on volume slices) can be controlled and searched on the Display Control Dialog.

  • (23 Jan 2008) Add additional foci search options for Study

Authors, Study Name, and "ALL".

  • (22 Jan 2008) When viewing windows 3-10 are opened, set their

size to the size of viewing window 2 if it is open.

  • (22 Jan 2008) Fixed layout problem on Display Control's Foci

Search page that placed the spatial search surfaces at the bottom of the page after a large amount of empty space.

  • (22 Jan 2008) Fixed display of identification information for

volume foci.

  • (22 Jan 2008) On data type selection pages, show the data types

in the model selection overlay control.  When going to a data type selection page, set the model overlay control to the highest priority overlay that is set to the data type.

  • (22 Jan 2008) Fixed mistaken appending of ".cell" when saving a

foci file.

  • (22 Jan 2008) Correct display of foci without keywords or link to

a study.

  • (22 Jan 2008) When adding new Subheaders to a Table or Page

Reference in the Study Metadata Editor, automatically initialize the Subheaders number to the number of Subheaders in its parent Table or Page Referrence.

  • (18 Jan 2008) Added new Surface Region of Interest Dialog. 

This fixes problems with the previous ROI dialog being too tall on some low-resolution displays and allows the user to choose the coordinate and topology files for node selection and operation.

  • (18 Jan 2008) Added button to Study Meta Data Editor that deletes

all studies that are not linked by the following file types: Areal Estimation, Cells, Deformation Field, Foci, Geodesic, Lat/Lon, Paint, Rgb Paint, Surface Shape, Surface Vector, Topography, and Vocabulary.

  • (17 Jan 2008) Fixed display of surface shape colorbar.
  • (17 Jan 2008) Add Foci Density to Metric Conversion to the Layers->Foci

menu.

  • (15 Jan 2008) Add a Foci Search page to the Display Control Dialog. 

This page allows the user to search foci for various attributes and display only those foci meeting the search criteria.

  • (15 Jan 2008) Modify Display Control Dialog's popup menu so that overlays

and the underlay can be selected.

  • (08 Jan 2008) Display border names and colors, cell classes and colors, and

foic colors, classes, names, keywords, and tables alphabetically on the Display Control Dialog.

  • (08 Jan 2008) When performing metric animation (on D/C metric misc page)

and debug is on, add a caption to each image identifying the image's metric column.

  • (07 Jan 2008) Fixed problem with using the context sensitive mouse for

identifying cellls, foci, and borders.

Personal tools
Sums Database