Caret7:Development/UserInterfaceDesign

From Van Essen Lab

Revision as of 16:38, 9 August 2011 by Elam (Talk | contribs)
Jump to: navigation, search

Contents

Caret7 User-Interface Design

Main Window

  • (JH) Should there be a viewer in the main window? Similar to AFNI/GIMP, the main window would be used for operations. By default, the contents of the main window is the identification panel (contents of identification window in Caret5/6). When the user selects an operation (ie: draw border) from a menu, the controls for entering the name of the border, setting the color, etc. appear in the main window. The identification panel will always reappear in the main window anytime an identification operation occurs or via a toolbar button. Viewing windows are accessed via toolbar buttons (1, 2, 3, etc) in the main window's toolbar.

Menus

  • Caret Menu (Apple Only)
    • About Caret
    • Quit
  • File Menu
    • Preferences
    • Set Current Directory (needed? Opening a Spec File sets the current directory to the directory containing the SpecFile): Might be useful if you don't want to do a spec file (e.g. you are loading a few files for a specialized task) --Matt
    • Open File (selects supported files for opening including the Spec File).
    • Open Previous Spec Files (goes to submenu).
    • Close Spec File.
    • Manage/Save Loaded Files.
    • Capture Images.
    • Exit (not on Apple).
  • Data Menu
    • Annotation Operations
    • Border Operations
    • Connectivity Operations
    • Foci Operations
    • Label Operations
    • Metric Operations
    • Shape Operations: Combine with metric --Matt
    • Study Operations
    • Map Surface Data to Volume
    • Map Group Volume via Atlas to Surface Data: Is this used? --Matt
    • Map Individual Volume to Surface Data.
  • Surface Menu
    • Identify Node/Triangle (possibly move to Identify Window)
    • Information
    • Geometry Operations
    • Region of Interest Operations
    • Registration Operations
    • Topology Operations
  • Volume Menu
    •  ?? ROI options would be good --Matt
  • Window Menu
    • Viewing Window 2
    • Viewing Window 3
    • Viewing Window 4
    • Viewing Window 5: Need more than 5 (probably at least 8: 4 on each of two screens) --Matt
    • Identify
    • Run Command
    • Bring All to Front
  • Help Menu
    • About Caret (not on Apple)
    • Help (Online)
    • Search Help (Online)

Keyboard Commands

Individual menu items can be activated using a CTRL (Apple) key combined with another key. For example, CTRL-O to display the Open Dialog.

Status Bar

Is the status bar needed? It does display the mouse function.

Viewing Windows

Viewing Window Toolbar

Yoking

Currently, yoking couples the view orientation to that in the main window.

Toolbar

  • (JH) Standard view buttons. For single hemisphere viewing should the buttons contain L, and M for lateral and medial. When yoked, pressing L or M would switch to lateral or medial views in all yoked windows. For whole brain views, should L and R for left and right be displayed?

Whole Brain

Single Surface

Volume Slices in One or More Planes

(JE) Is the idea here to show one plane at a time in 2D and all three (all Axis) in 3D (orthogonal to each other)? It would be helpful if you could select more than one plane to have a view of 2 or 3 2D planes (or 2 3D planes)

Volume Slices Montage in One Plane

  • (MG) I don't think "All Axes" would work for montage.

Volume Slice in an Oblique View

  • (JH) How should oblique volume viewing operate? Should there be controls to set the stereotaxic coordinate *(millimeters) around which rotation occurs and the distance (millimeters) of the slice from the rotation point along a vector that points to the user?
  • (MG) I don't quite understand the volume slice in oblique view. Shouldn't this have axial, coronal, sagittal options? Why does it have L R A P D V X? I thought we had agreed that to manipulate 2D oblique view, the user would grab the corners of the slices in the 3D all structure view. The rotation should happen around the current slice center (the user can translate the slices according to a "slices P # C: # A: #).

Viewers

Viewers provide a view of the data. Viewers from Caret5 and Caret6 include:

  • Suface
  • Surface and Volume (Caret5)
  • Orthogonal Volume Slice
  • Orthogonal Volume Slice All displays three orthogonal slices and a surface) (Caret5)
  • Oblique Volume Slice (Caret5)
  • Montage Volume Slice (Caret5)
  • All Structures (Caret6)

Pop-Up Menu

Caret5 contained a pop-up menu accessed by clicking the right mouse button (or Control-click on Mac). It this needed? Did it ever get used?

I do not use it --Matt.

Personal tools
Sums Database